Symptômes

Symptôme 1

Lorsque vous essayez d’exécuter un rapport dans Microsoft Dynamics CRM 3.0, le message d’erreur suivant s’affiche :

La demande a échoué avec l’état HTTP 401 : non autorisé.

Lorsque vous essayez d’exécuter un rapport dans Microsoft Dynamics CRM 4.0, le message d’erreur suivant s’affiche :


Erreur
Une erreur s’est produite. Essayez à nouveau cette action. Si le problème persiste, vérifiez la Communauté de Microsoft Dynamics CRM pour les solutions ou contactez l’administrateur de votre organisation Microsoft Dynamics CRM. Enfin, vous pouvez contacter le Support Microsoft.



Lorsque vous essayez d’exécuter un rapport dans Microsoft Dynamics CRM 2011, le message d’erreur suivant s’affiche :

Erreur de création de rapports
Le rapport ne peut pas être affiché. (rsAccessDenied)


Avec DevErrors, activation, vous recevez une erreur similaire aux messages suivants :

Description de l’erreur :

Les autorisations accordées à l’utilisateur « NT AUTHORITY\NETWORK SERVICE » sont insuffisantes pour effectuer cette opération.



Détails de l’erreur :

Les autorisations accordées à l’utilisateur « NT AUTHORITY\NETWORK SERVICE » sont insuffisantes pour effectuer cette opération.


Symptôme 2

Lorsque vous essayez d’ajouter un rapport dans Microsoft Dynamics CRM 3.0, le message d’erreur suivant s’affiche :


Erreur du chargement du rapport
Une erreur s’est produite en essayant d’ajouter le rapport à Microsoft CRM. Essayez de l’ajouter à nouveau le rapport. Si le problème persiste, contactez votre administrateur système.


Avec DevErrors activée, vous recevez le message d’erreur suivant :

Erreur du serveur dans l’Application '/'.
Exception de type Microsoft.Crm.CrmException a été levée.


Lorsque vous essayez d’ajouter un rapport dans Microsoft Dynamics CRM 4.0 ou Microsoft Dynamics CRM 2011, le message d’erreur suivant s’affiche :

Une erreur s’est produite en essayant d’ajouter le rapport à Microsoft Dynamics CRM. Essayez à nouveau cette action. Si le problème persiste, vérifiez la Communauté de Microsoft Dynamics CRM pour les solutions ou contactez l’administrateur de votre organisation Microsoft Dynamics CRM. Enfin, vous pouvez contacter le Support Microsoft.


Code d’erreur : 0x80048298


Cause

Ce problème se produit car le compte de sécurité pour le pool d’applications CRMAppPool ne dispose pas de l’éditeur pour le rôle de Microsoft Dynamics CRM dans le Gestionnaire de rapports.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Trouver l’utilisateur. Pour ce faire, procédez comme suit :

    1. Sur le serveur Microsoft Dynamics CRM, cliquez sur Démarrer, sur exécuter, tapez compmgmt.msc /s, puis cliquez sur OK pour ouvrir la gestion de l’ordinateur.

    2. Développez Services et Applications, développez Gestionnaire des Services Internet (IIS), développez Pools d’applications, droit CRMAppPool, puis cliquez sur Propriétés.

    3. Dans la boîte de dialogue Propriétés de CRMAppPool , notez la valeur dans la zone prédéfini sur l’onglet identité .

  2. Accorder à l’éditeur pour le rôle de Microsoft Dynamics CRM pour l’utilisateur identifié dans les étapes précédentes. Pour ce faire, procédez comme suit :

    1. Tapez l’adresse suivante dans la barre d’adresses dans Microsoft Internet Explorer, puis cliquez sur Go pour ouvrir le Gestionnaire de rapports Reporting Services :

      http://SRSServer/ReportsRemarque : SRSServer est un espace réservé représentant un nom réel d’un serveur Microsoft SQL Server Reporting Services.

      Remarque : Si vous ne pouvez pas vous connecter à Reporting Services, consultez http://technet.microsoft.com/en-us/library/bb630430.aspx.

    2. Cliquez sur le dossier de nom de société de Microsoft Dynamics CRM.

      Remarque Le nom de la société de Microsoft Dynamics CRM semblable à la suivante :

      CRM_Company_Name_MSCRM

    3. Dans l’onglet Propriétés , cliquez sur sécurité.

      Remarque  Pour SQL Reporting Services 2008, passez votre souris sur le dossier, cliquez sur la flèche déroulante et sélectionnez sécurité.

    4. Vérifiez si l’utilisateur qui a trouvé à l’étape 1 est répertorié avec le rôle d’éditeur pour Microsoft CRM .

      Remarque Si Microsoft Dynamics CRM et SQL Reporting Services sont sur le même serveur et que l’identité CRMAppPool est en cours d’exécution en tant que SERVICE réseau, le compte NT AUTHORITY\NETWORK SERVICE doit avoir le rôle d’éditeur pour Microsoft CRM . Si Microsoft Dynamics CRM et SQL Reporting Services sont sur des serveurs distincts, et que l’identité CRMAppPool est en cours d’exécution en tant que SERVICE réseau, le < domaine > \ < serveur_crm > compte de $ doit avoir le rôle d’éditeur pour Microsoft CRM . Le < domaine > \ < serveur_crm >$ compte peut soit recevoir le rôle d’éditeur pour Microsoft CRM directement ou en étant un membre du SQLAccessGroup dans Active Directory et en accordant le SQLAccessGroup le rôle d’éditeur pour Microsoft CRM .

      Remarque Si l’utilisateur n’est pas répertorié, cliquez sur Nouvelle attribution de rôle.
      Dans la zone nom d’utilisateur ou de groupe , tapez le nom de l’utilisateur que vous avez noté à l’étape 1c.

    5. Activez la case à cocher de éditeur pour Microsoft CRM , puis cliquez sur OK.

    6. Dans Microsoft Dynamics CRM 2011, les rapports de boîte de sont stockés dans le dossier SharedReports. Par conséquent, vous devez également vous assurer de que les autorisations sont ajoutées à ce dossier, si les utilisateurs ne peuvent pas afficher de rapports. Lorsque les rapports sont téléchargés vers Microsoft Dynamics CRM 2011, ils sont publiés dans le dossier Organization_MSCRM de cette organisation.

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