Symptômes

Lorsque vous essayez d’installer ou de mettre à niveau un client Microsoft Dynamics CRM pour l’ordinateur de Microsoft Office Outlook, le message d’erreur suivant s’affiche :

Échec de l’action Microsoft.Crm.Config.Client.InstallAbpAction.

L'accès est refusé. (Exception à partir de HRESULT : 0 x 80070005 (E_ACCESSDENIED))

En outre, vous recevez un des messages d’erreur suivants.

Message d'erreur 1Lorsque vous installez un client Microsoft Dynamics CRM 4.0 pour un ordinateur Outlook, le message d’erreur suivant s’affiche dans le journal de configuration :

12:58:46 | Erreur | Exception de configuration. System.Exception : Échec de l’Action Microsoft.Crm.Config.Client.InstallAbpAction. --->
Exception System.UnauthorizedAccessException : L’accès est refusé. (Exception à partir de HRESULT : 0 x 80070005 (E_ACCESSDENIED))

à System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal (Int32 errorCode, IntPtr errorInfo)

à Microsoft.Crm.Config.Client.InstallAbpAction.Do (IDictionary parameters)

à Microsoft.Crm.Setup.Common.Action.ExecuteAction (Action action, IDictionary paramètres, Boolean undo)

---Fin de la trace de pile d’exception interne---

à Microsoft.Crm.Setup.Common.Action.ExecuteAction (Action action, IDictionary paramètres, Boolean undo)

à Microsoft.Crm.Setup.Common.Installer.Install (IDictionary stateSaver)

à Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall (IDictionary stateSaver)

à Microsoft.Crm.Setup.Common.ComposedInstaller.Install (IDictionary stateSaver)

à Microsoft.Crm.Config.Client.ClientConfig.Install (IDictionary données)

au niveau de Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46 | Verbose | Échec de la configuration 12:58:46 | Info | Nous ne parvenons pas à configurer Microsoft Dynamics CRM pour Outlook :



Échec de l’action Microsoft.Crm.Config.Client.InstallAbpAction.

L'accès est refusé. (Exception à partir de HRESULT : 0 x 80070005 (E_ACCESSDENIED))

Message d'erreur 2Lorsque vous mettez à niveau un client Microsoft Dynamics CRM 3.0 pour un ordinateur Outlook, le message d’erreur suivant s’affiche dans le journal d’installation :

UpgradeDatabase.Action

UpgradeDatabase.Started

Recherche de fichiers de base de données

Déplacement des fichiers de base de données

Actions de base de données terminé

Attribution d’autorisations pour S-1-5-21-682003330-616249376-1801674531-1112

C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf

à System.Security.AccessControl.NativeObjectSecurity.CreateInternal (ResourceType resourceType, Boolean isContainer, nom de chaîne, poignée de SafeHandle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, exceptionContext de l’objet)

à System.Security.AccessControl.FileSystemSecurity... ctor (Boolean isContainer, nom de chaîne, AccessControlSections includeSections, Boolean isDirectory)

à System.Security.AccessControl.FileSecurity... constructeur (String fileName, AccessControlSections includeSections)

à System.IO.FileInfo.GetAccessControl() à Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade (une session)

à Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase (une session)

Fin de l’action 10:33:09 : InstallFinalize. Valeur renvoyée 3.

Lorsque vous essayez de configurer la version du Client Outlook en mode hors connexion de Microsoft Dynamics CRM 4.0, vous recevez toujours le message d’erreur suivant dans une fenêtre modale de Réessayer/Annuler :

Échec de l’action Microsoft.Crm.Config.Client.InstallPstAction. LaunchOutlookInstallerProcess a échoué.

Cause

Ce problème peut se produire si le fichier de données Microsoft Dynamics CRM n’a pas été complètement supprimé, et si le Microsoft Dynamics CRM carnet d’adresses fournisseur (émises) contacts n’ont pas été complètement supprimés.

Résolution

Résolution 1

Pour résoudre ce problème, appliquez l’une des méthodes suivantes, puis essayez d’installer ou de mettre à niveau un client Microsoft Dynamics CRM pour un ordinateur Outlook.

Méthode 1 : Si Microsoft Office Outlook 2007 est installé

  1. Démarrez Outlook 2007.

  2. Dans le menu Outils, cliquez sur Paramètres du compte.

  3. Cliquez sur l’onglet Fichiers de données .

  4. Cliquez sur Microsoft CRM, puis cliquez sur Supprimer.

  5. Cliquez sur l’onglet Carnets d’adresses .

  6. Cliquez sur Carnet d’adresses Microsoft CRM, puis cliquez sur Supprimer.

  7. Quittez Outlook 2007.

Méthode 2 : Si vous avez Microsoft Office Outlook 2003 installé

  1. Quittez Outlook 2003.

  2. Cliquez sur Démarrer, cliquez sur Panneau de configuration, cliquez sur Comptes d’utilisateurs, puis cliquez sur courrier.

  3. Dans la boîte de dialogue Configuration de la messagerie , cliquez sur Fichiers de données.

  4. Cliquez sur Microsoft CRMet cliquez sur Supprimer, puis cliquez sur Fermer.

  5. Dans la boîte de dialogue Configuration de la messagerie , cliquez sur Comptes de messagerie.

  6. Cliquez sur Afficher ou modifier les annuaires existants ou les carnets d’adresses, puis cliquez sur suivant.

  7. Cliquez sur Carnet d’adresses Microsoft CRM, puis cliquez sur Supprimer.

  8. Cliquez sur Fermer pour fermer la boîte de dialogue Configuration de la messagerie .

Résolution 2

Procédez comme suit :

  1. Démarrez Outlook.

  2. Dans le menu Outils, cliquez sur Options

  3. Dans l’onglet Messagerie , cliquez sur Comptes de messagerie.

  4. Sous l’onglet Fichiers de données , sélectionnez Microsoft CRM-n’est pas disponible, puis cliquez sur Supprimer.

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