Symptômes
Vous ne pouvez pas vous connecter à un serveur qui exécute Microsoft Exchange Server à partir d’un client Microsoft Outlook 2019 pour Mac ou Outlook pour Mac pour Office 365 après la désactivation du protocole SSL (Secure Sockets Layer) sur le serveur.
Cause
L’échec de connexion se produit car Outlook pour Mac utilise SSL pour établir la communication avec un serveur Exchange. Lorsque SSL est désactivé et que la renégociation sécurisée est implémentée comme défini dans RFC 5746, Outlook exige que le serveur soit en mode compatible afin que la session puisse être renégociée de SSL à TLS (Transport Layer Security).
Solution de contournement
Configurez le serveur Exchange pour prendre en charge le mode compatible en suivant les instructions de l’article de la Base de connaissances 980436. Ce mode permet au client Outlook pour Mac d’établir une connexion à l’aide du protocole SSL, puis de renégocier à l’aide du protocole TLS. En utilisant cette méthode, Outlook pour Mac pouvez se connecter au serveur même lorsque SSL 2.0 et 3.0 sont bloqués. Si vous utilisez un produit de sécurité tel que Microsoft Forefront Threat Management Gateway (TMG) pour gérer les connexions à Exchange Server en dehors de votre entreprise, vous devez configurer votre serveur TMG à l’aide de l’article de la Base de connaissances 980436. Les connexions externes à Exchange Server peuvent être bloquées si le serveur TMG est en mode Strict.
Remarque : Ne configurez pas le serveur TMG pour utiliser le mode Strict, car cela empêche le client Outlook pour Mac de se connecter à Exchange Server.
Informations supplémentaires
Pour plus d’informations sur la renégociation SSL/TLS, consultez ce billet de blog TechNet.