Outlook se bloque lorsque vous essayez de suivre un e-mail dans Microsoft Dynamics CRM

Cet article fournit une solution et des solutions de contournement pour résoudre le problème de blocage de Microsoft Outlook lorsque vous essayez de suivre un e-mail dans Microsoft Dynamics CRM.

S’applique à : Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, Outlook 2016, Outlook 2013 Microsoft Outlook 2010
Numéro de la base de connaissances d’origine : 3142993

Symptômes

Lorsque vous sélectionnez Suivre dans CRM ou Définir concernant sur un e-mail avec une pièce jointe, Microsoft Outlook se bloque.

En outre, dans le journal des événements de l’application, vous pouvez trouver une ou plusieurs des signatures d’incident suivantes avec l’ID d’événement 1000 :

Nom de l’application Version de l'application Nom du module Version du module Offset
Outlook 2010
Outlook.exe 14.0.7165.5000 exsec32.dll 14.0.7159.5000 0x00007D06
Outlook.exe 14.0.7160.5000 exsec32.dll 14.0.7159.5000 0x00000000000023C5
Outlook.exe 14.0.6109.5005 exsec32.dll 14.0.6019.1000 0x00007C50
Outlook 2013
Outlook.exe 15.0.4763.1000 exsec32.dll 15.0.4759.1000 0x000076BD
Outlook.exe 15.0.4551.1004 exsec32.dll 15.0.4551.1001 0x000076a7
Outlook 2016
Outlook.exe 16.0.6366.2036 exsec32.dll 16.0.6366.1439 0x00003F99
Outlook.exe 16.0.4266.1001 exsec32.dll 16.0.4266.1001 0x00003F82
Outlook.exe 16.0.4266.1001 exsec32.dll 16.0.4266.1001 0x000000000000251F

Cause

Ce problème peut se produire si Outlook n’est pas configuré pour utiliser le mode Exchange mis en cache. Microsoft Dynamics CRM pour Outlook est pris en charge uniquement lors de l’utilisation du mode Exchange mis en cache.

Résolution

Pour résoudre ce problème, suivez les étapes de votre version d’Office et du type d’installation. Consultez la section Plus d’informations pour déterminer si votre installation d’Office est basée sur « Démarrer en un clic » ou sur MSI.

Office 2016

Installations « Démarrer en un clic » d’Office 2016

Pour résoudre ce problème, assurez-vous que votre installation Office 2016 Démarrer en un clic est à la version 16.0.6629.1000 ou une version ultérieure. S’il ne s’agit pas de cette version ou d’une version ultérieure, mettez à jour votre installation d’Office 2013. Pour cela, procédez comme suit.

  1. Ouvrez une application Office, telle que Outlook ou Word.
  2. Sélectionnez Fichier, puis Compte Office ou Compte.
  3. Affichez la version répertoriée sous Office Mises à jour.
  4. Si la version n’est pas 16.0.6629.1000 ou ultérieure, sélectionnez Options de mise à jour, puis Mettre à jour maintenant.

Remarque

Si vous avez précédemment désactivé les mises à jour, sélectionnez Activer les mises à jour après avoir sélectionné Options de mise à jour, puis sélectionnez Mettre à jour maintenant.

Pour plus d’informations sur les canaux de mise à jour pour les clients Office 365, consultez Historique des mises à jour pour les Microsoft 365 Apps (répertoriés par date).

Installations d’Office 2016 basées sur MSI

Pour résoudre ce problème, installez la mise à jour du 7 février 2017 pour Outlook 2016. Pour plus d’informations sur cette mise à jour, consultez Mise à jour du 7 février 2017 pour Outlook 2016 (KB3141511).

Office 2013

Installations « Démarrer en un clic » d’Office 2013

Pour résoudre ce problème, assurez-vous que votre installation d’Office 2013 Démarrer en un clic est à la version 15.0.4833.1001 ou ultérieure. S’il ne s’agit pas de cette version ou d’une version ultérieure, mettez à jour votre installation d’Office 2013. Pour cela, procédez comme suit.

  1. Ouvrez une application Office, telle que Outlook ou Word.
  2. Sélectionnez Fichier, puis Compte Office ou Compte.
  3. Consultez la version indiquée sous Mises à jour pour Office.
  4. Si la version n’est pas 15.0.4833.1001 ou ultérieure, sélectionnez Options de mise à jour, puis Mettre à jour maintenant.

Remarque

Si vous avez précédemment désactivé les mises à jour, sélectionnez Activer les mises à jour après avoir sélectionné Options de mise à jour, puis sélectionnez Mettre à jour maintenant.

Pour plus d’informations sur Démarrer en un clic pour Office 2013, voir Historique des mises à jour pour Office 2013

Installations d’Office 2013 basées sur MSI

Pour résoudre ce problème, installez la mise à jour du 7 juin 2016 pour Outlook 2013. Pour plus d’informations sur cette mise à jour, voir Mise à jour du 7 juin 2016 pour Outlook 2013 (KB3115158).

Solution de contournement

Si vous ne pouvez pas installer la mise à jour mentionnée dans la section Résolution pour résoudre ce problème, vous pouvez contourner le problème à l’aide de l’une des options suivantes :

Option 1 - Activer le mode Exchange mis en cache

Suivez les étapes décrites dans l’article suivant pour activer le mode Exchange mis en cache dans Outlook :

Activer ou désactiver le mode Exchange mis en cache

Option 2 - Activer la synchronisation Server-Side

Basculez l’enregistrement de boîte aux lettres dans Microsoft Dynamics CRM pour votre utilisateur sur Synchronisation côté serveur ou routeur Email au lieu de Microsoft Dynamics CRM pour Outlook. Pour plus d’informations sur la configuration de la synchronisation Server-Side, reportez-vous à l’article suivant.

Configurer la synchronisation côté serveur des courriers, rendez-vous, contacts et tâches

Informations supplémentaires

Pour déterminer si votre installation Office est basée sur un clic ou msi, procédez comme suit :

  1. Ouvrez une application Office, comme Word ou Outlook.
  2. Dans le menu Fichier , sélectionnez Compte ou Compte Office.
  3. Pour les installations Office Démarrer en un clic, un élément Options de mise à jour s’affiche. Pour les installations basées sur MSI, l’élément Options de mise à jour n’est pas affiché.