Performances lentes lors de l’épinglage d’affichages Microsoft Dynamics CRM

Symptômes

Microsoft Dynamics CRM client pour Microsoft Office Outlook peut s’exécuter lentement lors de l’épinglage d’affichages.

Cause

Lorsqu’un affichage est épinglé, les enregistrements de la vue sont retirés vers la base de données SQL CE locale dans {orgid.sdf} et mis en cache. Lorsque des affichages sont épinglés, ils sont présentés à un utilisateur en « affichage de liste » et non en « affichages page ». Chaque fois qu’un affichage épinglé est accessible, il renvoie des résultats à partir des fichiers .sdf locaux.

Ces données sont régulièrement mises à jour en tant que processus en arrière-plan. Si un utilisateur a plusieurs affichages épinglés ou sur des ordinateurs qui ne disposent pas d’un grand nombre de ressources, cela peut entraîner des problèmes de performances et de chargement ralentis.

Résolution

Pour empêcher les affichages épinglés de retirer des informations vers les caches SQL CE locaux, une clé de Registre peut être définie sur les clients Outlook Microsoft Dynamics CRM 2011. Cela peut également vous aider à réduire le trafic réseau global envoyé à partir d’un Microsoft Dynamics CRM 2011 vers un ordinateur client Microsoft Dynamics CRM Outlook 2011.

Lorsque cette valeur est définie sur 1, les utilisateurs ont toujours la possibilité d’épingler les affichages. Toutefois, la requête est envoyée au serveur CRM pour récupérer les résultats plutôt que dans le cache local.

Importante Cette section, méthode ou tâche contient les étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d’informations sur la restauration et la restauration du Registre, cliquez sur le numéro d’article suivant pour le consulter dans la Base de connaissances Microsoft :
322756Comment faire pour restaurer et restaurer le Registre dans Windows. Pour que nous suivent ce


problème, consultez la section « Résoudre le problème pour moi ». Si vous préférez résoudre le problème vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi



Pour résoudre ce problème automatiquement, cliquez sur le bouton ou le lien Corriger. Cliquez ensuite sur Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez la procédure indiquée par l’Assistant Résolution.




Notes

  • Il se peut que cet Assistant ne soit disponible qu’en anglais. Toutefois, la résolution automatique fonctionne aussi pour d’autres versions linguistiques de Windows.

  • Si vous n’utilisez pas l’ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l’exécuter sur l’ordinateur concerné par le problème.


Ensuite, allez à la section « Le problèmeest-ilcorrigé ? ».



Je résous le problème moi-même

Pour résoudre ce problème, suivez ces étapes :
1. Connectez-vous aux Microsoft Dynamics CRM client Outlook 2011 en tant qu’utilisateur ayant installé le client Outlook Microsoft Dynamics CRM 2011.
2. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK. Accédez à la clé de Registre, HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD (32 bits).
3. Tapez DisableMapiCaching, puis appuyez sur Entrée.
4. Cliquez avec le bouton droit sur DisableMapiCaching, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
5. Cliquez avec le bouton droit sur DisableMapiCaching, puis cliquez sur Modifier.
6. Dans la zone Données de la valeur, tapez 1, puis cliquez sur OK.
7. Fermez l'Éditeur du Registre.


Le problème est-il résolu ?

  • Vérifiez que le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter le support technique.

  • Vos commentaires sont les bienvenus. Pour envoyer des commentaires ou signaler des problèmes avec cette solution, veuillez laisser un commentaire sur le blog « Résoudre le problème pourmoi» ou nous envoyer un message électronique.

Informations supplémentaires

La mise à jour rollup 6 ou version supérieure doit être installée pour que la clé de Registre DisableMapiCaching fonctionne. Pour plus d’informations sur le rollup 6 de mise à jour, voir KB 2600640.


Remarque : cette clé de Registre n’est pas valide une fois la mise à jour rollup 14 appliquée. Celle-ci devra être mise à jour à l’aide de l’outil OrgDbOrgSettings.

OrgDBOrgSettings Tool for Microsoft Dynamics CRM 2011

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