Le propriétaire ne peut pas créer de dossiers publics modernes à l’aide d’Outlook dans Exchange Server 2013 ou Exchange Server 2016

Symptômes

Supposons que vous êtes propriétaire d’une boîte aux lettres de dossiers publics ou que vous disposez des autorisations d’accès suffisantes pour créer un dossier public dans un environnement Microsoft Exchange Server 2013 ou Microsoft Exchange Server 2016. La boîte aux lettres utilise la hiérarchie secondaire comme boîte aux lettres de dossiers publics par défaut. Dans ce cas, lorsque vous essayez de créer un dossier public à l’aide de Microsoft Outlook, le message d’erreur suivant s’affiche :

Impossible de créer le dossier. Vous ne disposez pas des autorisations suffisantes pour effectuer cette opération sur cet objet. Consultez le contact du dossier ou votre administrateur système.

Remarque

Si la boîte aux lettres de dossiers publics par défaut est remplacée par une boîte aux lettres de dossiers publics contenant la hiérarchie principale, vous pouvez créer des dossiers publics à l’aide d’Outlook.

Consultez Plus d’informations sur la résolution du problème dans cet article.

Cause

Ce problème se produit car l’entrée de LmCompatibilityLevel Registre sur le rôle serveur de boîtes aux lettres Exchange Server est configurée sur une valeur inférieure à 2.

Solution de contournement

Importante

Suivez attentivement les étapes de cette section. Des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Avant de modifier le Registre, sauvegardez-le pour restauration en cas de problèmes.

Pour contourner ce problème, procédez comme suit sur le rôle serveur de boîtes aux lettres Exchange Server qui héberge la boîte aux lettres de dossiers publics de hiérarchie secondaire :

  1. Remplacez la valeur de l’entrée LmCompatibilityLevel de Registre par 2 ou plus.

    Remarque

    L’entrée se trouve sous le chemin d’accès du Registre suivant :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Redémarrez les services suivants :

    • Banque d'informations Microsoft Exchange
    • Accès au client RPC Microsoft Exchange
    • Microsoft Exchange Gestionnaire d'intégrité

Informations supplémentaires

Pour plus d’informations sur le paramètre LmCompatibilityLevel, consultez les articles suivants :

Informations générales sur l’entrée de Registre LmCompatibilityLevel

Surveillance de sécurité : Le paramètre Sécurité Windows le plus mal compris de tous les temps

Plus d’informations pour résoudre ce problème

Lorsque ce problème se produit, autre que le message d’erreur, vous pouvez également trouver les informations suivantes qui peuvent vous aider à résoudre ce problème.

  • Le message suivant est enregistré sous le journal « Accès client RPC » dans observateur d'événements :

    Client=MSExchangeRPC,,,,-2147024891 (rop::AccessDenied),00:00:00.0310000,,"RopHandler:
    CreateFolder: [AccessDeniedException] Cannot open mailbox /o=Contoso/ou=Exchange Administrative Group
    (FYDIBOHF23SPDLT)/cn=Recipients/cn=9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. ->
    [MapiExceptionNoAccess] Unable to make connection to the server. (hr=0x80070005, ec=-2147024891)
    [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=] 
    at M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore() 
    at M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder(String folderName, String folderDescription, StoreId parentFolderId, CreateMode mode, Guid& contentMailboxGuid) 
     at M.E.R.H.PublicFolderOperations.<>c__DisplayClass1.<CreateFolder>b__0(StoreId& folderIdToSync, Guid& contentMailboxGuid) 
    at M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T](Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy",,,admin@contoso.com,
    
  • Si vous exécutez la commande Get-ServerHealth -Identity ServerIdParameter -HealthSet « Outlook.Protocol » dans Exchange Management Shell (EMS), le jeu d’intégrité Outlook.Protocol signale un état non sain, en particulier pour les moniteurs suivants qui sont liés à la procédure distante Outlook appelant RPC) :

    • OutlookRpcDeepTestMonitor
    • OutlookRpcSelfTestMonitor
  • L’échec de la sonde OutlookRpcDeepTestProbe enregistre le message suivant :

    Microsoft.Exchange.Rpc.RpcException: Error 0x5 (Access is denied) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall