Symptômes

Supposons que vous êtes le propriétaire d’une boîte aux lettres de dossier public ou disposez des autorisations d’accès suffisantes pour créer un dossier public dans un environnement Microsoft Exchange Server 2013 ou 2016 de Microsoft Exchange Server. La boîte aux lettres utilise la hiérarchie secondaire en tant que la boîte aux lettres de dossier public par défaut. Dans ce cas, lorsque vous essayez de créer un dossier public à l’aide de Microsoft Outlook, le message d’erreur suivant s’affiche :

Impossible de créer le dossier. Vous n’avez pas de permissions suffisantes pour effectuer cette opération sur cet objet.
Consultez le contact du dossier ou votre administrateur système.

Remarque  Si la boîte aux lettres de dossiers publics par défaut est modifiée pour une boîte aux lettres de dossier public qui contient la hiérarchie principale, vous pouvez créer des dossiers publics à l’aide de Outlook.

Dans cet article, reportez-vous à la section plus d’informations sur la façon de résoudre le problème .

Cause

Ce problème se produit car l’entrée de Registre LmCompatibilityLevel sur le rôle de serveur de boîtes aux lettres Exchange Server est configurée sur une valeur inférieure à 2.

Solution de contournement

Important
Suivez les étapes décrites dans cette section avec soin. Des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Avant que vous modifiez, sauvegarder le Registre pour la restauration en cas de problèmes.

Pour contourner ce problème, procédez comme suit sur le rôle de serveur de boîtes aux lettres Exchange Server qui héberge la boîte aux lettres des dossiers publics de hiérarchie secondaire :

  1. Modifiez la valeur de l’entrée de Registre LmCompatibilityLevel égale ou supérieure à 2 .

    Remarque L’entrée se trouve sous le chemin de Registre suivant :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Redémarrez les services suivants :

    • Banque d’informations Microsoft Exchange

    • Accès de Client RPC Microsoft Exchange

    • Gestionnaire d’état de Microsoft Exchange


Plus d'informations

Pour plus d’informations sur le paramètre LmCompatibilityLevel , consultez les articles suivants :

Informations générales sur l’entrée de Registre LmCompatibilityLevel

Surveillance de la sécurité : Les plus mal compris le paramètre de sécurité Windows de tous les temps

Lorsque ce problème se produit, que le message d’erreur, vous trouverez également les informations suivantes qui peuvent aider à résoudre ce problème.

  • Le message suivant est consigné dans le journal de le « Accès de Client RPC » dans l’Observateur d’événements :

    Client = MSExchangeRPC,, -2147024891 (rop::AccessDenied), 00:00:00.0310000, "RopHandler : CreateFolder : [AccessDeniedException] Impossible d’ouvrir la boîte aux lettres /o = Contoso/ou = Exchange Administrative Group (FYDIBOHF23SPDLT) / cn = Destinataires/cn = 9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. -> [MapiExceptionNoAccess] Impossible d’établir la connexion au serveur. (hr = 0 x 80070005, ec =-2147024891)  [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=]
    à M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore()
    à M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder (String nom_dossier, folderDescription de chaîne, StoreId parentFolderId, mode de création, mode, Guid & contentMailboxGuid)
    à M.E.R.H.PublicFolderOperations. <> c__DisplayClass1 < CreateFolder > b__0 (StoreId & folderIdToSync, Guid & contentMailboxGuid)
    à M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T] (Boolean isCompleteSync, PublicLogon, publicLogon, PrimaryHierarchy",, admin@contoso.com,

  • Si vous exécutez le Get-ServerHealth-Identity ServerIdParameter - HealthSet 'Outlook.Protocol' commande dans Exchange Management Shell (EMS), à la santé Outlook.Protocol définie des rapports incorrecte, spécialement pour les moniteurs suivants associés à l’appel de procédure distante Outlook RPC) :

    • OutlookRpcDeepTestMonitor

    • OutlookRpcSelfTestMonitor

  • L’échec de la sonde OutlookRpcDeepTestProbe enregistre le message suivant :

    Microsoft.Exchange.Rpc.RpcException : Erreur 0 x 5 (accès refusé) à partir de ClientAsyncCallState.CheckCompletion : RpcAsyncCompleteCall



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