Les règles d’entreprise (logique métier portable) peuvent ne pas fonctionner correctement ou créer des erreurs lorsqu’un utilisateur exécute des flux de processus métier sans privilèges suffisants sur l’entité De processus

Cet article fournit une solution au problème lié au fait que les règles d’entreprise (logique métier portable) ne fonctionnent pas comme prévu ou que des erreurs se produisent lorsqu’un utilisateur exécute des flux de processus métier sans privilèges suffisants sur l’entité Processus.

S’applique à : Microsoft Dynamics CRM
Numéro de la base de connaissances d’origine : 4025533

Symptômes

Les règles d’entreprise ne parviennent pas à s’exécuter ou les flux de processus métier affichent un message d’erreur qui commence par l’échec du plug-in de service web dans SdkMessageProcessingStepId : (...).

Cause

Si le rôle de sécurité d’un utilisateur dispose de privilèges insuffisants sur l’entité Process , qui fait référence à la table de flux de travail interne, les règles d’entreprise et les flux de processus métier ne parviennent pas à générer, charger et s’exécuter correctement lors du premier chargement, ce qui entraîne un comportement inattendu ou des erreurs intermittentes. Lorsque cela se produit, l’état est mis en cache, et un utilisateur suivant, dont le rôle de sécurité dispose de privilèges suffisants, tente de charger et d’exécuter les mêmes règles d’entreprise et flux de processus métier.

Pour case activée pour les niveaux d’accès, accédez à Paramètres> Rôlesde sécurité>Sélectionnez> un rôle > de sécurité onglet> PersonnalisationEntité de processus. La colonne Read doit être entièrement verte (accès au niveau de l’organisation).

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Assurez-vous que tous les rôles de sécurité disposent de privilèges de lecture complets au niveau de l’organisation pour l’entité Processus.
  2. Publiez les personnalisations en accédant à Paramètres>Personnalisation>du système.