Résolution des problèmes d’un lot partiellement publié dans Comptes fournisseurs dans Microsoft Dynamics SL

Cet article fournit des solutions aux erreurs qui se produisent lorsque vous essayez de publier un lot dans Comptes fournisseurs dans Microsoft Dynamics SL.

S’applique à : Microsoft Dynamics SL 2011
Numéro de la base de connaissances d’origine : 871362

Symptômes

Lorsque vous essayez de publier un lot dans Comptes fournisseurs dans Microsoft Dynamics SL, le lot n’est pas publié. Lorsque vous examinez, vous voyez que le lot de la boîte de dialogue Release AP Batches (03.400.00) a un status partiellement libéré. Vous pouvez voir l’un des messages d’erreur suivants dans un journal des événements :

Message système 8888 - Une erreur inattendue s’est produite lors de la libération du lot %s. Veuillez contacter Solomon pour obtenir de l’aide sur ce lot.

Message système 6019 - Batch n’est pas équilibré et n’est pas publié.

Message système 6909 - Un autre processus a déjà ajouté l’élément %s. Le programme doit être arrêté.

Cause

Il existe plusieurs causes possibles pour les messages d’erreur.

Remarque

Si aucune des causes suivantes ne s’applique, exécutez un script de débogage. Pour plus d’informations sur l’exécution d’un script de débogage, consultez résolution 2.

  • Pendant le processus de publication, la connexion entre Microsoft Dynamics SL et le instance de SQL Server a été perdue. Voir résolution 1.
  • Pendant le processus de mise en production, vous avez sélectionné Annuler dans la boîte de dialogue Release AP Batches (03.400.00). Voir résolution 1.
  • Le message d’erreur 6909 du message système peut se produire lorsque vous essayez de libérer les lots Vérifier la réconciliation à partir de la boîte de dialogue Vérifier la réconciliation (03.060.00) après avoir essayé de modifier la période en Post.
  • Dans Microsoft Business Solutions - Solomon 6.0, le bogue 7318 peut entraîner l’affichage du message d’erreur 6909.

Résolution

Remarque

Si vous utilisez actuellement Microsoft Dynamics SL 2011 ou versions ultérieures, vous pouvez supprimer le lot de l’écran de saisie de données et le saisir de nouveau.

Résolution 1

Essayez de libérer à nouveau le lot. Pour ce faire, procédez comme suit :

  1. Ouvrez la boîte de dialogue Release AP Batches (03.400.00).
  2. Sélectionnez la zone Case activée sélectionné en regard du numéro de lot référencé dans le journal des événements.
  3. Sélectionnez Commencer le traitement.

Résolution 2

Si vous exécutez Microsoft SQL Server 2000, exécutez le script AP_6019_DEBUG dans l’Analyseur de requêtes SQL, puis envoyez les résultats du script et le journal des événements aux services de support technique Microsoft. Pour ce faire, procédez comme suit. Une vidéo est également disponible qui décrit le processus d’exécution du script de débogage AP :

  1. Téléchargez le fichier AP_6019_DEBUG.sql .

    Microsoft a analysé ce fichier à la recherche de virus. Microsoft a utilisé le logiciel de détection de virus le plus actuel disponible à la date de publication du fichier. Le fichier est stocké sur des serveurs à sécurité renforcée qui permettent d’empêcher toute modification non autorisée du fichier.

  2. Sélectionnez Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server, puis sélectionnez Analyseur de requête.

  3. Dans la boîte de dialogue Se connecter à SQL Server, tapez le nom du instance de SQL Server nom dans la zone SQL Server, puis sélectionnez Authentification SQL Server.

  4. Tapez sa dans la zone Nom de connexion, tapez le mot de passe dans la zone Mot de passe , puis sélectionnez OK.

  5. Dans la barre d’outils de l’Analyseur de requêtes, sélectionnez la base de données de l’application.

  6. Dans le menu Outils , sélectionnez Options, puis sélectionnez l’onglet Résultats .

  7. Dans la zone Cible de résultats par défaut , sélectionnez Résultats au texte.

  8. Dans la zone Format de sortie des résultats , sélectionnez Délimité par tabulation, puis OK.

  9. Remplacez XXXXXX par votre numéro de lot à six chiffres.

  10. Pour exécuter le script, appuyez sur F5.

  11. Une fois l’exécution du script terminée, cliquez sur la fenêtre inférieure.

  12. Dans le menu Fichier, sélectionnez Enregistrer sous.

  13. Dans la zone Nom de fichier , tapez IncidentAP. Remplacez Incident par votre numéro d’incident réel.

  14. Dans la zone Type de fichier, sélectionnez Fichiers de rapport (*.rpt), puis Enregistrer.

  15. Compressez ce fichier avec le journal des événements, puis envoyez les fichiers aux services de support technique Microsoft.

Si vous exécutez Microsoft SQL Server 2005 ou Microsoft SQL Server 2008, exécutez le script AP_6019_DEBUG dans SQL Server Management Studio, puis envoyez les résultats du script et le journal des événements aux services de support technique Microsoft. Pour ce faire, procédez comme suit :

  1. Téléchargez le fichier de débogage AP_6019_DEBUG.sql.

    Le fichier suivant est disponible en téléchargement à partir de l’Exchange Server microsoft Dynamics File : AP_6019_DEBUG.sql.

    Microsoft a analysé ce fichier à la recherche de virus. Microsoft a utilisé le logiciel de détection de virus le plus actuel disponible à la date de publication du fichier. Le fichier est stocké sur des serveurs à sécurité renforcée qui permettent d’empêcher toute modification non autorisée du fichier.

  2. Démarrez SQL Server Management Studio, connectez-vous au serveur, puis modifiez la mise en forme de la sortie. Pour ce faire, procédez comme suit :

    1. Dans le menu Outils, sélectionnez Options.
    2. Sélectionnez Résultats de la requête.
    3. Dans la zone Destination par défaut pour les résultats , sélectionnez Résultats en texte.
    4. Développez Résultats de la requête, puis développez la instance de SQL Server.
    5. Sélectionnez Résultats sur Texte.
    6. Dans la zone Format de sortie , sélectionnez Délimité par tabulation.
    7. Sélectionnez la zone Inclure les en-têtes de colonne dans le jeu de résultats case activée.
    8. Sélectionnez OK pour fermer la boîte de dialogue Options .
  3. Dans le menu Fichier , sélectionnez Ouvrir, recherchez le fichier AP_6019_DEBUG.sql , puis double-cliquez sur le fichier AP_6019_DEBUG.sql .

  4. Remplacez l’espace réservé XXXXXX par le numéro de lot à six chiffres du lot suspendu.

  5. Appuyez sur la touche F5.

  6. Une fois le script terminé, cliquez avec le bouton gauche sur le volet inférieur de la fenêtre.

  7. Dans le menu Fichier, sélectionnez Enregistrer sous.

  8. Dans la zone Nom de fichier , tapez IncidentAP.

    Remarque

    Remplacez l’espace réservé Incident par le numéro de lot du lot suspendu.

  9. Dans la zone Type de fichier, sélectionnez Fichiers de rapport (*.rpt).

  10. Sélectionnez Enregistrer.

  11. Compressez le fichier.

  12. Envoyez le fichier compressé avec le journal des événements aux services de support technique Microsoft.

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