Symptôme
Un script qui peut être exécuté avec succès en mode participé ne s’exécute pas correctement en mode sans surveillance.
Elle échoue généralement avec un message tel que : « Un problème est à l’œuvre lorsque l’action « Cliquez » est en cours. Le lien n’a pas pu être cliqué sur la page web ».
Cause
Les échecs classiques d’une exécute sans surveillance sont dus à l’une des raisons suivantes :
-
Script non testé en mode présent avant de passer à l’écran sans surveillance
-
Configuration différente utilisée par la session sans surveillance
-
Compte de Windows utilisé par une exécuter sans surveillance que celui utilisé pour créer le flux
-
Résolution de l’écran (découvrir comment modifier la résolution de l’écran)
-
Configuration du navigateur
-
Utilisateur
-
Bloqueur de fenêtres pop-up
-
Extensions (manquantes/non activées)
-
-
-
Les écrans ne sont pas entièrement chargés (retards manquants)
-
Invite UAC qui bloque l’automatisation de l’interface utilisateur au début de la session
Solution
Comme il peut y avoir différentes causes, la solution ci-dessous explique comment ajouter des captures d’écran avant et après un échec pour obtenir des commentaires visuels. Si vous regardez attentivement les captures d’écran suite à un échec du script sans surveillance, vous pouvez trouver l’une des raisons répertoriées ci-dessus.
Si vous avez déjà des captures d’écran dans votre flux et qu’elles ne s’exécutent pas, il se peut qu’une boîte de dialogue UAC (User Account Control) bloque l’exécution de votre flux. Veuillez vous connecter à l’ordinateur qui reproduit le problème avec le compte que vous utilisez pour exécuter le flux et voir si une telle boîte de dialogue de blocage apparaît. Si c’est le cas, modifiez votre routine de démarrage pour éviter que cela se produise.
Ajout de captures d’écran à résoudre
Commencez par vous connecter à l’ordinateur qui reproduit le problème avec le compte que vous utilisez dans votre connexion. Vérifiez qu’aucune invite uAC ne bloque l’automatisation de l’interface utilisateur.
Si rien ne bloquerait l’automatisation de l’interface utilisateur, prenez une capture d’écran avant et après l’échec d’une étape en mode sans surveillance peut vous aider à obtenir des commentaires visuels.
L’étape à l’échec doit se poursuivre en cas d’échec de sorte qu’une capture d’écran puisse être prise après l’échec.
1- Rechercher l’action «Prendre une capture d’écran»
2- Glisser-déposer de l’action «Prendre une capture d’écran» sur le côté script
3- Modifiez l’action, utilisez «Fichier»au lieu du Presse-papiers et « avant » dans l’emplacement du nom de fichier
4- Ensuite, copiez/collez et modifiez le nom du fichier de capture d’écran après l’avoir
5- Entourez l’étape à l’échec des captures d’écran
6- Modifier le comportement surErreur de l’étape d’échec
6a - Modifiez l’étape et cliquez sur« surErreur» en bas
6b - Définissez l’exécuter de flux sur« Continuer l’exécuter» et «Passer à l’action suivante »
7- Enregistrer,exécuter localement pour tester la production des captures d’écran et relancer une exécuter sans surveillance.
8- Vérifiez les fichiers de capture d’écran nonattés.
Remarque
Comme indiqué précédemment, si l’action de capture d’écran elle-même échoue, il est possible qu’une boîte de dialogue Contrôle de compte d’utilisateur bloque l’exécution de votre flux. Veuillez vous connecter à l’ordinateur qui reproduit le problème avec le compte que vous utilisez pour exécuter le flux et voir si une telle boîte de dialogue de blocage apparaît. Si c’est le cas, modifiez votre routine de démarrage pour éviter que cela se produise.
Si le script a d’autres étapes, il peut échouer après que le comportement a été modifié afin de ne pas échouer et de faire une capture d’écran. Il convient donc d’ignorer les échecs après la deuxième capture d’écran.
Une fois le problème compris et corrigé, restituer le comportement d’origine de votre flux pour éviter des erreurs.