Utiliser un lecteur d’écran pour exporter un tableau Access dans un classeur Excel

Travaillez partout et à partir de n’importe quel appareil avec Microsoft 365

Effectuez une mise à niveau vers Microsoft 365 pour travailler partout avec les dernières fonctionnalités et mises à jour.

Mettre à niveau maintenant
Symbole de lecture à haute voix avec l’étiquette de contenu de lecteur d’écran. Cette rubrique concerne l’utilisation du lecteur d’écran avec Office

Cet article est destiné aux personnes souffrant de troubles de la vue qui utilisent un programme de lecteur d’écran avec les produits Office et fait partie du contenu Accessibilité Office. Pour plus d’informations, voir l’accueil du support Office.

Utilisez Access clavier et un lecteur d’écran pour exporter des données dans un format de fichier Excel lire. Nous l’avons testé avec le narrateur, JAWS et NVDA, mais il est possible qu’il fonctionne avec d’autres lecteurs d’écran, à condition qu’ils respectent les techniques et normes d’accessibilité courantes. Vous découvrirez comment utiliser l’Assistant Exportation pour exporter des données, telles qu’une table, une requête, un formulaire, un état ou des enregistrements sélectionnés dans une vue à plusieurs enregistrements, telle qu’une feuille de données vers un fichier compatible Excel.

Remarques : 

Contenu de cet article

Préparer vos données pour l’exportation

Avant d’exporter vos données, prenez quelques instants pour examiner les données et décider comment vous voulez les exporter.

  • Assurez-vous que les données ne contiennent pas d’indicateurs d’erreur ou de valeurs d’erreur. Sinon, des problèmes peuvent survenir lors de l’exportation et des valeurs Null peuvent être insérées dans Excel de feuille de calcul. Pour des informations de dépannage, voir la section Résoudre les problèmes de valeurs manquantes et incorrectes dans Exporter des données vers Excel.

  • Décidez si vous voulez exporter une table ou une requête avec ou sans sa mise en forme. Cette décision affecte la quantité de données exportées et le format d’affichage des données. Pour plus d’informations sur le résultat de l’exportation de données formatées et non mise en forme, voir la section Préparer l’exportation dans Exporter des données vers Excel.

  • Choisissez le classeur de destination et le format de fichier. Si vous exportez une table, une requête, un formulaire ou un état avec une mise en forme dans un fichier existant, le fichier est écrasé.

    Remarque : Les rapports ne peuvent être exportés que dans l’ancien format de fichier *.xls, et non dans le nouveau format de fichier *.xlsx.

Exporter les données

Si vous exportez un formulaire contenant des sous-formulaires, un état contenant des sous-états ou une feuille de données contenant des sous-feuilles, seul le formulaire, la feuille de données ou l’état principal est exporté. Vous devez répéter l’exportation pour chaque sous- Excel.

Vous pouvez exporter un seul objet de base de données à la fois par opération d’exportation. Toutefois, vous pouvez fusionner plusieurs feuilles de calcul dans Excel opérations d’exportation individuelles.

Si vous n’avez pas de workbook prêt, il sera créé lors de l’exportation. Les données sont toujours ajoutées à une nouvelle feuille de calcul.

Access ne prend pas en charge l’exportation de macros ou modules vers Excel.

  1. Si vous avez un Excel de destination prêt, fermez-le.

  2. Accédez à la base de données source, puis sélectionnez l’objet à exporter.

    Si l’objet est une table, une requête ou un formulaire et que vous souhaitez exporter uniquement une partie des données, ouvrez l’objet en mode Feuille de données et sélectionnez les enregistrements de votre choix. Pour obtenir des instructions, voir Ouvrir un objet en mode Feuille de données.

    Remarque : Vous ne pouvez pas exporter une partie d’un état. Toutefois, vous pouvez sélectionner ou ouvrir la table ou la requête sur la base de l’état, puis exporter une partie des données de cet objet.

  3. Pour démarrer l’Assistant Exportation d Excel exporter, appuyez sur Alt+X, X. La boîte de dialogue Exporter - Feuille de calcul Excel s’ouvre.

  4. Effectuez l’une des actions suivantes :

    • Si vous voulez créer une feuille de calcul pendant l’exportation, appuyez sur Alt+F pour déplacer le focus sur le champ de texte Nom de fichier. Access suggère le nom de l’objet source comme nom de fichier pour le fichier exporté. Pour modifier le nom, supprimez le nom suggéré et tapez un nouveau nom.

    • Si vous avez un fichier Excel vers lequel vous voulez exporter les données, appuyez sur Alt+R pour ouvrir la boîte de dialogue Enregistrer le fichier, puis recherchez le fichier de votre choix. Une fois sur le fichier, appuyez sur Entrée pour le sélectionner. La boîte de dialogue se ferme et le focus revient à la boîte de dialogue Exporter - Feuille de calcul Excel.

  5. Appuyez sur Alt+T pour déplacer le focus sur la liste Format de fichier. Vous entendez le format actuel. Pour sélectionner le format de fichier de votre choix, appuyez sur Espace pour développer la liste, sur Flèche haut ou Flèche bas jusqu’à entendre le format de votre choix, puis sur Entrée pour le sélectionner.

  6. Si vous exportez une table ou une requête et si vous voulez exporter les données mises en forme, appuyez sur Alt+W pour déplacer et sélectionner les données d’exportation avec les options de mise en forme et de mise en page.

    Remarque : Si vous exportez un formulaire ou un état, cette option est sélectionnée par défaut et vous ne pouvez pas la désélectionner.

  7. Si vous souhaitez que le classe Excel de destination s’ouvre automatiquement après l’exportation, appuyez sur Alt+A pour vous déplacer vers et sélectionner l’option Ouvrir le fichier de destination une fois l’exportation terminée.

  8. Si l’objet source est ouvert et que vous avez sélectionné un ou plusieurs enregistrements dans la vue avant de commencer l’exportation (enregistrements que vous voulez exporter), appuyez sur Alt+S pour passer à l’option Exporter uniquement les enregistrements sélectionnés, puis sélectionnez-la. Si vous voulez exporter tous les enregistrements affichés dans la vue, ne sélectionnez pas cette option.

    Remarque : Si aucun enregistrement n’est sélectionné, cette option n’est pas disponible.

  9. Pour démarrer l’exportation, appuyez sur Tab jusqu’à atteindre le bouton OK, puis appuyez sur Entrée.

  10. Si l’exportation a réussi, Access vous invite à enregistrer les étapes d’exportation pour les répéter rapidement sans l’Assistant Exportation. Pour sélectionner cette option, appuyez sur Alt+V. Pour nommer le fichier, appuyez sur Alt+A, puis tapez un nom de fichier. Pour enregistrer le fichier d’étapes, appuyez sur Alt+S.

    Si l’exportation échoue en raison d’une erreur, Access un message décrivent la cause de l’erreur.

    Si vous avez sélectionné pour ouvrir automatiquement le Excel de destination, appuyez sur Alt+Tab jusqu’à entendre le nom du groupe de travail et examinez son contenu.

Ouvrir un objet en vue Feuille de données

Si l’objet que vous voulez exporter est une table, une requête ou un formulaire et que vous souhaitez exporter uniquement une partie des données, vous devez ouvrir l’objet en mode Feuille de données pour sélectionner les enregistrements de votre choix.

  1. Accédez à l’objet dans l’arborescence de navigation.

  2. Lorsque vous vous trouverez sur l’objet, appuyez sur Lest.

  3. Dans le menu, appuyez sur Tab jusqu’à atteindre l’option d’affichage Feuille de données, puis appuyez sur Entrée pour la sélectionner. L’objet s’ouvre en affichage Feuille de données.

    Si l’option Feuille de données n’est pas disponible, activez l’affichage pour l’objet. Pour obtenir des instructions, voir Activer le mode Feuille de données pour un objet.

Activer le vue Feuille de données pour un objet

  1. Lorsque vous vous trouverez sur l’objet dans l’arborescence de navigation, appuyez sur Shift+F10 pour ouvrir le menu contextux.

  2. Dans le menu, appuyez sur D pour ouvrir le mode Création.

  3. En mode Création, appuyezsur F4 pour ouvrir le volet Feuille de propriétés.

  4. Appuyez une fois sur F6. Le focus se déplace sur une ligne de propriété dans le volet Feuille de propriétés. Vous entendez le numéro de ligne, suivi du contenu de la cellule de propriété.

  5. Pour déplacer le focus vers la liste déroulante du type de sélection, appuyez sur Shift+Tab jusqu’à entendre « Champ entier », suivi de la valeur actuelle, puis « Modification combinée ». Si la valeur actuelle est Formulaire,vous pouvez passer à l’étape suivante. Sinon, appuyez sur Alt+Flèche vers le bas pour développer la liste, appuyez sur La flèche vers le haut ou vers le bas jusqu’à entendre « Formulaire », puis appuyez sur Entrée pour le sélectionner.

  6. Dans le volet Feuille de propriétés, appuyez sur la touche Tab jusqu’à entendre l’élément d’onglet actuellement sélectionné, par exemple, « Élément d’onglet Données, sélectionné ». Si l’onglet actuel est l’onglet Format, vous pouvez passer à l’étape suivante. Sinon, appuyez sur flèche gauche ou droite jusqu’à entendre : « Élément d’onglet Format ». Les propriétés de l’onglet Format sont affichées.

  7. Sous l’onglet Format, appuyez sur Tab jusqu’à entendre : « Ligne quatre, Non, collapsed ». Le foyer est sur la propriété Autoriser le affichage Feuille de données. Pour définir la propriété sur Oui,appuyez sur Alt+Flèche vers le bas, appuyez une fois sur la flèche vers le haut, puis appuyez sur Entrée pour sélectionner la nouvelle valeur.

  8. Pour fermer le volet Feuille de propriétés, appuyez sur F4.

  9. Pour ouvrir l’objet sélectionné en affichageFeuille de données, appuyez sur Alt+J, D, W, puis H.

Voir aussi

Utiliser un lecteur d’écran pour créer des tables dans des bases de données de bureau Access

Utilisez un lecteur d’écran pour créer une requête dans des bases de données de bureau Access

Utiliser un lecteur d’écran pour créer un formulaire dans des bases de données Access de bureau

Utiliser un lecteur d’écran pour exporter un tableau Access dans un fichier texte

Raccourcis clavier d’Access

Utiliser un lecteur d’écran pour explorer et parcourir Access

Support technique pour les clients souffrant d’un handicap

L’objectif de Microsoft est d’offrir la meilleure expérience possible à tous ses clients. Si vous souffrez d’un handicap ou si vous avez des questions liées à l’accessibilité, veuillez contacter Microsoft Answer Desk Accessibilité pour obtenir une assistance technique. Les membres de l’équipe du support Answer Desk Accessibilité sont formés à l’utilisation des technologies d’assistance les plus répandues et peuvent vous offrir une aide en anglais, en espagnol, en français et en langue des signes américaine. Accédez au site Microsoft Answer Desk Accessibilité pour connaître les informations de contact pour votre pays ou région.

Si vous êtes un utilisateur au sein d’un organisme gouvernemental, d’une PME ou d’une grande entreprise, veuillez contacter Answer Desk Accessibilité pour les entreprises.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×