Symptômes
Une fois la mise à niveau vers Microsoft Windows Server 2003 à partir d’un système d’exploitation antérieur, vous pouvez rencontrer un ou plusieurs des messages d’erreur suivants :
Message d'erreur 1
Message d'erreur 1
3709 - la connexion ne peut pas être utilisée pour effectuer cette opération. Elle est fermée ou non valide dans ce contexte.
Message d'erreur 2-Erreur automation 2147024769
Message d'erreur 38007007f erreur inconnue
Message d’erreur 48007007f Impossible d’ouvrir la table
Message d’erreur 5« Méthode ' ~' de l’objet ' ~' a échoué » sur l’appel de la méthode Open d’un objet ADODB. Connexion
Message d’erreur 6Erreur : Le GetTextExtentPointI de point d’entrée procédure n’a pas pu être localisé dans la bibliothèque de liens dynamiques MSDART. DLL.
Message d’erreur 7Erreur de connexion à SQL-2147024769 -
Cause
Ce problème se produit car les fichiers Microsoft Data Access Components (MDAC) appropriés n’ont pas mis à niveau avec succès.
Résolution
Pour résoudre ce problème, vous devez appliquer le correctif cumulatif de MDAC 2.8 qui est disponible auprès de Microsoft Product Support Services. En général, si vous appliquez ce correctif logiciel après la mise à niveau vers Windows Server 2003, il vérifiera que les fichiers MDAC 2.8 ont été installés.
Pour plus d’informations sur ce correctif, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
Important:
Pour plus d’informations sur ce correctif, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
Important:
- Parfois, le correctif cumulatif de MDAC 2.8 ne s’installera pas du tout en raison de problèmes avec la configuration actuelle de MDAC sur l’ordinateur. Si ce problème se produit, contactez les Services de Support technique Microsoft pour poursuivre le dépannage.
- Si vous avez installé le correctif cumulatif de MDAC 2.8 et que vous continuez à rencontrer ces symptômes, contactez les Services de Support technique de Microsoft pour un dépannage supplémentaire.
- Si vous avez rencontré ces symptômes et un plan de mise à niveau de plusieurs ordinateurs, contactez les Services de Support technique Microsoft pour des étapes supplémentaires pour éviter ce problème sur d’autres ordinateurs.