Message d’erreur lorsque vous essayez d’imprimer un rapport dans Microsoft Dynamics CRM 4,0 : « impossible de charger le contrôle d’impression client »

S’applique à : Dynamics CRM 4.0

Symptômes


Lorsque vous essayez d’imprimer un rapport dans Microsoft Dynamics CRM 4,0, le message d’erreur suivant s’affiche :
Impossible de charger le contrôle d’impression client.
Ce problème survient si vous installez la mise à jour pour SQL Server 2005 Service Pack 2 (GDR). Pour plus d’informations sur la mise à jour pour SQL Server 2005 Service Pack 2 GDR, cliquez sur le numéro ci-dessous pour consulter l’article de la base de connaissances Microsoft :
954606 MS08-052 : description de la mise à jour de sécurité pour GDI+ pour SQL Server 2005 Service Pack 2 GDR : 9 septembre 2008

Cause


Ce problème survient parce que la mise à jour de SQL Server 2005 Service Pack 2 GDR met à jour le numéro de version de la classe RSClientPrint. Par conséquent, le contrôle ReportViewer doit également être mis à jour.

Résolution


Pour résoudre ce problème, utilisez l’une des méthodes suivantes : 
  • Installer la visionneuse de rapports redistribuable 2005 Service Pack 1 Pour obtenir la visionneuse de rapports 2005 Service Pack 1, rendez-vous sur le site Web de Microsoft suivant :
  • Installez le package de mise à jour cumulative 9 pour SQL Server 2005 Service Pack 2. Pour plus d’informations sur le package de mise à jour cumulative 9 pour SQL Server 2005 Service Pack 2, cliquez sur le numéro ci-dessous pour consulter l’article de la base de connaissances Microsoft :  
    953752 Package de mise à jour cumulative 9 pour SQL Server 2005 Service Pack 2  
    Si vous continuez à recevoir le message d’erreur mentionné dans la section symptômes après l’installation de la mise à jour cumulative 9, supprimez la classe RSClientPrint . Pour cela, procédez comme suit :  
    1. Démarrez Windows Internet Explorer.
    2. Dans le menu Outils, cliquez sur Options Internet.
    3. Suivez la procédure appropriée :  
      • Dans Windows Internet Explorer 7, cliquez sur paramètres dans la zone historique de navigation , puis cliquez sur Afficher les objets.
      • Dans Microsoft Internet Explorer 6, cliquez sur paramètres dans la zone fichiers Internet temporaires , puis cliquez sur afficher les objets.
    4. Cliquez avec le bouton droit sur classe RSClientPrint, puis cliquez sur supprimer.

Références


Pour plus d’informations, reportez-vous au site web de Microsoft à l’adresse suivante :