Résoudre les problèmes liés à une composition endommagée dans Publisher


Pour obtenir la version 98 de Microsoft Publisher, voir 191131 .

Résumé


Si vous observez un comportement inattendu lors de l’utilisation d’une composition dans Microsoft Publisher, il est possible que la composition soit endommagée. Les symptômes d’une composition endommagée sont les suivants :
  • Vous recevez une erreur de page non valide, une erreur de protection générale ou un message d’erreur d’instruction interdit.
  • Lorsque vous essayez d’ouvrir la composition, l’un des messages d’erreur suivants s’affiche :
    -Il ne s’agit pas d’une composition Publisher.
    -Publisher ne peut pas ouvrir le type de fichier représenté par <nom de fichier>.
    -Le fichier est manquant.
  • Vous recevez un message d’erreur indiquant que la mémoire est insuffisante ou le message d’erreur « ressources système faible » s’affiche.
Remarque Vous risquez de recevoir l’un de ces messages d’erreur en raison d’une composition endommagée. Toutefois, si ce comportement ne se produit que lorsque vous utilisez une composition particulière, celle-ci est probablement endommagée.

Informations supplémentaires


Pour résoudre ce problème, redémarrez l’ordinateur en mode sans échec. Utilisez ensuite les méthodes de dépannage appropriées pour votre problème.Remarque La procédure suivante peut varier en fonction de la version de Microsoft Windows installée sur votre ordinateur. Si tel est le cas, reportez-vous à la documentation de votre produit pour exécuter cette procédure.

Redémarrer l’ordinateur en mode sans échec

Pour redémarrer l’ordinateur en mode sans échec, utilisez la méthode appropriée pour votre version de Microsoft Windows.
  1. Fermez, puis redémarrez l’ordinateur.
  2. Lorsque le message « Veuillez sélectionner le système d’exploitation à démarrer » s’affiche, appuyez sur la touche F8.
  3. Dans le menu Options avancées de Windows , utilisez les touches de direction pour sélectionner mode sans échec, puis appuyez sur entrée.
  4. Si vous disposez d’un ordinateur double démarrage ou d’un ordinateur de démarrage multiple, sélectionnez le système d’exploitation approprié dans la liste, puis appuyez sur entrée.
Pour plus d’informations sur le mode sans échec, cliquez sur les numéros d’article suivants pour consulter les Articles de la base de connaissances Microsoft :
315222 Description des options de démarrage en mode sans échec dans Windows XP
202485 Description du mode de démarrage sans échec dans Windows 2000
180902 Démarrer un ordinateur fonctionnant sous Windows 98 en mode sans échec

Essayer d’ouvrir la composition

Après le démarrage de l’ordinateur en mode sans échec, essayez d’ouvrir la composition. Si vous ne recevez pas de message d’erreur, un programme ou un appareil qui est chargé lorsque l’ordinateur est en mode normal peut interférer avec la composition.

Si vous ne parvenez pas à ouvrir la composition

Si vous ne parvenez pas à ouvrir la composition après le démarrage de l’ordinateur en mode sans échec, utilisez les méthodes suivantes dans l’ordre dans lequel elles sont présentées.

Coller la composition dans le fichier du programme Publisher

Vous pourrez peut-être ouvrir la composition en la collant dans le fichier du programme Publisher. Pour cela, procédez comme suit :
  1. Démarrez l’Explorateur Windows.
  2. Recherchez le fichier de composition.
  3. Cliquez avec le bouton droit sur le fichier de composition, puis cliquez sur copier.
  4. Fermez l’Explorateur Windows.
  5. Cliquez sur Démarrer, sur exécuter, tapez l’une des lignes suivantes dans la zone ouvrir , puis cliquez sur OK:
    Pour Publisher 2003c:\Program Files\Microsoft Office\Office11pour Publisher 2002c:\Program Files\Microsoft Office\Office10pour Publisher 2000C:\Program Files\Microsoft Office\Office
  6. Cliquez avec le bouton droit sur le fichier programme Mspub. exe , puis cliquez sur coller.
Si vous ne parvenez pas à ouvrir la composition, passez à la méthode suivante.

Double-cliquez sur le fichier de composition dans l’Explorateur Windows

Pour double-cliquer sur le fichier de composition dans l’Explorateur Windows, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur l’Explorateur Windows.
  2. Recherchez le fichier de composition.
  3. Double-cliquez sur le fichier de composition.
Si vous ne parvenez pas à ouvrir la composition, passez à la méthode suivante.

Configurer Publisher pour masquer les images

Pour configurer Publisher pour masquer les images, procédez comme suit :
  1. Démarrez Publisher, puis ouvrez une nouvelle composition vierge.
  2. Dans le menu affichage , cliquez sur affichage d’image dans Publisher 2000 ou cliquez sur images dans publisher 2003 ou Publisher 2002.
  3. Cliquez sur Masquer les images, puis cliquez sur OK.
  4. Dans le menu Fichier, cliquez sur Ouvrir.
  5. Recherchez le fichier de composition.
  6. Cliquez pour sélectionner la composition, puis cliquez sur ouvrir.
Si vous pouvez ouvrir la composition, la composition peut contenir un objet endommagé ou un espace réservé d’objet. Pour supprimer ou remplacer un objet ou un espace réservé d’objet endommagé, passez à la méthode suivante. Si vous ne parvenez pas à ouvrir la composition, accédez à la méthode « copier la composition sur un deuxième ordinateur ».

Rechercher et supprimer un objet ou un espace réservé d’objet endommagé

Pour rechercher et supprimer un objet ou un espace réservé d’objet endommagé, procédez comme suit :
  1. Dans la composition, cliquez avec le bouton droit sur un espace réservé d’objet, puis cliquez sur Supprimer l’objet.
  2. Dans le menu Fichier, cliquez sur Enregistrer sous.
  3. Dans la zone nom , tapez un nouveau nom pour la composition, puis cliquez sur Enregistrer.
  4. Dans le menu affichage , cliquez sur affichage d’image dans Publisher 2000 ou cliquez sur images dans publisher 2003 ou Publisher 2002.
  5. Cliquez sur affichage détaillé, puis cliquez sur OK.Remarque Si un message d’erreur s’affiche, passez à l’étape 8.
  6. Dans le menu Fichier, cliquez sur Fermer.
  7. Dans le menu fichier , cliquez sur ouvrir, puis sur la composition que vous avez enregistrée à l’étape 3. Si vous pouvez ouvrir la composition, l’objet ou l’espace réservé d’objet que vous avez supprimé à l’étape 1 est endommagé. Ajustez votre disposition à l’espace réservé objet ou objet manquant. Vous pouvez également dessiner un nouvel espace réservé d’objet et remplacer l’objet supprimé par un objet qui n’est pas endommagé. Pour ce faire, utilisez la méthode adaptée à votre source d’objet.À partir de la Galerie d’images ClipArt
    1. Dans le menu insertion , pointez sur image, puis cliquez sur image clipart.
    2. Dans l’une des catégories disponibles, cliquez pour insérer l’image, le son ou le clip animé de votre choix.
    3. Enregistrez et fermez la composition. Ensuite, essayez à nouveau d’ouvrir la composition.
    À partir d’un emplacement autre que la Galerie d’images ClipArt
    1. Utilisez l’outil cadre d’image pour dessiner un nouvel espace réservé d’objet.
    2. Cliquez pour sélectionner l’espace réservé, pointez sur image dans le menu Insérer , puis cliquez sur à partir du fichier.
    3. Recherchez l’image que vous voulez insérer, puis cliquez dessus pour la sélectionner.
    4. Cliquez sur Insérer.
    5. Enregistrez et fermez la composition. Ensuite, essayez à nouveau d’ouvrir la composition.
    Si vous ne parvenez pas à ouvrir la composition, répétez la méthode « configurer Publisher pour masquer les images ». Ensuite, passez à l’étape 8.
  8. Répétez les étapes 1 à 7 jusqu’à ce que vous puissiez ouvrir la composition avec l’option d' affichage détaillée activée.
  9. Lorsque vous pouvez ouvrir la composition, utilisez l’une des méthodes suivantes :
    • Remplacez l’objet ou l’espace réservé d’objet supprimé par un espace de passe qui n’est pas endommagé.
    • Ajustez la disposition à l’espace réservé objet ou objet manquant.
  10. Dans le menu fichier , cliquez sur Enregistrer.
Si vous ne parvenez toujours pas à ouvrir la composition, passez à la méthode suivante.

Déplacer le fichier de la composition vers un autre disque

Si votre fichier de composition se trouve sur un disque amovible, tel qu’une disquette ou un disque zip, il est possible que Windows ne puisse pas lire le fichier. Dans ce scénario, copiez le fichier sur le disque dur. Si vous ne parvenez pas à copier le fichier à partir du disque amovible, il est possible que le fichier soit croisé avec d’autres fichiers ou dossiers. Par ailleurs, il est possible que le fichier se trouve dans un secteur endommagé du disque. Dans l’un des deux scénarios, accédez à la méthode « exécuter la vérification des erreurs sur le disque ».

Copier la composition sur un deuxième ordinateur

Dans certains cas, vous pouvez ouvrir une composition endommagée après avoir copié la composition sur un deuxième ordinateur sur lequel Publisher est installé. Pour cela, procédez comme suit :
  1. Démarrez l’Explorateur Windows.
  2. Recherchez le fichier de composition.
  3. Cliquez avec le bouton droit sur le fichier de composition, puis cliquez sur copier.
  4. Pour copier la composition sur un deuxième ordinateur, utilisez l’une des méthodes suivantes :
    • Copiez le fichier de la composition sur un disque amovible, tel qu’une disquette ou un disque zip. Copiez ensuite la composition à partir du disque amovible sur un autre ordinateur.
    • Copiez le fichier de la composition sur un deuxième ordinateur via un réseau.
  5. Sur le deuxième ordinateur, ouvrez l’Explorateur Windows.
  6. Recherchez et double-cliquez sur le fichier de composition.
Si vous pouvez ouvrir la composition, examinez chaque page pour savoir s’il existe un espace réservé d’objet vide. Pour chaque espace réservé d’objet vide que vous trouvez, cliquez avec le bouton droit sur le fichier, puis cliquez sur supprimer. Enregistrez la composition, puis recopiez le fichier de la composition sur le premier ordinateur. Si vous ne parvenez pas à ouvrir la composition, passez à la méthode suivante.

Exécuter la vérification des erreurs sur le disque

Exécutez la vérification des erreurs pour réparer toutes les erreurs sur le disque. Demandez la vérification des erreurs pour réparer tous les fichiers à liaisons croisées et convertir des fragments perdus en fichiers.Remarque Même si la vérification des erreurs peut déterminer que le fichier de publication est croisé, puis réparez le fichier, cette méthode ne garantit pas que Publisher peut lire le fichier après la vérification des erreurs. Pour exécuter la vérification des erreurs, procédez comme suit :
  1. Fermez tous les programmes en cours d’exécution.
  2. Double-cliquez sur l’icône du poste de travail sur l' ordinateur de bureau.
  3. Cliquez avec le bouton droit sur le disque local que vous voulez vérifier, puis cliquez sur Propriétés.
  4. Dans l’onglet Outils , cliquez sur vérifier sous vérification des erreurs.
  5. Sous options de vérification du disque, activez la case à cocher Rechercher et tenter une récupération des secteurs défectueux . Puis cliquez sur Démarrer.
  6. Lorsque la vérification des erreurs est terminée lors de l’analyse et de la résolution des erreurs, cliquez sur Fermer.
  7. Démarrez Publisher, puis essayez d’ouvrir la composition.
Si vous ne parvenez pas à ouvrir la composition, passez à la méthode suivante.

Essayer de récupérer le texte de la composition

Cette méthode décrit comment récupérer le texte de votre composition endommagée et insérer le texte récupéré dans une nouvelle composition vierge. Vous devez ensuite recréer la disposition et réinsérer tous les objets de la composition endommagée dans la nouvelle composition. Pour récupérer du texte à partir de la composition endommagée puis insérer le texte dans une nouvelle composition, procédez comme suit :
  1. Démarrez Publisher, puis créez une nouvelle composition vide.
  2. Utilisez l’outil cadre de texte dans Publisher 2000 ou l’outil zone de texte dans Publisher 2003 ou dans Publisher 2002 pour dessiner un cadre de texte sur la page vierge.
  3. Dans le menu insertion , cliquez sur fichier texte.
  4. Dans la zone type de fichiers , cliquez surfichiers Publisher (*. pub).
  5. Cliquez sur votre composition, puis cliquez sur OK. Si vous recevez un message indiquant la manière dont le texte que vous voulez insérer tient sur la page, cliquez sur Oui.

Si vous pouvez ouvrir la composition endommagée

Si vous pouvez ouvrir la composition en mode sans échec, utilisez l’une des méthodes suivantes pour recréer votre composition.

Copier des pages de la composition endommagée vers une nouvelle composition

Pour copier les pages d’une composition endommagée vers une nouvelle composition, procédez comme suit :
  1. Démarrez Publisher, puis ouvrez la composition endommagée.
  2. Démarrez une autre instance de Publisher.
  3. Créez une nouvelle composition vierge configurée comme étant la composition endommagée.
  4. Dans la composition endommagée, sélectionnez tous les objets d’une page spécifique.
  5. Dans le menu Edition, cliquez sur Copier.
  6. Appuyez sur ALT + TAB pour passer à la nouvelle composition.
  7. Dans le menu Edition, cliquez sur Coller.
  8. Répétez les étapes 4 à 7 jusqu’à ce que toutes les pages soient collées dans la nouvelle composition.
Remarque Si vous remarquez un comportement étrange dans la nouvelle composition après la copie d’une page dans la nouvelle composition, celle-ci contient probablement un objet endommagé. Dans ce scénario, utilisez l’une des méthodes suivantes pour contourner ce problème :
  • Copiez un objet à la fois à partir de la page problème vers la nouvelle composition pour déterminer quel objet est endommagé. Ensuite, veillez à ne pas inclure l’objet endommagé dans la nouvelle composition.
  • Reconstruisez la page problème dans la nouvelle composition.
Si chaque page de la composition est endommagée, passez à la méthode suivante.

Enregistrer la composition au format RTF (Rich Text Format)

Si le dommage de votre composition semble répandu, enregistrez la composition au format RTF pour récupérer le texte de la composition. Pour cela, procédez comme suit :
  1. Ouvrez la composition.
  2. Cliquez sur un cadre de texte.
  3. Dans la zone type de fichier , cliquez sur RichText Format (*. rtf).
  4. Dans la zone nom de fichier , tapez le nom du fichier souhaité.
  5. Dans la zone enregistrer dans , cliquez sur le dossier dans lequel vous voulez enregistrer le texte de votre composition.
  6. Cliquez sur Enregistrer, puis sur OK.
  7. Fermez la composition.
  8. Dans le menu Fichier, cliquez sur Ouvrir.
  9. Dans la zone type de fichiers , cliquez sur RichText Format (*. rtf).
  10. Dans la liste des fichiers, cliquez sur le fichier texte que vous avez enregistré à l’étape 6.
  11. Cliquez sur Ouvrir.  
  12. Mettre en forme le texte d’une façon qui duplique la façon dont le texte est disposé et mis en forme dans la composition endommagée.

Références


Pour plus d’informations sur la façon de résoudre les problèmes de publications Publisher endommagées, cliquez sur les numéros d’article suivants pour consulter les Articles de la base de connaissances Microsoft :
315222 Description des options de démarrage en mode sans échec dans Windows XP
164519 Résolution des erreurs d’Office Kernel32. dll sous Windows 95
179095 Message d’erreur de liaison de fichier lors de l’ouverture de Publisher