It takes longer for an eSATA hard disk drive to disappear from Device Manager and from Windows Explorer in Windows 7 SP1 than in Windows 7

S’applique à : Windows 7 Service Pack 1Windows 7 EnterpriseWindows 7 Home Premium Plus

Symptoms


You remove an external Serial Advanced Technology Attachment (eSATA) hard disk drive from a computer that is running Windows 7 Service Pack 1 (SP1). However, it takes longer than expected for the eSATA hard disk drive to disappear from Device Manager or from Windows Explorer. 

For example, it may take 60 seconds for an eSATA hard disk drive to disappear from Device Manager or from Windows Explorer in Windows 7 SP1. However, it takes only 10 seconds for the drive to disappear in Windows 7. Additionally, if you remove an eSATA hard disk drive from a computer and then connect a new eSATA hard disk drive to the computer before Windows 7 SP1 detects the changes, the new eSATA hard disk may not work correctly.

Cause


This behavior is by design.

The ATAport and ATAPI driver model is mainly designed for Serial Advanced Technology Attachment (SATA) hard disk drives that use the Parallel Advanced Technology Attachment (PATA) mode. Therefore, when a hot-plug removal interrupt is received, the ATAport or ATAPI driver performs a bus rescan to validate the current state of the device. Because the device is missing, the ATAport or ATAPI driver must wait for the bus rescan commands to time out. This time-out value was increased from 10 seconds to 60 seconds to resolve the issue that is described in the following Microsoft Knowledge Base article:
977178 You receive various Stop error messages in Windows 7 or in Windows Server 2008 R2 when you try to resume a computer that has a large SATA hard disk

Workaround


Wait 60 seconds for Windows 7 SP1 to recognize that the eSATA hard disk drive has been removed.