Dynamics GP 2010 Utilities error "The Microsoft SQL Server database compatibility level for your Microsoft Dynamics GP databases is not supported. Change the compatibility level to SQL Server 2005 or later, refer to KB article 2399690"


Symptoms


When you run Microsoft Dynamics GP 2010 Utilities following the installation of Service Pack 1 for Microsoft Dynamics GP 2010, you receive the following error message: 

The Microsoft SQL Server database compatibility level for your Microsoft Dynamics GP database is not supported. Change the level to SQL Server 2005 or later, refer to KB article 2399690 for additional information.

Cause


The database compatibility level of one or more Microsoft Dynamics GP databases is not set to SQL Server 2005 (90) or SQL Server 2008 (100). This is a new requirement starting with Microsoft Dynamics GP 2010 Service Pack 1.

Resolution


Change the database compatibility level of all Microsoft Dynamics GP databases to SQL Server 2005 (90) if running Microsoft SQL Server 2005 or to SQL Server 2008 (100) if running SQL Server 2008.

IMPORTANT NOTE: If an integrating application or customization requires the database compatibility to be something other than SQL Server 2005 (90) or SQL Server 2008 (100), change the database compatibility temporarily for the Service Pack 1 installation and then change it back to the required setting. Please be aware that this process will have to be performed for every hotfix and service pack installation following Service Pack 1 if the compatibility level is set back to a version older than SQL Server 2005 (90).

Perform the following steps:

1. At the Microsoft SQL Server, click Start, click All Programs, click Microsoft SQL Server 2005 or Microsoft SQL Server 2008, and then click SQL Server Management Studio.

2. Login to your Microsoft SQL Server as the sa user.

3. In the Object Explorer area, expand Databases.

4. Right-click the DYNAMICS database and then click Properties.

5. In the Select a page area, click Options.

6. Click to select the drop down list next to Compatibility level and then select SQL Server 2005 (90) if running Microsoft SQL Server 2005 or select SQL Server 2008 (100) if running Microsoft SQL Server 2008.

7. Click OK.

8. Repeat Steps 4-7 for each Microsoft Dynamics GP company database.

9. Start Microsoft Dynamics GP 2010 Utilities to continue the service pack installation.