Impossible de se connecter à l’aide d’Exchange ActiveSync en raison de la consommation des ressources Exchange


Symptômes


Initial symptômes inclura des utilisateurs n’est pas en mesure de synchroniser leurs périphériques avec Exchange.  En outre, les symptômes suivants peuvent se produire :
  • Dans le journal d’Application sur le serveur Exchange, vous pouvez afficher les événements suivants :

Source de l’événement : Server ActiveSync
L’ID d’événement : 3007
Description :
Délai de réponse de serveur de boîtes aux lettres d’Exchange : serveur : [mail.contoso.com] utilisateur : [user@contoso.com]. Exchange ActiveSync Server n’a pas pu communiquer avec le serveur de boîtes aux lettres Exchange en temps voulu. Vérifiez que la boîte aux lettres Exchange Server fonctionne correctement et n’est pas surchargé.

Source de l’événement : Server ActiveSync
L’ID d’événement : 3014
Description:
La boîte aux lettres Exchange Server : [mail.contoso.com] a atteint son seuil de délai d’attente. Le serveur de boîte aux lettres sera protégé de nouvelles requêtes pendant [60] secondes.

  • Le nombre de connexions autorisées de RPC sur le serveur de boîte aux lettres peut dépasser la limite recommandée ainsi.
    Le nombre maximal de demandes RPC qui peuvent s’exécuter à un moment donné avant le début de la banque d’informations rejette les nouvelles connexions est de 500 pour Exchange 2007 et 2010, cependant, le compteur doit rester inférieure à 70 à tout moment. Quoi que ce soit au-dessus indique un goulot d’étranglement de performances. Pour confirmer ce comportement, un peut vérifier le compteur de l’Analyseur de performances « Msexchangeis\demandes » qui vous indique si le serveur est supérieure aux limites recommandées.

    Veuillez consulter http://technet.microsoft.com/en-us/library/bb201689%28EXCHG.80%29.aspx

  • Vous verrez dans les fichiers journaux W3SVC HTTP 409 et 503 réponses renvoyées pour les demandes de Microsoft-Server-ActiveSync.
    Vous pouvez également voir que l’erreur renvoyée « TooManyJobsQueued » dans les journaux W3SVC. Voir les exemples suivants :

    2010-09-09 21:35:35 W3SVC1 10.0.0.10 POST /Microsoft-Server-ActiveSync/default.eas utilisateur = < utilisateur > & DeviceId = < DeviceID > & DeviceType = < Type > & Cmd = synchronisation = Ping = < données > 443 domaine\utilisateur 10.0.0.20 < UserAgent > 503 0 0

    2010-09-15 : 00:00:02 W3SVC1 155.109.199.51 valider /Microsoft-Server-ActiveSync/default.eas Cmd = Ping & utilisateur = < utilisateur > & DeviceId = < DeviceID > & DeviceType = < Type > & journal = erreur : TooManyJobsQueued_ 443 domaine\utilisateur 10.0.0.20 < UserAgent 503 > 0 0

  • Les journaux HTTPErr affiche Connection_Dropped pour les demandes de /Microsoft-Server-ActiveSync.
    Vous devez être en mesure de voir que le s-port ou Source provient de la Connection_Dropped atteint un nombre relativement élevé. Par exemple :

    2010-09-09 00:27:25 10.0.0.10 64637 10.0.0.20 443 HTTP/1.1 POST /Microsoft-Server-ActiveSync ? Utilisateur = < utilisateur > & DeviceId = < DeviceID > & DeviceType = < Type > & Cmd = Ping - 1 Connection_Dropped MSExchangeSyncAppPool
  • Pour Exchange 2003, le serveur soit dépensé de mémoire de Pool de Non-Paged (NPP).
    Que la limite est atteinte, NPP est consommé et HTTP.sys commence à rejeter les connexions HTTP une fois que le serveur commence à maximum 100 mégaoctets de NPP en fonction de la configuration du serveur. Lorsque le serveur atteint près de 108 Mo, HTTP.sys ne parviendra pas à toutes les connexions. NPP peut être vérifié à l’aide du Gestionnaire des tâches et d’affichage des performances et de vérification de la mémoire du noyau.    
  • Pour plus d’informations sur Exchange et NPP, voir http://technet.microsoft.com/en-us/library/aa996269(EXCHG.80).aspx

    Pour plus d’informations sur l’utilisation de Netstat, reportez-vous à la section http://technet.microsoft.com/en-us/library/cc940097.aspx

    Pour plus d’informations sur le téléchargement et l’utilisation de TCPView, consultez http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

     

    Cause


    Cela peut se produire pour les raisons connexions des périphériques mobiles ou des problèmes avec le logiciel du périphérique.  Il y a plusieurs causes principales pour les échecs de connexion et les causes de l’épuisement de la mémoire :

    1. le serveur commence à rejeter les connexions, en raison du nombre de requêtes sur le serveur, ou les demandes dépassent le nombre de connexions autorisées de IIS de Pool d’Application. De la même façon, l’atteindre la limite de port TCP sur l’ou les serveurs Exchange est à l’origine.

    Remarque : Plus probablement, les serveurs peuvent atteindre un des autres limites (longueur de file d’attente du Pool Application sur les autorités de certification ou des demandes RPC sur le serveur de boîtes aux lettres) avant d’approcher de carence de Port TCP.

    L’article suivant explique épuisement du port :
    http://technet.microsoft.com/en-us/library/cc540453(EXCHG.80).aspx

    Les articles suivants de mentionnent l’utilisation de connexions MaxUserPort et TCP dans Windows et Exchange

    http://technet.microsoft.com/en-us/library/cc940037.aspx

    http://technet.microsoft.com/en-us/library/bb397382(EXCHG.80).aspx

    2. une synchronisation de périphérique mobile à l’aide d’Exchange ActiveSync peut simuler le comportement d’une attaque de déni de service sur un serveur. Des exemples sont répertoriées dans l’article suivant :
    http://technet.microsoft.com/en-us/library/cc182260.aspx

    3. le Pool d’applications reçoit les requêtes plus rapidement qu’il puisse les traiter.  Cette opération est abordée dans l’article suivant :
    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9701f9dd-d40b-4d24-a2df-1d1abc13f764.mspx?mfr=true

     

    Résolution


    Pour arrêter ces périphériques de consommer les ressources Exchange et afin d’éviter la charge de travail, les périphériques suspects doit être bloqué.  

    IMPORTANT : Il existe un problème connu avec iPhone 4.0 du système d’exploitation défini par l’agent utilisateur 801.293 - http://support.apple.com/kb/TS3398

    Tous les journaux IIS qui contiennent cet agent utilisateur doivent être signalés, et que le propriétaire de ce périphérique doit mettre à jour OS 4.1 ou version ultérieure (de préférence, la version iOS 4.3.x). Est recommandé que ces utilisateurs doit être bloquée en attendant.

    Les périphériques peuvent être bloquées par la désactivation de l’accès d’Exchange ActiveSync pour le propriétaire du périphérique, la désactivation de l’appareil ou à l’aide d’un filtre d’Internet Security and Acceleration (ISA) ou ForeFront Threat Management Gateway (TMG).

    Pour plus d’informations sur le blocage de périphériques, consultez le billet suivant sur le blog de l’équipe de Exchange de Microsoft (EHLO) :

    http://msexchangeteam.com/archive/2008/09/05/449757.aspx

    Remarque : , Certains périphériques peuvent continuer à essayer de se connecter au serveur Exchange (à l’origine d’un grand nombre de connexions TCP) même lorsque l’utilisateur est désactivé pour une utilisation d’Exchange ActiveSync. Nous vous recommandons de désactiver le périphérique ou bloquer le périphérique à l’aide d’un filtre ISA.

    Exchange Server 2010

    Si l’utilisateur d’appareil suspect à l’utilisateur a une boîte aux lettres Exchange 2010, elle peut être activée et pour tous les utilisateurs d’Exchange ActiveSync empêcher des périphériques de surcharger le serveur Exchange. Consultez l’article suivant à partir de Microsoft TechNet en ligne :

     http://technet.microsoft.com/en-us/library/dd297964.aspx

    Étapes à suivre pour effectuer cette opération sont inclus dans cet article, toutefois ici sont des exemples :

    $un = Get-ThrottlingPolicy | WHERE-object {$_. IsDefault – eq $true}

    $un | Set-ThrottlingPolicy-EASMaxConcurrency 10

    Pour plus d’informations sur la définition des stratégies de limitation, consultez la rubrique suivante de TechNet en ligne :

     http://technet.microsoft.com/en-us/library/dd298094.aspx

    Facteurs supplémentaires pour vérifier qui influencent connexions par périphérique

    1. Existe-t-il des grande nombre d’éléments dans les dossiers principales (qui est le principal dossier boîte de réception) ? Lorsqu’il existe plusieurs éléments de milliers dans le dossier boîte de réception et le périphérique est de la synchronisation de tous ces éléments, vous verrez un grand nombre de connexions/requêtes à partir de ce périphérique pour télécharger l’ensemble de ces éléments. La solution comprend :

      a. Configurer le périphérique pour synchroniser uniquement le dernier jour ou pas plus de 3 jours, en fonction du nombre d’éléments de cet utilisateur reçoit jour.
      b Réduire le nombre d’éléments dans la boîte aux lettres
    2. Les comptes d’utilisateurs sont désactivés pour Exchange ActiveSync ? Cela peut augmenter le nombre de connexions de périphérique sur le serveur. Si le périphérique envoie toujours plusieurs requêtes sur le serveur, puis mettez le périphérique hors tension ou mettre un filtre en place sur ISA pour bloquer l’ID de périphérique.
    3. Les utilisateurs dépassent leur limite de quota de boîte aux lettres ? Dans ce cas, le périphérique ne sera pas en mesure de synchroniser de nouveaux éléments à la boîte aux lettres et peut continuer d’essayer indéfiniment.
    4. Y a-t-il des tailles limites des messages dans l’organisation ? S’il n’y a aucune limite, vous possédez peut-être un périphérique qui tente de synchroniser de grandes quantités de données.

      Remarque : En outre, continuer à surveiller les connexions du périphérique à l’aide d’analyseur de journal pour les périphériques suspects. Pour obtenir de l’aide en utilisant l’Analyseur de journal, reportez-vous à la section plus d’informations.

    Lorsqu’un périphérique suspect est détecté, nous recommandons que les clients contacter le fabricant du périphérique pour obtenir de l’aide à déterminer pourquoi le périphérique envoie le nombre excessif de demandes à Exchange.

    Reportez-vous à la section «étapes qui aideront les administrateurs lors de la résolution des problèmes :» dans la section informations supplémentaires pour effectuer des actions supplémentaires, les administrateurs peuvent tirer pour tenter d’améliorer les performances lors de la résolution des problèmes.

    Plus d'informations


    Les périphériques sont suspects ?
    Généralement si un périphérique envoie plus de 1000 demandes par jour, nous vous recommandons d’étudier.

    Si le nombre d’accès (requêtes) est au-dessus de 1500, il existe peut-être un problème sur le périphérique ou l’environnement. Le périphérique et l’activité de l’utilisateur doivent être examinées.

    Lisez le message suivant dans le blog de l’équipe Exchange et. Fichier ps1 qui peut être utilisé avec Windows Powershell pour analyser les fichiers journaux IIS pour n’importe quelle version d’Exchange Server.

    Un script pour résoudre les problèmes avec Exchange ActiveSync
    http://blogs.technet.com/b/exchange/archive/2012/01/31/a-script-to-troubleshoot-issues-with-exchange-activesync.aspx

    Script de ActiveSyncReport
    http://gallery.technet.microsoft.com/scriptcenter/ActiveSyncReport-script-a2417a84

    Analyseur de journal peut être utilisée sans le script, mais le script a été conçu pour filtrer en fonction de critères spécifiés dans la ligne de commande utilisée.  Utilisez le script ci-dessus, les rapports ou les alertes par courrier électronique peuvent également être créées.

    Étapes qui vous aiderez les administrateurs lors de la résolution des problèmes :

    Les options suivantes ne résoudra pas le problème. Qu’ils vous donneront plus de temps pour analyser les journaux IIS pour déterminer les périphériques sont suspects.

    • Réduire la valeur de temps persistantes sur les serveurs de boîte aux lettres Exchange pour envoyer un Conserver actif toutes les 30 minutes aux autorités de certification au lieu de toutes les 2 heures.

      Le conserver actif la valeur 30 minutes (1800000) dans le Registre, décrit dans l’article suivant dans la Base de connaissances Microsoft en ligne :
      http://support.microsoft.com/kb/324270  

      Les informations de valeur de Registre sont inférieur à :
      Chemin d’accès : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\
      Nom de la valeur: KeepAliveTime
      Type de valeur: REG_DWORD-temps en millisecondes
      Plage valide : 1-0xFFFFFFFF.
      Par défaut : 7 200 000 (deux heures)

      Cette valeur contrôle la fréquence à laquelle TCP tente de vérifier qu’une connexion inactive est intacte par l’envoi d’un paquet persistant. Si l’ordinateur distant est toujours joignable, il reconnaît le paquet persistant. Les paquets persistants ne sont pas envoyés par défaut. Vous pouvez utiliser un programme pour configurer cette valeur sur une connexion. La valeur recommandée est 1,800,000 (égal à 30 minutes). (Décimal) (Nécessite un redémarrage du serveur)

      Surveiller ce paramètre et si les ports de serveur sont toujours épuisement, cela peut-être être abaissé à 15 minutes au lieu de 30 minutes.
    • Augmentez le délai de connexion IIS dans IIS

      La valeur recommandée et par défaut doivent être de 120 secondes. Si elle est définie à une valeur plus élevée, il doit alors être définie entre les 120 secondes minimum recommandés de valeur à la deuxième valeur maximale 300.
      Consultez la rubrique suivante sur TechNet en ligne pour plus d’informations :

      http://technet.microsoft.com/en-us/library/cc182260.aspx

      Ceci est possible en via les propriétés du Site Web par défaut en modifiant la valeur de délai de connexion (en secondes).
    • Augmenter le nombre de connexions de IIS (longueur de la file d’attente) pour le ExchangeApplicationPool sur la boîte aux lettres de Exchange 2003 et les serveurs frontaux :


      Utilisez le Gestionnaire des Services Internet pour désactiver le processus de travail de recyclage dans IIS 6.0
      1. Démarrer Internet Information Services (IIS) Manager.
      2. Développez l’ordinateur local, développez Pools d’applications, les pools d’applications ExchangeApplicationPool d’avec le bouton droit et puis cliquez sur Propriétés.
      3. Cliquez pour désactiver la case à cocher de recyclage travailleur processus (en minutes), puis cliquez sur OK.

      Utilisez le Gestionnaire des Services Internet pour augmenter la longueur de la file d’attente dans IIS 6.0
      1. Démarrer Internet Information Services (IIS) Manager.
      2. Développez l’ordinateur local, développez Pools d’applications, cliquez sur le pool d’applications ExchangeApplicationPool et puis cliquez sur Propriétés.
      3. Cliquez sur l’onglet performances, puis modifiez la valeur dans la zone de limite de file d’attente de requête. Remplacez la valeur par défaut de 1000 4000.
      4. Cliquez sur OK.
    • Augmenter le nombre de connexions de IIS (longueur de la file d’attente) pour le MSExchangeSyncAppPool sur l’Exchange 2007 et les serveurs d’accès Client Exchange 2010

      Utilisez le Gestionnaire des Services Internet pour désactiver le recyclage des processus de travail dans IIS 7.0 et version ultérieure (cela doit être désactivée par défaut pour le MSExchangeSyncAppPool)

      1. Démarrer le Gestionnaire des Services Internet.
      2. E développez l’ordinateur local, puis cliquez sur Pools d’applications.
      3. Je n le volet Pools d’applications, cliquez sur le pool d’applications approprié, par exemple MSExchangeSyncAppPool ou le nouveau pool d’applications que vous avez créé et puis cliquez sur Paramètres avancés.
      4. Dans le recyclage de la section, modifiez la valeur de l’intervalle régulier (en minutes). Remplacez la valeur par défaut de 1740 par 0 (zéro). Une valeur égale à zéro désactive le recyclage des processus de travail.
      5. Click OK.
    • Utilisez le Gestionnaire des Services Internet pour augmenter la longueur de la file d’attente dans IIS 7.0 et version ultérieure

      1. Démarrer le Gestionnaire des Services Internet.
      2. Développez l’ordinateur local, puis cliquez sur Pools d’applications.
      3. Dans le volet de Pools d’applications, cliquez sur le pool d’applications approprié, par exemple MSExchangeSyncAppPool ou le nouveau pool d’applications que vous avez créé et puis cliquez sur Paramètres avancés.
      4. En général la section, modifiez la valeur de la longueur de la file d’attente. Remplacez la valeur par défaut de 1000 10000.
    • 5. Click OK

    Remarque : Si vous exécutez Exchange 2007 sur Windows 2003 (IIS 6), suivez les étapes ci-dessus pour augmenter la limite de la file d’attente de la demande pour le MSExchangeSyncAppPool.

    Pour plus d’informations sur la raison pour laquelle il peut être important de modifier ces valeurs pour les Pools d’applications et des liens supplémentaires à « How To » d’informations, consultez la rubrique suivante de TechNet en ligne :

    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9701f9dd-d40b-4d24-a2df-1d1abc13f764.mspx?mfr=true