Les performances sont médiocres lors de l’utilisation du profil utilisateur par défaut personnalisé dans Windows

Cet article fournit une solution aux problèmes qui se produisent lorsque vous utilisez personnaliser les profils utilisateur par défaut.

Produits concernés : Windows 10 (toutes les éditions), Windows Server 2019, Windows Server 2016
Numéro de la base de connaissances d’origine : 4056823

Symptôme

Prenons l’exemple du scénario suivant :

  • Vous créez un profil utilisateur par défaut et vous l’activez.
  • Un nouvel utilisateur ouvre une session à l’aide d’un profil créé à partir du profil par défaut sur un ordinateur Windows 10, Windows Server 2016 ou Windows Server 2019.

Dans ce scénario, vous rencontrez un ou plusieurs des problèmes suivants :

  • L’affichage des icônes de bureau prend beaucoup de temps.

  • Les performances sont médiocres lorsque vous démarrez ou naviguez dans Internet Explorer ou Microsoft Edge.

  • Les erreurs ESENT telles que les suivantes sont enregistrées dans le journal des événements :

    EventLogID : 454
    TaskHostW : (pid)
    WebCacheLocal : « Échec de la récupération/restauration de la base de données avec une erreur inattendue -1907 »

    Remarque

    Le message complet du journal des événements peut également indiquer une association avec un autre emplacement de dossier utilisateur, tel que C :\Users\Administrator.

Cause

Ces problèmes se produisent parce que le profil utilisateur par défaut inclut une copie verrouillée de la base de données du cache d’un autre utilisateur.

Lorsqu’un nouvel utilisateur se connecte à l’ordinateur, le contenu de profil utilisateur par défaut est incorporé dans son nouveau profil. À mesure que l’interpréteur de commandes windows et le bureau commencent à se charger, la base de données ne peut pas être entièrement initialisée pour être utilisée. Les applications qui utilisent la base de données rencontrent des performances négatives ou signalent des erreurs.

Résolution

Pour résoudre le problème, procédez comme suit :

  1. Connectez-vous à chaque ordinateur affecté à l’aide d’un compte disposant d’informations d’identification administratives, puis supprimez le fichier et le dossier masqués suivants s’ils existent :

    Fichier : C :\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Dossier : C :\Users\Default\AppData\Local\Microsoft\Windows\WebCache

  2. Pour chaque compte d’utilisateur sur l’ordinateur, assurez-vous que l’utilisateur est complètement déconnecté et que le profil a été entièrement déchargé, puis supprimez le fichier et le dossier masqués suivants s’il existe :

    Fichier : C :\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Dossier : C :\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache

Remarque

<affectedUserFolder> est un espace réservé pour le nom du dossier de profil utilisateur. Par exemple, pour le compte d’utilisateur Administrateur, le dossier se trouve sous C :\Users\Administrator. Vous devez supprimer les fichiers et dossiers ci-dessus pour chaque compte d’utilisateur affecté sur l’ordinateur.

Comment afficher les fichiers masqués

Pour afficher les fichiers masqués, procédez comme suit :

  1. Dans Windows Explorer, sélectionnez Fichier, puis Options.
  2. Sous l’onglet Affichage , sélectionnez l’option Afficher les fichiers, dossiers et lecteurs masqués .
  3. Désélectionnez l’option Masquer les fichiers du système d’exploitation protégés (recommandé), puis cliquez sur OK.

Remarque

Nous vous recommandons de sélectionner à nouveau les deux options une fois le problème résolu.

Plus d’informations

Étant donné que la base de données du cache est conçue pour être générée par utilisateur au moment de la connexion initiale à un ordinateur individuel, Microsoft ne recommande pas ou ne prend pas en charge l’inclusion de la base de données de cache dans le profil utilisateur par défaut ou tout autre profil utilisateur destiné à être utilisé comme modèle.