Message d'erreur « Service non disponible » lorsque vous parcourez une page Web IIS 6.0 sur un contrôleur de domaine Windows Server 2003


Symptômes


Lorsque vous parcourez une page Web hébergée sur un contrôleur de domaine Microsoft Windows Server 2003, le message d'erreur ASP (Active Server Pages) « Erreur 5 » suivant peut s'afficher :

Service non disponible
Par ailleurs, l'événement d'avertissement suivant peut être enregistré dans le journal des événements Système :

Par ailleurs, l'événement d'erreur suivant peut être enregistré dans le journal des événements Applications :







Lorsque vous utilisez Filemon pour surveiller l'activité des fichiers, un message d'erreur semblable au suivant s'affiche :

3521 Heure w3wp.exe:3168 CREATE C:\WINDOWS\system32\inetsrv\ASP Compiled Templates\PID3168.TMP ACCESS DENIED AUTORITÉ NT\SERVICE RÉSEAU

Cause



Ce problème peut se produire si le serveur qui exécute Microsoft Internet Information Services (IIS) 6.0 est également contrôleur de domaine. Il se produit parce que le pool d'application utilise le compte Autorité NT\Service réseau et que celui-ci peut ne pas avoir d'autorisations d'accès aux dossiers requis.

Résolution



Pour résoudre ce problème, définissez manuellement des autorisations sur les dossiers pour le groupe IIS_WPG, puis définissez des autorisations sur les dossiers pour le compte Autorité NT\Service réseau.



Afin que nous puissions résoudre le problème pour vous, consultez la section « Aidez-moi ». Si vous préférez le résoudre vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi



Pour résoudre ce problème automatiquement, cliquez sur le bouton Fix it ou sur le lien associé. Cliquez sur Exécuter dans la boîte de dialogue Téléchargement de fichier et suivez la procédure indiquée par l'Assistant Résolution.



Remarques
  • Cet Assistant peut n'exister qu'en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.
  • Si vous n'utilisez pas l'ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l'exécuter sur l'ordinateur concerné par le problème.

Consultez ensuite la section « Le problème est-il résolu ? ».



Je résous le problème moi-même


Pour définir des autorisations sur les dossiers pour le groupe IIS_WPG, procédez comme suit :
  1. Démarrez l'Explorateur Windows, puis ouvrez le dossier suivant :
    %systemroot%\Help\iisHelp
  2. Dans le volet droit, cliquez avec le bouton droit sur le dossier Common, puis cliquez sur Partage et sécurité.
  3. Cliquez sur l'onglet Sécurité, cliquez sur Ajouter, tapez IIS_WPG, puis cliquez sur OK.
  4. IIS_WPG étant sélectionné, activez les cases à cocher suivantes dans la colonne Autoriser, puis cliquez sur OK :
    • Lecture et exécution
    • Affichage du contenu du dossier
    • Lecture
  5. Ouvrez le dossier suivant :
    %systemroot%\system32\inetsrv
  6. Dans le volet droit, cliquez avec le bouton droit sur le dossier ASP Compiled Templates, puis cliquez sur Partage et sécurité.
  7. Sous l'onglet Sécurité, cliquez sur le groupe IIS_WPG, puis activez la case à cocher Contrôle total dans la colonne Autoriser. Cliquez sur OK.
  8. Ouvrez le dossier suivant :
    %systemroot%
  9. Dans le volet droit, cliquez avec le bouton droit sur le dossier IIS Temporary Compressed, puis cliquez sur Partage et sécurité.
  10. Sous l'onglet Sécurité, cliquez sur le groupe IIS_WPG, puis activez la case à cocher Contrôle total dans la colonne Autoriser. Cliquez sur OK.
Pour définir des autorisations sur les dossiers du compte Autorité NT\Service réseau, procédez comme suit :
  1. Démarrez l'Explorateur Windows, puis ouvrez le dossier suivant :
    %systemroot%\Help\iisHelp
  2. Dans le volet droit, cliquez avec le bouton droit sur le dossier Common, puis cliquez sur Partage et sécurité.
  3. Cliquez sur l'onglet Sécurité, cliquez sur Ajouter, tapez SERVICE RÉSEAU, puis cliquez sur OK.
  4. NETWORK SERVICE étant sélectionné, activez les cases à cocher suivantes dans la colonne Autoriser, puis cliquez sur OK :
    • Lecture et exécution
    • Affichage du contenu du dossier
    • Lecture
  5. Ouvrez le dossier suivant :
    %systemroot%\system32\inetsrv
  6. Dans le volet droit, cliquez avec le bouton droit sur le dossier ASP Compiled Templates, puis cliquez sur Partage et sécurité.
  7. Cliquez sur l'onglet Sécurité, cliquez sur Ajouter, tapez NETWORK SERVICE, puis cliquez sur OK.
  8. NETWORK SERVICE étant sélectionné, activez la case à cocher Contrôle total dans la colonne Autoriser, puis cliquez sur OK.
  9. Ouvrez le dossier suivant :
    %systemroot%
  10. Dans le volet droit, cliquez avec le bouton droit sur le dossier IIS Temporary Compressed, puis cliquez sur Partage et sécurité.
  11. Cliquez sur l'onglet Sécurité, cliquez sur Ajouter, tapez NETWORK SERVICE, puis cliquez sur OK.
  12. NETWORK SERVICE étant sélectionné, activez la case à cocher Contrôle total dans la colonne Autoriser, puis cliquez sur OK.
À la fin de ces étapes, redémarrez le service d'administration IIS à partir du composant logiciel enfichable Services ou du composant logiciel enfichable Gestion de l'ordinateur.

Contournement


Vous pouvez peut-être contourner temporairement ce problème en redémarrant le service d'administration IIS à partir du composant logiciel enfichable Services ou du composant logiciel enfichable Gestion de l'ordinateur.

Statut


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations


Pour plus d'informations sur un problème semblable mais ayant une cause différente, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.

332097 DCPROMO ne conserve pas les autorisations sur certains dossiers IIS


Le problème est-il résolu ?

  • Vérifiez que le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter le support.
  • Vos commentaires sont les bienvenus. Pour nous faire part de vos commentaires ou d'un problème concernant cette solution, écrivez-nous sur le blog « Aidez-moi » ou envoyez-nous un courrier électronique.