Message d'erreur lorsque vous installez un package de mise à jour .msu sur un ordinateur qui exécute Windows: « L'installateur de Modules Windows doit être mis à jour avant d'installer ce package »

S’applique à : Windows 8.1 EnterpriseWindows 8.1Windows 8.1 Pro

Symptômes


Lorsque vous installez un package de mise à jour .msu sur un ordinateur qui exécute Windows, le message d'erreur suivant s'affiche :
L'installateur de Modules Windows doit être mis à jour avant d'installer ce package. Veuillez mettre à jour l'installateur de Modules Windows sur l'ordinateur, puis recommencez l'installation.
Lorsque vous utilisez un script pour installer le package de mise à jour .msu, l’installation échoue. Lorsque ce problème se produit, le processus de Wusa.exe renvoie code d’erreur 0x800f0823.

Cause


Ce problème se produit car l'installation nécessite une nouvelle version du programme d’installation de modules Windows ou de la pile de maintenance.

Résolution


Pour résoudre ce problème, utilisez Windows Update pour mettre à jour l'installateur de Modules Windows ou la pile de maintenance. Ou bien, téléchargez les mises à jour qui sont répertoriés dans le tableau suivant à partir du Microsoft Download Center.
Système d'exploitationNuméro de la base de connaissances
Windows Vista et Windows Server 2008955430
Windows 7 et Windows Server 2008 R22533552
Windows 8 et Windows Server 20122871777
Windows 8.1 et Windows Server 2012 R22919442

Plus d'informations


Lorsque vous utilisez Windows Update, l’installateur de Modules Windows ou de la mise à jour de pile maintenance est nécessaire. Toutefois, lorsque vous installez un package de mise à jour .msu, le programme d’installation ne se connecte pas à Windows Update pour mettre à jour l’installateur de Modules Windows ou de la pile de maintenance.