Un message « Erreur lors du lancement du processus desservant le pool d’applications « CRMAppPool » » est enregistré dans le journal d’Application après avoir configuré CRMAppPool pour un utilisateur de compte de domaine dans Microsoft Dynamics CRM

S’applique à : Dynamics CRM 4.0

Symptômes


Lorsque vous exécutez le pool d’applications CRMAppPool après la configuration du pool d’applications pour un compte d’utilisateur de domaine dans Microsoft Dynamics CRM, le message suivant est enregistré dans le journal d’Application :
Remarque Dans ce message d’erreur, Date et heure représentent la date effective et l’heure réelle. Par exemple, ces valeurs peuvent être des « 12 / 12 / 2007 » et « 17:53:26.138 ».

Lorsque ce problème se produit, il est impossible de démarrer le pool d’applications CRMAppPool. En outre, le message d’erreur suivant s’affiche :
Service non disponible.
Ce problème se produit même si le compte d’utilisateur de domaine est un membre du groupe administrateur local.

Cause


Le problème se produit car les autorisations ou les droits de l’utilisateur de compte de domaine ne sont pas suffisantes.

Résolution


Pour résoudre ce problème, procédez comme suit :
  1. Inclure le compte d’utilisateur de domaine dans les groupes suivants dans Active Directory :
    • Le groupe utilisateurs de domaine Active Directory
    • PrivUserGroup
    • SQLAccessGroup
    Pour ce faire, procédez comme suit :
    1. Ouvrez une session sur un serveur en tant qu’utilisateur disposant des droits administrateur de domaine ou des droits de mise à jour de ces groupes.
    2. Cliquez droit sur le groupe Utilisateurs du domaine dans Active Directory, puis cliquez sur Propriétés.
    3. Dans la zone nom du groupe , tapez le nom de l’utilisateur qui exécute le Pool d’applications CRM et puis cliquez sur OK à deux reprises.
    4. Répétez les étapes b et c pour les groupes PrivUserGroup et au groupe SQLAccessGroup.
    Si vous disposez de plusieurs déploiements de Microsoft Dynamics CRM sont installés, plusieurs groupes figurent dans Active Directory. Pour déterminer les groupes que vous souhaitez mettre à jour, procédez comme suit.

    Pour Microsoft Dynamics CRM 3.0
    1. Exécutez l’instruction SQL suivante sur la base de données MSCRM :
      select organizationid from organizationbase
    2. Notez le GUID. Par exemple, le GUID peut être C8AB1D52-9383-4164-B571-4C80D46674E3.
    3. Recherchez les groupes PrivUserGroup et SQLAccessGroup dans Active Directory. Le nom du groupe contient le GUID que vous avez noté à l’étape b.
    Pour Microsoft Dynamics CRM 4.0
    1. Exécutez l’instruction SQL suivante sur la base de données MSCRM_config :
      select id, friendlyname from organization
    2. Notez le GUID. Par exemple, le GUID peut être C8AB1D52-9383-4164-B571-4C80D46674E3 Org Name.
    3. Recherchez les groupes PrivUserGroup et SQLAccessGroup dans Active Directory. Le nom du groupe contient le GUID que vous avez noté à l’étape b.
  2. Inclure le compte d’utilisateur de domaine dans les groupes suivants sur le serveur Microsoft Dynamics CRM :
    • Le groupe local IIS_WPG
    • Le groupe local de CRM_WPG
    Remarque Le compte d’utilisateur de domaine doit avoir des droits d’utilisateur locaux suivants :
    • Le droit d’emprunter l’identité d’un client après l’authentification
    • Le droit d’Ouvrir une session en tant que service
    Pour ce faire, procédez comme suit :
    1. Sur le serveur Microsoft Dynamics CRM, cliquez sur Démarrer, pointez sur Outils d’administration, puis cliquez sur Stratégie de sécurité locale.
    2. Développez Stratégies locales, puis cliquez sur Attribution des droits utilisateur.
    3. Droit d’emprunter l’identité d’un client après l’authentification, puis cliquez sur Propriétés.
    4. Cliquez sur Ajouter un utilisateur ou un groupe.


      Remarque Il se peut que vous deviez cliquez sur emplacement pour sélectionner le domaine au lieu de l’ordinateur local.
    5. Dans la zone nom du groupe , tapez le nom de l’utilisateur qui exécute le Pool d’applications CRM et puis cliquez sur OK à deux reprises.
    6. Répétez les étapes 2c à 2e pour le droit d’Ouvrir une session en tant que service .
  3. Configurer le compte de sécurité de pool d’applications CRMAppPool pour utiliser un nom principal de service (SPN). Pour plus d’informations sur la configuration des noms principaux de service, consultez le document de noms principaux (SPN) du service configuration suivant sur le centre de ressources :Remarque : Pour Microsoft Dynamics CRM 4.0, vous n’êtes pas obligé de créer un SPN pour le compte de domaine.
  4. Configurer le compte d’utilisateur sur le serveur Microsoft Dynamics CRM qui doit être approuvé pour la délégation 1. Pour ce faire, procédez comme suit :
    1. Sur le contrôleur de domaine, ouvrez Active Directory utilisateurs et ordinateurs.

      Remarque Si la délégation contrainte est disponible, utilisez un serveur qui exécute Windows Server 2003 pour ouvrir utilisateurs et ordinateurs. Dans le cas contraire, vous ne voyez pas les options pour définir la délégation contrainte.
    2. Développez le domaine, puis développez utilisateurs.
    3. Cliquez sur le nom d’utilisateur, puis cliquez sur Propriétés.
    4. Suivez les étapes de la méthode appropriée que vous utilisez.

      Délégation complète
      1. Cliquez sur l’onglet compte .
      2. Dans la section options de compte , faites défiler vers le bas et puis sélectionnez le compte est approuvé pour la délégation.

        Remarque Cette option ne s’affiche pas si le nom principal de service n’a pas été défini.
      IIS 6.0 et la délégation contrainte
      1. Cliquez sur l’onglet délégation .
      2. Cliquez sur approuver ce compte pour la délégation aux services spécifiés.
      3. Cliquez sur utiliser uniquement Kerberos.
      4. Cliquez sur Ajouter.
      5. Cliquez sur utilisateurs ou ordinateurset cliquez sur Options avancées, cliquez sur Rechercher maintenant, sélectionnez le serveur Reporting Services, puis cliquez sur OK à deux reprises.
      6. Sélectionnez le service HTTP, puis cliquez sur OK.
  5. Redémarrez le serveur.

Plus d'informations


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909588 comment configurer l’authentification Kerberos pour Microsoft CRM 3.0 et Microsoft SQL Server Reporting Services