Vous pouvez rencontrer des performances ralenties si vous êtes un utilisateur qui n’est pas affecté un ID utilisateur SUPER dans Microsoft Dynamics NAV 4.0


Cet article s’applique à Microsoft Dynamics NAV 4.0 pour tous les pays et tous les paramètres régionaux de langue.

Symptômes


Dans Microsoft Dynamics NAV 4.0, vous pouvez rencontrer des performances lentes si vous êtes un utilisateur qui n’est pas affecté un identificateur (ID) utilisateur SUPER. Ce problème se produit si les conditions suivantes sont remplies :
  • Dans Microsoft Dynamics NAV 4.0, vous utilisez la base de données Native.
  • La base de données Native contient plus de 300 entreprises.

Cause


Ce problème se produit car Microsoft Dynamics NAV 4.0 doit vérifier les lots d’autorisations.

Résolution


Informations sur le correctif

Un correctif pris en charge est désormais disponible auprès de Microsoft. Le correctif résout le problème qui est décrit dans cet article. Appliquez le correctif uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème immédiatement, contactez le Support technique pour Microsoft Dynamics et les produits connexes obtenir le correctif. Vous pouvez ouvrir une session sur le site de Microsoft Dynamics et créer une demande de support. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :Vous pouvez également contacter le Support technique pour Microsoft Dynamics et les produits associés par téléphone au (888) 477-7877.

Remarque Dans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Conditions préalables

Aucunes conditions préalables ne sont requises.

Informations sur la suppression

Vous ne pouvez pas supprimer ce correctif.

Nécessite un redémarrage

Si vous êtes invité à redémarrer l’ordinateur, vous devez redémarrer l’ordinateur après avoir appliqué ce correctif.

Comment faire pour obtenir le correctif logiciel de Microsoft Dynamics NAV ou mettre à jour des fichiers

Une fois que vous demandez un correctif de Microsoft Dynamics NAV ou un fichier de mise à jour à partir d’un Support technique pour Microsoft Dynamics, un lien hypertexte sera envoyé dans un message électronique pour vous.


Le message électronique contiendra un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel de Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier – Avertissement de sécurité s’ouvre. Puis, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.


Si vous cliquez sur exécuter, les fichiers de démarrer le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers et ensuite fournir le mot de passe.


Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Vous devez ensuite fournir le mot de passe fourni dans le message électronique.


Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment faire pour installer le correctif de Microsoft Dynamics NAV ou de la mise à jour de Microsoft Dynamics NAV

Les correctifs de Microsoft Dynamics NAV et les mises à jour de Microsoft Dynamics NAV sont accessibles sous forme de fichiers unique. Pour installer un correctif Microsoft Dynamics NAV ou une mise à jour de Microsoft Dynamics NAV, vous devez remplacer les fichiers d’installation de Microsoft Dynamics NAV existantes en utilisant les fichiers de correctif ou la mise à jour.


Si vous avez installé le client Microsoft Dynamics NAV, vous devez remplacer les fichiers suivants dans le répertoire d’installation de client Microsoft Dynamics NAV.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Dbm.dll4.0.3.25307345,20801-Oct-200717:57x86
Fin.exe4.0.3.253078,119,41601-Oct-200717:58x86
Finhlink.exe4.0.3.25307119,92801-Oct-200717:56x86
Finsql.exe4.0.3.253078,168,56801-Oct-200717:58x86
Nc_netb.dll4.0.3.2530778,96801-Oct-200717:56x86
Nc_tcp.dll4.0.3.2530783,06401-Oct-200717:56x86
Nc_tcps.dll4.0.3.2530791,25601-Oct-200717:56x86
Ndbcs.dll4.0.3.253071,090,68001-Oct-200717:58x86
Slave.exe4.0.3.2530795,35201-Oct-200717:56x86
Remarque En général, le client Microsoft Dynamics NAV est installé dans le répertoire suivant :
C:\Program Files\Microsoft Business Solutions-Navision\Client
Pour remplacer les fichiers d’installation de Microsoft Dynamics NAV existantes, procédez comme suit :
  1. Quittez Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation de client Microsoft Dynamics NAV.
  3. Copiez les fichiers que vous avez téléchargé.
  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de client Microsoft Dynamics NAV.
  5. Dans la boîte de dialogue Confirmer le remplacement du fichier , cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation de client Microsoft Dynamics NAV.

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft