Le service SMS_EXECUTIVE de System Center Configuration Manager 2007 sur un serveur de site enfant peut se bloquer lorsqu’il traite le fichier .sha et envoie les données d’inventaire à son site parent

S’applique à : Microsoft System Center Configuration Manager 2007

Symptômes


Considérez le scénario suivant :
  • Lorsqu’un site enfant est affecté à un site parent ou que le site parent est modifié dans System Center Configuration Manager 2007 Service Pack 1 (SP1), un fichier de .sha SiteCodeest généré sous le dossier Dataldr.box.
  • Le service SMS_EXECUTIVE sur le site enfant envoie les données d’inventaire au site parent lorsqu’il gère le fichier .sha codesite.
Dans ce scénario, le service SMS_EXECUTIVE peut se bloquer. Il est probable, le problème se produit lorsque l’option pageheap ou gflags est activée.

En outre, l’événement suivant est enregistré dans le journal système sur le serveur de site enfant :
Source: Service Control Manager Date:  Date & Time Event ID: 7034 Task Category: None Level: Error Keywords: Classic User: N/A Computer:  Computer Name 
Description: The SMS_EXECUTIVE service terminated unexpectedly. It has done this 1 time(s).

Cause


Ce problème se produit en raison d’un problème dans le composant de chargement des données de stock.

Résolution


Informations sur le Service Pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Microsoft System Center Configuration Manager 2007, disponible à partir de ce site web de Microsoft : http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Pour obtenir une liste des problèmes résolus dans ce service pack, cliquez sur le numéro de l’article suivant dans la Knowledgebase de Microsoft :
Liste des 971348 des correctifs et des mises à jour contenues dans System Center Configuration Manager 2007 Service Pack 2

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Vous devez disposer de System Center Configuration Manager 2007 Service Pack 1 pour appliquer ce correctif. Pour résoudre ce problème, installez le correctif 954716 sur les serveurs de site enfants de System Center Configuration Manager 2007 Service Pack 1.

Nécessite un redémarrage

Vous n'êtes pas obligé de redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Nom de fichierVersion de fichierTaille du fichierDateHeure
Baseobj.dll4.0.6221.1103991,16030-Nov-200819:10

Remarque Les informations sur les attributs de ce fichier s’applique aux x86 plate-forme, x64 plate-forme, International Client Pack 1 et International Client Pack 2.

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft