« Délai d’expiration de la demande » lorsque vous essayez de charger un fichier volumineux dans une bibliothèque de documents SharePoint Services 3.0

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous installez Microsoft Windows SharePoint Services 3.0.

  • Vous configurez un site web Windows SharePoint Services 3.0 pour prendre en charge les fichiers volumineux.

  • Vous vous connectez au site web Windows SharePoint Services 3.0.

  • Vous essayez de charger un fichier volumineux dans une bibliothèque de documents.

Dans ce cas, un message d’erreur semblable au suivant s’affiche :

La demande a expiré.

Cause

Ce problème peut se produire si le fichier que vous essayez de charger dépasse 50 mégaoctets (Mo).

Résolution

Pour résoudre ce problème, utilisez une ou plusieurs des méthodes suivantes.

Méthode 1 : augmenter la taille de chargement maximale

Pour augmenter la taille de chargement maximale, procédez comme suit :

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Outils d’administration, puis cliquez sur Administration centrale de SharePoint.

  2. Cliquez sur Gestion des applications.

  3. Sous Gestion des applications web SharePoint, cliquez sur Paramètres généraux de l’application web.

  4. Dans la page Paramètres généraux de l’application web , cliquez sur l’application web que vous souhaitez modifier.

  5. Sous Taille de chargement maximale, tapez la taille de fichier maximale en mégaoctets souhaitée, puis cliquez sur OK. Vous pouvez spécifier une taille de fichier maximale de 2 047 mégaoctets.

Méthode 2 : Augmenter le paramètre de délai d’attente de connexion

Pour augmenter le paramètre de délai d’attente de connexion, procédez comme suit :

Remarque

Par défaut, le paramètre de délai d’attente de connexion IIS est de 120 secondes.

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, pointez sur Outils d'administration, puis cliquez sur Gestionnaire des services Internet (IIS).

  2. Cliquez avec le bouton droit sur le serveur virtuel que vous souhaitez configurer, puis cliquez sur Propriétés.

  3. Cliquez sur l’onglet Site web .

  4. Sous Connections, tapez le nombre de secondes souhaitées dans la zone Délai d’attente de la connexion, puis cliquez sur OK.

Méthode 3 : ajouter la valeur executionTimeout

  1. Ouvrez le fichier Web.config dans le Bloc-notes.

    NOTE Par défaut, ce fichier se trouve à l’emplacement suivant :Program Files\Common Files\Microsoft Shared\Web server extensions\12\TEMPLATE\LAYOUTS

  2. Ajoutez la valeur executionTimeout souhaitée. Par exemple, remplacez la valeur comme suit.

    Code existant

    <location path="upload.aspx">   
     <system.web>   
       <httpRuntime maxRequestLength="2097151" />   
     </system.web>   
    </location>  
    

    Code de remplacement

    <location path="upload.aspx">   
     <system.web>   
       <httpRuntime executionTimeout="999999" maxRequestLength="2097151" />   
     </system.web>   
    </location>  
    
  3. Cliquez sur Fichier, puis sur Enregistrer.

  4. Ouvrez le fichier Web.config de l’application web dans le Bloc-notes.

    Note Par défaut, ce fichier se trouve dans le Inetpub\wwwroot\wss\VirtualDirectories\VirtualDirectoryFolder dossier .

  5. Modifiez la ligne suivante dans le fichier.

    Ligne existante

    <httpRuntime maxRequestLength="51200" />  
    

    Ligne de remplacement

    <httpRuntime executionTimeout="999999" maxRequestLength="51200" />  
    
  6. Cliquez sur Fichier, puis sur Enregistrer.

  7. Quittez le Bloc-notes.

Informations supplémentaires

Sur un ordinateur Windows Server 2008 disposant uniquement d’installations IIS 7.0, vous pouvez ajouter la valeur maxAllowedContentLength pour résoudre le problème décrit dans la section « Symptômes ». Toutefois, vous ne pouvez pas charger de fichiers dont la taille dépasse 28 Mo, même si vous avez configuré le paramètre de chargement de fichiers volumineux lorsque vous exécutez Windows SharePoint Services sur un ordinateur Windows Server 2008 sur lequel IIS 7.0 est installé. En règle générale, vous recevez un message d’erreur qui ressemble à l’un des éléments suivants :

La page ne peut pas être affichée.
HTTP 404

Pour contourner ce problème, modifiez la <section configuration> dans le fichier Web.config de l’application web. Pour cela, procédez comme suit :

  1. Ouvrez le fichier Web.config de l’application web dans le Bloc-notes.

    Note Par défaut, ce fichier se trouve dans le Inetpub\wwwroot\wss\VirtualDirectories\VirtualDirectoryFolder dossier .

  2. Augmentez la valeur de maxAllowedContentLength dans le nœud requestLimits . Par exemple, modifiez le fichier comme suit pour définir cette valeur sur sa taille maximale :

    <requestLimits maxAllowedContentLength="52428800"/>
    

    Note Si votre fichier Web.config n’a pas encore le <nœud requestLimits> , vous devez l’ajouter à la position correcte dans la hiérarchie de sections :

    <configuration>  
    <system.webServer>  
    <security>  
    <requestFiltering>  
    <requestLimits maxAllowedContentLength="52428800"/>  
    </requestFiltering>  
    </security>  
    </system.webServer>  
    </configuration>
    

    Note Nous vous recommandons de définir la valeur maxAllowedContentLength légèrement supérieure à la taille maximale de chargement de fichier que vous avez configurée dans SharePoint. Si la valeur maxAllowedContentLength est égale ou inférieure à la taille maximale de chargement de fichier configurée dans SharePoint, les utilisateurs ne recevront pas le message d’erreur indiquant qu’ils dépassent la limite de taille s’ils tentent de charger une taille de fichier supérieure à celle spécifiée par l’administrateur.

References

Pour plus d’informations sur le paramètre maxAllowedContentLength, consultez l’article suivant dans la Base de connaissances Microsoft :

942074 message d’erreur lorsque vous visitez un site web hébergé sur un serveur exécutant Internet Information Services 7.0 : « Erreur HTTP 404.13 - CONTENT_LENGTH_TOO_LARGE »

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