מידע אודות רשימת ההשלמה האוטומטית של Outlook

חל על: Outlook 2016Outlook 2013Microsoft Office Outlook 2003 יותר

סיכום


מאמר זה מכיל סקירה של רשימת ההשלמה האוטומטית של Microsoft Outlook (המכונה גם Outlook רשימת השלמה אוטומטית). בנוסף המתארת את התכונה, מאמר זה מכיל מידע נוסף והוראות שלב אחר שלב עבור משתמשים מתקדמים לנהל את הרשימה.

מידע נוסף


Outlook שומר את רשימת ההשלמה האוטומטית. הרשימה משמשת את התכונה בדיקת שמות אוטומטית וגם את התכונה השלמה אוטומטית. רשימת ההשלמה האוטומטית, המכונה גם מטמון הכינויים, נוצר באופן אוטומטי בעת שליחת הודעות דואר אלקטרוני מ- Outlook. הרשימה מכילה כתובות SMTP, ערכי LegacyExchangeDN ושמות התצוגה של אנשים שאליהם שלחת דואר בעבר.הערה רשימת ההשלמה האוטומטית עבור Outlook הוא ספציפי ל- Outlook, והוא אינו משותף על-ידי Outlook Web App (OWA). OWA מנהלת את רשימת ההשלמה האוטומטית משלו.הסעיפים הבאים מספקים מידע אודות התכונה ' השלמה אוטומטית '.

הגבל מספר הערכים

Outlook מגביל את מספר הערכים שניתן לשמור ברשימה השלמה אוטומטית. לאחר שהגעת למגבלה זו, Outlook ישתמש אלגוריתם פנימי כדי לקבוע את שמות הטובה ביותר כדי להסיר מהרשימה. פעולה זו מתבצעת בהתבסס על שקלול השימוש. לכן, ייתכן שתגלה חלק מהשמות הוסר באופן בלתי צפוי ממטמון הכינויים שלך. קיימות שתי גישות כללי שבו באפשרותך להשתמש כדי להימנע ממצב זה:
  1. באפשרותך להסיר ערכי רשימת השלמה אוטומטית שאין לך עוד צורך בעצמם. זוהי השיטה המועדפת. לקבלת מידע נוסף אודות אופן ביצוע פעולה זו, עיין בסעיף "כיצד להסיר ערכי הרשימה ' השלמה אוטומטית ' אחד בכל פעם."
  2. באפשרותך להגדיל את המגבלה עבור מטמון הכינויים. מכיוון שתצורה זו היא שלא נבדקו, איננו ממליצים אותו. אם מטמון הכינויים גדול יותר, גם עלול לאבד מספר גדול יותר של ערכים המאוחסנים במטמון אם מטמון הכינויים שלך יהפוך לבלתי שמיש עקב פגם. לקבלת מידע נוסף אודות כיצד להגדיל את המגבלה, עיין בסעיף שכותרתו "כיצד לשנות את המגבלה עבור רשימת ההשלמה האוטומטית."
המגבלות הן כדלקמן:
  • Outlook 2016: 1,000 ערכים
  • Outlook 2013: 1,000 ערכים
  • Outlook 2010: 1,000 ערכים
  • Outlook 2007: ערכי 2,000
  • Outlook 2003: 1,000 ערכים
 

כיצד להפעיל את תכונת ההשלמה האוטומטית

סעיף זה מפרט כיצד להפעיל או להשבית את התכונה השלמה אוטומטית.
Outlook 2010, Outlook 2013 ו- Outlook 2016
כדי לגשת שהגדרת ההשלמה האוטומטית, בצע את הפעולות הבאות:
  1. בתפריט קובץ , לחץ על אפשרויות.
  2. בחר את הכרטיסיה דואר .
  3. גלול בקירוב בחצי השני למטה עד שתראה לשלוח הודעות. ודא כי התיבה השתמש ברשימת השלמה אוטומטית כדי הצע שמות בעת הקלדה בתיבות אל, עותק, עותק מוסתר קווים הוצאה.
Outlook 2003 ו- Outlook 2007
כדי לגשת להגדרות השלמה אוטומטית, בצע את השלבים:
  1. לחץ על כליםולאחר מכן לחץ על אפשרויות.
  2. לחץ על לחצן אפשרויות דואר אלקטרוני .
  3. לחץ על לחצן אפשרויות דואר אלקטרוני מתקדמות .
  4. ודא הצע שמות בעת השלמת עותק, ועותק מוסתר שדות תיבה מסומנת. (אחרי מסך לקח עבור שלב זה.)The screen shot for this step.
 

כיצד לייבא קבצים. nk2 לתוך Outlook 2010, Outlook 2013 ו- Outlook 2016

Microsoft Office Outlook 2007 וגירסאות קודמות לאחסן רשימת ההשלמה האוטומטית בקובץ כינוי (. nk2) בדיסק. Outlook 2010, Outlook 2013 ו- Outlook 2016 לאחסן רשימת ההשלמה האוטומטית כהודעה מוסתרים במאגר ההודעות הראשי שלך. Outlook 2010, Outlook 2013 ו- Outlook 2016 מאפשרות לך לייבא את קבצי ה-. nk2 ישנים יותר.לקבלת מידע נוסף אודות ייבוא קבצים. nk2 ב- Outlook 2010, עבור אל אתר האינטרנט הבא של Microsoft:

כיצד להעתיק את הרשימה השלמה אוטומטית

השלבים כדי לייצא ולייבא את הרשימה השלמה אוטומטית הן שונות, בהתאם לגירסת Outlook שבה אתה משתמש.
Outlook 2010, Outlook 2013 ו- Outlook 2016
כדי להעתיק את הרשימה השלמה אוטומטית ב- Outlook 2010, Outlook 2013 ו- 2016 ב- Outlook, בצע את הפעולות הבאות:שלב1כדי לייצא את ההודעה בתיבת הדואר של השלמה אוטומטית, בצע את הפעולות הבאות:
  1. לצאת מ- Outlook ולאחר מכן סגור את Outlook Web Access או יישום אינטרנט Outlook (OWA) על כל תחנות העבודה המחוברות אל תיבת הדואר שלך.
  2. הורד והתקן MFCMAPI מ- http://mfcmapi.codeplex.com.
  3. הפעל את mfcmapi.exe.
  4. תפריט הפעלה , לחץ על כניסה.
  5. אם תתבקש לבחור פרופיל, בחר את שם הפרופיל הרצוי ולאחר מכן לחץ על אישור.
  6. בחלונית העליונה, אתר את השורה המתאימה אל תיבת הדואר שלך ולאחר מכן לחץ עליו פעמיים.
  7. בחלונית הניווט הימנית, הרחב את הגורם המכיל של הבסיסולאחר מכן הרחב העליון של מאגר המידע או IPM_SUBTREE.
  8. לחץ לחיצה ימנית על התיקיה תיבת דואר נכנס , ולאחר מכן לחץ על פתח משויכת תוכן טבלה. פעולה זו פותחת חלון חדש של MFCMAPI אשר מכיל מאפיינים שונים.
  9. תחת עמודה ' נושא ', לחץ לחיצה ימנית על פריט הכולל את הנושא IPM. Configuration.Autocomplete, ולאחר מכן לחץ על ייצוא של ההודעה. פעולה זו פותחת את החלון לשמור הודעה לקובץ .
  10. ברשימה הנפתחת, בחר קובץ MSG (UNICODE)ולאחר מכן לחץ על אישור.
  11. בחר מיקום התיקיה שבה ברצונך לשמור את ההודעה ולאחר מכן לחץ על שמור. רשום לפניך את המיקום.
שלב 2כדי לייבא את הודעות הדואר השלמה אוטומטית, בצע את הפעולות הבאות.
  1. לצאת מ- Outlook ולאחר מכן סגור את Outlook Web Access או יישום אינטרנט Outlook (OWA) על כל תחנות העבודה המחוברות אל תיבת הדואר שלך.
  2. הורד והתקן MFCMAPI מ- http://mfcmapi.codeplex.com
  3. הפעל את mfcmapi.exe.
  4. תפריט הפעלה , לחץ על כניסה.
  5. אם תתבקש לבחור פרופיל, בחר את שם הפרופיל הרצוי ולאחר מכן לחץ על אישור.
  6. בחלונית העליונה, אתר את השורה המתאימה אל תיבת הדואר שלך ולאחר מכן לחץ עליו פעמיים.
  7. בחלונית הניווט הימנית, הרחב את בסיס - תיבת הדוארולאחר מכן הרחב העליון של מאגר המידע או IPM_SUBTREE.
  8. לחץ לחיצה ימנית על התיקיה תיבת דואר נכנס , ולאחר מכן לחץ על פתח משויכת תוכן טבלה. פעולה זו פותחת חלון חדש של MFCMAPI אשר מכיל מאפיינים שונים.
  9. כדי למנוע ערכים כפולים, עליך למחוק את ההודעה השלמה אוטומטית קיים. הערה לפני שתמחק את IPM. Configuration.Autocomplete ההודעה, עליך לייצא את ההודעה באמצעות השלבים בסעיף 'כיצד לייצא את המטמון ' השלמה אוטומטית'. כדי למחוק את ההודעה השלמה אוטומטית קיים, בצע את הפעולות הבאות:
    1. עמודה ' נושא ', אתר את הפריט עם הנושא IPM. Configuration.Autocomplete.
    2. לחץ לחיצה ימנית על הפריט ולאחר מכן לחץ על מחק את ההודעה. פעולה זו פותחת את החלון מחק פריט .
    3. ברשימה הנפתחת, בחר למחוק לצמיתות (מחיקה לשם שמירת פריט שנמחק אם הפעולה נתמכת)ולאחר מכן לחץ על אישור.
  10. בתפריט תיקיה , לחץ על ייבואולאחר מכן לחץ על מתוך MSG.
  11. אתר את הקובץ. msg שיצרת בשלב 11 בסעיף "כיצד כדי לייצא רשימת השלמה אוטומטית" ולאחר מכן לחץ על אישור.
  12. בחלון MSG עומס שמופיעה, בחר הודעה טעינה לתוך התיקיה הנוכחית ברשימה טען סגנון ולאחר מכן לחץ על אישור.
המידע השלמה אוטומטית מיובא מתוך ה-IPM. Configuration.Autocomplete_< הקוד ההקסדצימאלי >. msg, כאשר מציין מיקום< הקוד ההקסדצימאלי > מייצג מחרוזת ארוכה של מספרים ואותיות.
Outlook 2003 ו- Outlook 2007

השלבים כדי להעתיק רשימת ההשלמה האוטומטית ב- Outlook 2003 ו- Outlook 2007 הם שונים. הסיבה לכך היא Outlook 2003 ו- Outlook 2007 לאחסן רשימת ההשלמה האוטומטית ב- הקובץ. nk2.

כדי להעתיק את הרשימה השלמה אוטומטית ב- Outlook 2007, עבור אל אתר האינטרנט הבא של Microsoft:

להעתיק את הרשימה השלמה אוטומטית למחשב אחר

כיצד להסיר את ערכי רשימת השלמה אוטומטית אחת בכל פעם

כדי להסיר ערכים ערך אחד המטמון השלמה אוטומטית בכל פעם, בצע את הפעולות הבאות:
  1. פתח הודעת דואר אלקטרוני חדשה.
  2. הקלד את התווים הראשונים של ערך ההשלמה האוטומטית שברצונך להסיר.
  3. כאשר הערך מופיע ברשימת מוצעים שמות, העבר את מצביע העכבר מעל השם עד שהוא הופך מודגש, אך אל תלחץ על השם.
  4. כאשר הסמל "X" מופיע ליד שם המסומן, לחץ על X כדי להסיר את שמך מהרשימה, או הקש על מקש Delete במקלדת.

כיצד לנקות את הרשימה השלמה אוטומטית

סעיף זה מסביר כיצד למחוק את רשימת ההשלמה האוטומטית.
Outlook 2010, Outlook 2013 ו- Outlook 2016

השתמש באחת משתי השיטות הבאות כדי למחוק את הרשימה השלמה אוטומטית ב- Outlook 2010, Outlook 2013 ו- Outlook 2016.שיטה 1

  1. פתח את Outlook.
  2. בכרטיסיה קובץ, לחץ על אפשרויות.
  3. לחץ על הכרטיסיה דואר .
  4. תחת שליחת הודעות, לחץ על רשימת ההשלמה האוטומטית ריק.
  5. לחץ על כן.
שיטה 2הפעל את Outlook באמצעות הבורר /CleanAutoCompleteCache. לשם כך, בצע את הפעולות הבאות:
  1. לחץ על התחל ולאחר מכן לחץ על הפעל.
  2. סוג Outlook.exe /CleanAutoCompleteCache. הערה אם Outlook אינו מותקן במיקום ברירת המחדל, חייב להצביע על הנתיב של Outlook.exe.
Outlook 2003 ו- Outlook 2007
כדי למחוק את הרשימה ' השלמה אוטומטית ' ב- Outlook 2003 ו- Outlook 2007, עליך למחוק באופן ידני את הקובץ. nk2. כדי למחוק את הקובץ. nk2, בצע את הפעולות הבאות:
  1. צא מ-Outlook.
  2. לחץ על התחלולאחר מכן לחץ על מחשב.
  3. לחץ על סדרולאחר מכן לחץ על התיקיה ואת אפשרויות חיפוש.
  4. בכרטיסיה תצוגה , לחץ על הצג קבצים, תיקיות וכוננים מוסתרים.
  5. לחץ על אישור.
  6. לחץ על התחל, לחץ על כל התוכניות, לחץ על עזרים ולאחר מכן לחץ על הפעל.
  7. בתיבת הדו-שיח הפעלה , הקלד את הפקודה הבאה (כולל המירכאות) ולאחר מכן לחץ על אישור: "C:\ \AppData\Roaming\Microsoft\Outlookשם המשתמשUsers\"הערהשם משתמש בנתיב זה הוא השם של המחוברים כעת למערכת המשתמש של Windows.
  8. לחץ לחיצה ימנית. קובץ NK2 עם שם הפרופיל שברצונך לאפס ולאחר מכן לחץ על שנה שם.
  9. שנה את שם הקובץ בשם profilename.ה-. bakולאחר מכן הקש Enter.
  10. פעל את Outlook.
 

בעיות עם מטמון השלמה אוטומטית

סעיף זה מתאר בעיות מוכרות שעלולות להתרחש עם מטמון השלמה אוטומטית. מטמון השלמה אוטומטית נפגמים עם הזמן ולשמור עשוי לא ערכים חדשים. במקרה כזה, באפשרותך לנסות להסיר ערכים בודדים מתוך הרשימה. לשם כך, עיין בסעיף שכותרתו "כיצד להסיר ערכי הרשימה ' השלמה אוטומטית ' אחד בכל פעם." אם זה לא פותר את הבעיה, ניתן לאפס את רשימת ההשלמה האוטומטית כולה. לשם כך, עיין בסעיף שכותרתו "כיצד לנקות את הרשימה השלמה אוטומטית כולו."

כיצד לשנות את המגבלה עבור רשימת ההשלמה האוטומטית

מכיוון שתצורה זו היא שלא נבדקו, איננו ממליצים אותו. אם יש לך רשימת ההשלמה האוטומטית גדול יותר, גם עלול לאבד מספר גדול יותר של ערכים המאוחסנים במטמון אם מטמון ההשלמה האוטומטית שלך יהפוך לבלתי שמיש עקב פגם. נתון זה כתב ויתור, באפשרותך להשתמש נתוני הרישום הבאים כדי להגדיל את המגבלה רשימת ההשלמה האוטומטית ב- Outlook.חשוב הסעיף, שיטה או המשימה הזו מכילה פעולות המציינות כיצד לשנות את הרישום. עם זאת, עלולות להתרחש בעיות חמורות אם תשנה את הרישום באופן שגוי. לפיכך, ודא כי אתה מבצע צעדים אלה בקפידה. לקבלת הגנה נוספת, בצע גיבוי של הרישום לפני שתבצע בו שינויים. כך תוכל לשחזר את הרישום מאוחר יותר במקרה שתתעורר בעיה. לקבלת מידע נוסף על אופן הגיבוי והשחזור של הרישום, לחץ על מספר המאמר הבא כדי להציג את המאמר הרלוונטי מתוך Microsoft Knowledge Base:
322756 כיצד לגבות ולשחזר את הרישום ב-Windows
  1. צא מ-Outlook.
  2. הפעל את עורך הרישום.
    • ב- Windows 8.x, הקש Windows מפתח, הקלד regedit ולאחר מכן הקש Enter.
    • ב- Windows 7 ו- Windows Vista, לחץ על התחל, הקלד regedit בתיבה התחל חיפוש ולאחר מכן הקש Enter.
  3. אתר את מפתח המשנה הבא של הרישום, ובחר בו:
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck
    הערה מציין מיקום x.0 מפתח משנה זה של הרישום מייצג את הגירסה של Microsoft Office. השתמש בערך המתאים מתוך הרשימה הבאה. Outlook 2016 = 16.0 Outlook 2013 = 15.0 Outlook 2010 = 14.0 Outlook 2007 = 12.0 Outlook 2003 = 11.0
  4. בתפריט עריכה , הצבע על חדשולאחר מכן לחץ על ערך DWORD.
  5. הקלד MaxNickNamesולאחר מכן הקש Enter.
  6. בתפריט עריכה, לחץ על שינוי.
  7. הקלד את הערך החדש עבור הגבול ולאחר מכן לחץ על אישור. הערות
    • ודא כי אתה מקליד את המספר dטופס עשרונית. זוהי הצורה הנכונה שיש להקליד את המספר.
    • נסה להגדיל את המגבלה בכמות טווח רק על מחשב את מגבלת חדש. לדוגמה, כדי ליצור העלאה של 20 אחוז במגבלת ב- Outlook 2013, באפשרותך לציין 1200 עבור ערך MaxNickNames.
  8. צא מעורך הרישום.
  9. הפעל את Outlook.
הערה ערך הרישום MaxNickNames מציין רק את גבול שאינו ברירת מחדל. לכן, באפשרותך להשתמש גם בערך זה כדי להנמיך את מגבלת של מטמון הכינויים.