ב- Word, באפשרותך להפוך משימות הנמצאות בשימוש תכוף לאוטומטיות על-ידי יצירה וריצה של פקודות מאקרו. מאקרו הוא סידרה של פקודות והוראות שאתה מקיבוץ יחד כפקודה בודדת כדי לבצע משימה באופן אוטומטי.

כדי לחסוך זמן בביצוע משימות תכופות, ארוז את השלבים בפקודת מאקרו. תחילה, עליך להקליט את המאקרו. לאחר מכן, תוכל להפעיל את המאקרו על-ידי לחיצה על לחצן ב'סרגל כלים לגישה מהירה' או על-ידי הקשה על שילוב מקשים. אופן הפעלת המאקרו תלוי באופן שבו הגדרת אותו.

  1. לחץ על תצוגה > פקודות מאקרו > הקלטת מאקרו.

    הפקודה 'הקלטת מאקרו'

  2. הקלד שם עבור המאקרו.

    התיבה 'שם המאקרו'

  3. כדי להשתמש במאקרו זה בכל מסמך חדש שתיצור, ודא שבתיבה אחסן מאקרו ב מופיעה האפשרות כל המסמכים (Normal.dotm).

    תיבה לבחירת מיקום לאחסון מאקרו

  4. כדי להפעיל את המאקרו בעת לחיצה על לחצן, לחץ על לחצן.

    לחץ כדי להקצות את המאקרו ללחצן

  5. לחץ על המאקרו החדש (שמו יהיה משהו בדומה ל- Normal.NewMacros.<שם המאקרו שלך>) ולאחר מכן לחץ על הוסף.

    המאקרו ולחצן 'הוסף'

  6. לחץ על שינוי.

    הלחצן 'שינוי' בתיבה 'התאם אישית את סרגל הכלים לגישה מהירה'

  7. בחר תמונת לחצן, הקלד את השם הרצוי, ולחץ על אישור פעמיים.

    אפשרויות לחצן בתיבה 'שינוי לחצן'

  8. כעת הגיע הזמן להקליט את השלבים. לחץ על הפקודות או הקש על המקשים עבור כל שלב במשימה. Word מקליט את הלחיצות וההקשות שלך.

    הערה: השתמש בלוח המקשים כדי לבחור טקסט בעודך מקליט את המאקרו. פקודות מאקרו אינן מקליטות בחירות המבוצעות באמצעות העכבר.

  9. כדי לעצור את ההקלטה, לחץ על תצוגה > פקודות מאקרו > עצור הקלטה.

    הפקודה 'עצור הקלטה'

הלחצן עבור המאקרו שלך מופיע בסרגל הכלים לגישה מהירה.

לחצן 'מאקרו' בסרגל הכלים לגישה מהירה

כדי להפעיל את המאקרו, לחץ על הלחצן.

  1. לחץ על תצוגה > פקודות מאקרו > הקלטת מאקרו.

    הפקודה 'הקלטת מאקרו'

  2. הקלד שם עבור המאקרו.

    התיבה 'שם המאקרו'

  3. כדי להשתמש במאקרו זה בכל מסמך חדש שתיצור, ודא שבתיבה אחסן מאקרו ב מופיעה האפשרות כל המסמכים (Normal.dotm).

    תיבה לבחירת מיקום לאחסון מאקרו

  4. כדי להפעיל את המאקרו בעת הקשה על קיצור מקשים, לחץ על לוח המקשים.

    לחץ כדי להקצות את המאקרו לקיצור מקשים

  5. הקלד צירוף מקשים בתיבה הקש קיצור מקשים חדש.

  6. בדוק אם צירוף זה כבר הוקצה לפעולה אחרת. אם כן, נסה צירוף אחר.

  7. כדי להשתמש בקיצור מקשים זה בכל מסמך חדש שתיצור, ודא שבתיבה שמור שינויים ב מופיעה האפשרות Normal.dotm.

  8. לחץ על הקצה.

  9. כעת הגיע הזמן להקליט את השלבים. לחץ על הפקודות או הקש על המקשים עבור כל שלב במשימה. Word מקליט את הלחיצות וההקשות שלך.

    הערה: השתמש בלוח המקשים כדי לבחור טקסט בעודך מקליט את המאקרו. פקודות מאקרו אינן מקליטות בחירות המבוצעות באמצעות העכבר.

  10. כדי לעצור את ההקלטה, לחץ על תצוגה > פקודות מאקרו > עצור הקלטה.

    הפקודה 'עצור הקלטה'

כדי להפעיל את המאקרו, הקש על קיצורי המקשים בלוח המקשים.

כדי להפעיל מאקרו, לחץ על הלחצן בסרגל הכלים לגישה מהירה והקש על קיצור המקשים. לחלופין, באפשרותך להפעיל את המאקרו מהרשימה פקודות מאקרו.

  1. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    הפקודה 'הצג פקודות מאקרו'

  2. ברשימה תחת שם המאקרו, לחץ על המאקרו שברצונך להפעיל.

  3. לחץ על הפעל.

כדי להפוך מאקרו ממסמך אחד לזמין בכל המסמכים החדשים, הוסף אותו לתבנית Normal.dotm.

  1. פתח את המסמך המכיל את המאקרו.

  2. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    הפקודה 'הצג פקודות מאקרו'

  3. לחץ על סדרן.

    לחצן 'סדרן' בתיבה 'הצג פקודות מאקרו'

  4. לחץ על המאקרו שברצונך להוסיף לתבנית Normal.dotm ולחץ על העתק.

  1. לחץ על קובץ > אפשרויות > התאמה אישית של רצועת הכלים.

  2. תחת בחר פקודות מתוך, לחץ על פקודות מאקרו.

  3. לחץ על המאקרו הרצוי.

  4. תחת התאמה אישית של רצועת הכלים, לחץ על הכרטיסיה ועל הקבוצה המותאמת אישית שבהן ברצונך להוסיף את המאקרו.

אם אין לך קבוצה מותאמת אישית, לחץ על קבוצה חדשה. לאחר מכן לחץ על שנה שם והקלד שם עבור הקבוצה המותאמת אישית שלך.

  1. לחץ על הוסף.

  2. לחץ על שנה שם כדי לבחור תמונה עבור המאקרו והקלד את השם הרצוי.

  3. לחץ פעמיים על אישור.

  1. בכרטיסיה מפתחים, בקבוצה קוד, לחץ על פקודות מאקרו.

  2. בתיבה שם המאקרו, הקלד שם עבור המאקרו.

    הערה: אם אתה נותן למאקרו חדש שם זהה לשם של מאקרו מוכלל ב- Word, פעולות המאקרו החדשות יחליפו את המאקרו המוכלל. כדי להציג רשימה של פקודות מאקרו מוכללות, לחץ על פקודות Word ברשימה פקודות מאקרו ב.

  3. ברשימה פקודות מאקרו ב, לחץ על התבנית או המסמך שבו ברצונך לאחסן את המאקרו.

    כדי להפוך את המאקרו לזמין בכל המסמכים, הקפד ללחוץ על Normal.dotm.

  4. לחץ על צור כדי לפתוח את עורך Visual Basic.

לאחר פתיחת עורך Visual Basic, ייתכן שתרצה מידע נוסף אודות עבודה עם Visual Basic for Applications. לקבלת מידע נוסף, לחץ על עזרה של Microsoft Visual Basicבתפריט עזרה או הקש F1.

באפשרותך להקליט רצף פעולות, או לכתוב מאקרו מאפס על-ידי הזנת קוד Visual Basic for Applications עורך Visual Basic.

הערה: כדי לעבוד עם פקודות מאקרו Office Word 2007, עליך להציג את הכרטיסיה מפתחים.

  1. לחץ על לחצן Microsoft Office תמונת לחצן Office ולאחר מכן לחץ על אפשרויות Word.

  2. לחץ על נפוץ.

  3. תחת אפשרויות עליות לעבודה עם Word, בחר בתיבת הסימון הצג את הכרטיסיה מפתחים ברצועת הכלים.

    הערה: רצועת הכלים היא רכיב של ממשק המשתמש של Microsoft Office Fluent.

  1. בכרטיסיה מפתחים, בקבוצה קוד, לחץ על הקלט מאקרו.

    הקבוצה 'קוד' בכרטיסיה 'מפתחים'
  2. בתיבה שם המאקרו, הקלד שם עבור המאקרו.

    הערה: אם אתה נותן למאקרו חדש שם זהה לשם של מאקרו מוכלל Office Word 2007, פעולות המאקרו החדשות יחליפו את המאקרו המוכלל. כדי להציג רשימה של פקודות מאקרו מוכללות, בכרטיסיה מפתחים, בקבוצה קוד, לחץ על פקודות מאקרו. ברשימה פקודות מאקרו ב, לחץ על פקודות Word.

  3. בתיבה אחסן מאקרו ב, לחץ על תבנית או המסמך שבו ברצונך לאחסן את המאקרו.

    חשוב: כדי להפוך את המאקרו לזמין בכל המסמכים, הקפד ללחוץ על Normal.dotm.

  4. בתיבה תיאור, הקלד תיאור של המאקרו.

  5. בצע אחת מהפעולות הבאות:

    • התחל הקלטה    כדי להתחיל להקליט את המאקרו מבלי להקצות אותו ללחצן בסרגל הכלים Access או על מקש קיצור, לחץ על אישור.

    • יצירת לחצן    כדי להקצות את המאקרו ללחצן בסרגל הכלים Access, ביצוע הפעולות הבאות:

      1. לחץ על לחצן.

      2. תחת התאמה אישית של Access מהירה, בחר את המסמך (או את כל המסמכים) שעבורו ברצונך להוסיף את המאקרו לסרגל הכלים Access המהיר.

        חשוב: כדי להפוך את המאקרו לזמין בכל המסמכים, הקפד ללחוץ על Normal.dotm.

      3. תחת בחירת פקודות מתיבת הדו-שיח, לחץ על המאקרו שאתה מקליט ולאחר מכן לחץ על הוסף.

      4. כדי להתאים אישית את הלחצן, לחץ על שנה.

      5. תחת סימן, לחץ על הסימן שברצונך להשתמש בו עבור הלחצן.

      6. בתיבה שם תצוגה, הקלד את שם המאקרו שברצונך להציג.

      7. לחץ על אישור פעמיים כדי להתחיל להקליט את המאקרו.

        הסימן שתבחר יוצג בסרגל הכלים Access המהיר. השם שאתה מקליד מוצג כאשר אתה מצביע על הסימן.

    • הקצאת קיצור מקשים    כדי להקצות את המאקרו בקיצור מקשים, ביצוע הפעולות הבאות:

      1. לחץ על Keyboard (מקלדת).

      2. בתיבה פקודות, לחץ על המאקרו שאתה מקליט.

      3. בתיבה הקש מקש קיצור חדש, הקלד את רצף המקשים הרצוי ולאחר מכן לחץ על הקצה.

      4. לחץ על סגור כדי להתחיל להקליט את המאקרו.

  6. בצע את הפעולות שברצונך לכלול במאקרו.

    הערה: בעת הקלטת מאקרו, באפשרותך להשתמש בעכבר כדי ללחוץ על פקודות ואפשרויות, אך לא כדי לבחור טקסט. עליך להשתמש בלוח המקשים כדי לבחור טקסט. לקבלת מידע נוסף אודות בחירת טקסט באמצעות לוח המקשים, ראה בחירת טקסט.

  7. כדי להפסיק להקליט את הפעולות שלך, לחץ על הפסק הקלטה בקבוצה קוד.

שינוי קיצור המקשים עבור מאקרו

  1. לחץ על לחצן Microsoft Office תמונת לחצן Office ולאחר מכן לחץ על אפשרויות Word.

  2. לחץ על התאם אישית.

  3. לצד קיצורי מקשים , לחץעל התאמה אישית.

  4. ברשימה קטגוריות, לחץ על פקודות מאקרו.

  5. ברשימה פקודות מאקרו, לחץ על המאקרו שברצונך לשנות.

  6. בתיבה הקש מקש קיצור חדש, הקלד את צירוף המקשים שברצונך לבחור.

  7. בדוק את התיבה מקשים נוכחיים כדי לוודא שאתה לא מקצה צירוף מקשים שכבר אתה משתמש בו כדי לבצע משימה אחרת.

  8. ברשימה שמור שינויים ב, לחץ על האפשרות התואמת למקום שבו ברצונך להפעיל את המאקרו.

    חשוב: כדי להפוך את המאקרו לזמין בכל המסמכים, הקפד ללחוץ על Normal.dotm.

  9. לחץ על סגור.

  1. בכרטיסיה מפתחים, בקבוצה קוד, לחץ על פקודות מאקרו.

    הקבוצה 'קוד' בכרטיסיה 'מפתחים'

  2. ברשימה תחת שם מאקרו, לחץ על המאקרו שברצונך להפעיל.

  3. לחץ על הפעלה.

  1. בכרטיסיה מפתחים, בקבוצה קוד, לחץ על פקודות מאקרו.

    הקבוצה 'קוד' בכרטיסיה 'מפתחים'

  2. בתיבה שם המאקרו, הקלד שם עבור המאקרו.

    הערה: אם אתה נותן למאקרו חדש שם זהה לשם של מאקרו מוכלל Office Word 2007, פעולות המאקרו החדשות יחליפו את המאקרו המוכלל. כדי להציג רשימה של פקודות מאקרו מוכללות, לחץ על פקודות Word ברשימה פקודות מאקרו ב.

  3. ברשימה פקודות מאקרו ב, לחץ על תבנית או המסמך שבו ברצונך לאחסן את המאקרו.

    כדי להפוך את המאקרו לזמין בכל המסמכים, הקפד ללחוץ על Normal.dotm.

  4. לחץ על צור כדי לפתוח את עורך Visual Basic.

לאחר פתיחת עורך Visual Basic, ייתכן שתרצה מידע נוסף אודות עבודה עם Visual Basic for Applications. לקבלת מידע נוסף, לחץ על עזרה של Microsoft Visual Basicבתפריט עזרה או הקש F1.

כדי לבצע עבודה מהירה של משימות שאתה עושה לעתים קרובות, בגירסת שולחן העבודה של Word, באפשרותך לשלב את השלבים בפקודות מאקרו שפועלים בלחיצה אחת. ב- Word באינטרנט, עליך לעבור בין משימות כאלה באופן ידני.

אם יש לך Word, לחץ תחילה על פתח ב- Word כדי לפתוח את המסמך ב- Word.

תמונה של הפקודה 'פתח באפליקציה לשולחן העבודה'

לאחר מכן בצע את ההוראות עבור גירסת שולחן העבודה של Word.

בעת הפעלת המאקרו ב- Word ושמור את המסמך, תראה את תוצאות המאקרו בעת פתיחת המסמך מחדש ב- Word באינטרנט.

זקוק לעזרה נוספת?

הרחב את הכישורים שלך
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Microsoft insider

האם מידע זה היה שימושי?

עד כמה אתה מרוצה מאיכות התרגום?
מה השפיע על החוויה שלך?

תודה על המשוב!

×