מאפייני הבעיה

כאשר אתה מנסה להתקין או לשדרג מחשב לקוח Microsoft Dynamics CRM עבור Microsoft Office Outlook, מתקבלת הודעת השגיאה הבאה:

הפעולה Microsoft.Crm.Config.Client.InstallAbpAction נכשלה.

Access is denied.‎ (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

בנוסף, מופיעה אחת מהודעות השגיאה הבאות.

הודעת שגיאה 1 כאשר אתה מתקין מחשב לקוח Microsoft Dynamics CRM 4.0 עבור Outlook, מתקבלת הודעת השגיאה הבאה ביומן הגדרת התצורה:

12:58:46| Error| Configuration exception.System.Exception: הפעולה Microsoft.Crm.Config.Client.InstallAbpAction נכשלה. --->
System.UnauthorizedAccessException: Access is denied.‎ (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

ב-System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)

ב-Microsoft.Crm.Config.Client.InstallAbpAction.Do(IDictionary parameters)‎

ב-Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)

--- סוף מעקב מחסנית חריג פנימית ---

ב-Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)

ב-Microsoft.Crm.Setup.Common.Installer.Install(IDictionary stateSaver)‎

ב-Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall(IDictionary stateSaver)

ב-Microsoft.Crm.Setup.Common.ComposedInstaller.Install(IDictionary stateSaver)

ב-Microsoft.Crm.Config.Client.ClientConfig.Install(IDictionary data)

ב-Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46|Verbose| Configuration Failed 12:58:46| Info| לא ניתן להגדיר בהצלחה את Microsoft Dynamics CRM עבור Outlook:



הפעולה Microsoft.Crm.Config.Client.InstallAbpAction נכשלה.

Access is denied.‎ (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

הודעת שגיאה 2 כאשר אתה משדרג מחשב לקוח Microsoft Dynamics CRM 3.0 עבור Outlook, מתקבלת הודעת השגיאה הבאה ביומן ההתקנה:

UpgradeDatabase.Action

UpgradeDatabase.Started

מחפש קובצי מסד נתונים

מזיז קובצי מסד נתונים

הסתיימו הפעולות על מסד הנתונים

מקצה הרשאות עבור S-1-5-21-682003330-616249376-1801674531-1112

C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf

ב-System.Security.AccessControl.NativeObjectSecurity.CreateInternal(ResourceType resourceType, Boolean isContainer, String name, SafeHandle handle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)

ב-System.Security.AccessControl.FileSystemSecurity..ctor(Boolean isContainer, String name, AccessControlSections includeSections, Boolean isDirectory)

ב-System.Security.AccessControl.FileSecurity..ctor(String fileName, AccessControlSections includeSections)

ב-System.IO.FileInfo.GetAccessControl() ב-Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade(Session session)

ב-Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase(Session session)‎

Action ended 10:33:09: InstallFinalize. Return value 3.

כאשר אתה מנסה להגדיר את גירסת Outlook Offline Client של Microsoft Dynamics CRM 4.0, מתקבלת בעקביות הודעת השגיאה הבאה בחלון מודאלי נסה שוב/בטל:

הפעולה Microsoft.Crm.Config.Client.InstallPstAction נכשלה. LaunchOutlookInstallerProcess נכשל.

סיבה

בעיה זו עלולה להתרחש אם קובץ נתוני Microsoft Dynamics CRM לא הוסר לחלוטין ואם אנשי קשר Microsoft Dynamics CRM ABP לא הוסרו לחלוטין.

פתרון הבעיה

פתרון 1

כדי לפתור בעיה זו השתמש באחת מהשיטות הבאות ואז נסה להתקין או לשדרג מחשב לקוח Microsoft Dynamics CRM עבור Outlook.

שיטה 1: אם Microsoft Office Outlook 2007 מותקן

  1. הפעל את Outlook 2007.

  2. בתפריט כלים, לחץ על הגדרות חשבון.

  3. לחץ על הכרטיסייה קובצי נתונים.

  4. לחץ על Microsoft CRM ולאחר מכן לחץ על הסרה.

  5. לחץ על הכרטיסייה פנקסי כתובות.

  6. לחץ על פנקס כתובות של Microsoft CRM ולאחר מכן לחץ על הסרה.

  7. סגור את Outlook 2007.

שיטה 2: אם Microsoft Office Outlook 2003 מותקן

  1. סגור את Outlook 2003.

  2. לחץ על התחל, לחץ על לוח הבקרה, לחץ על חשבונות משתמשים ולאחר מכן לחץ על דואר.

  3. בתיבת הדו-שיח הגדרת דואר, לחץ על קובצי נתונים.

  4. לחץ על Microsoft CRM, לחץ על הסרה ולאחר מכן לחץ על סגור.

  5. בתיבת הדו-שיח הגדרת דואר, לחץ על חשבונות דואר אלקטרוני.

  6. לחץ על הצג או שנה מדריכי כתובות או פנקסי כתובות קיימים ולאחר מכן לחץ על הבא.

  7. לחץ על פנקס כתובות של Microsoft CRM ולאחר מכן לחץ על הסרה.

  8. לחץ על סגור כדי לסגור את תיבת הדו-שיח הגדרת דואר.

פתרון 2

בצע את הפעולות הבאות:

  1. הפעל את Outlook.

  2. בתפריט כלים, לחץ על אפשרויות.

  3. בכרטיסייה הגדרת דואר, לחץ על חשבונות דואר אלקטרוני.

  4. בכרטיסייה קובצי נתונים, בחר Microsoft CRM- לא זמין, ואז לחץ על הסר.

זקוק לעזרה נוספת?

הרחב את הכישורים שלך
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Microsoft insider

האם מידע זה היה שימושי?

עד כמה אתם מרוצים מאיכות השפה?
מה השפיע על החוויה שלכם?

תודה על המשוב!

×