User photos aren't synced from the on-premises environment to Exchange Online in a hybrid deployment
Symptoms
You have a hybrid deployment of on-premises Microsoft Exchange Server and Exchange Online in Microsoft 365. When you change a Microsoft 365 user's photo by accessing that user's on-premises information, the change isn't synced to Exchange Online. For example, when the user views the photo in Outlook, Outlook on the web (formerly known as Outlook Web App), or Microsoft Teams, the user's previous Exchange Online profile photo is still displayed.
Cause
Although the thumbnailPhoto
attribute is synced from the on-premises environment to Microsoft Entra ID, the following behaviors could cause this problem:
- The
thumbnailPhoto
attribute can store a user photo as large as 100 kilobytes (KB). - Exchange Online accepts only a photo that's no larger than 10 KB from Microsoft Entra ID.
Resolution
Use the Microsoft 365 admin center or Microsoft Graph PowerShell to change the user's photo. These methods enable admins to upload a photo that's as large as 4 MB. For instructions, see Change user profile photos.
References
Still need help? Go to Microsoft Community or the Exchange TechNet Forums.
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