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Summary

This article describes an issue in which you cannot find files when you search a Windows Vista-based computer even though the files exist on the computer. This article lists methods that you can use to resolve this issue when you search any location and when you search the index.

For help with Windows Search problems in Windows Vista automatically, click Run now button from the Automated Troubleshooting Services page and follow the steps in this wizard:

Fix problems in which Windows Search is not working or searches are slower

Symptoms

You experience issues when you try to find files on a computer that is running Windows Vista. For example, when you search for files by using a search term, you cannot find the files that you expect to find. The items do not appear in the search results. You experience this symptom even though the files exist on the computer.

Cause

This issue may occur in any of the following scenarios.

  • When you search any location, you experience the symptoms in the "Symptoms" section if any one of the following conditions is true:

    • The file is not in the location that you are currently searching

    • The file is located in a system folder.

    • The file is a hidden file.

    • The file does not appear in the first five thousand items that are listed in the search results

    • The file contains the search term in one of its properties and not in the file name

  • When you search the index, you experience the symptoms in the "Symptoms" section if any one of the following conditions is true:

    • The file is not in an indexed location.

    • The file type of the file is not indexed.

    • The file has properties that prevent it from being indexed.

    • The indexer has not yet inserted the file into the index.

    • The indexer is overlooking the file.

    • The items in the search results do not match the file that you are searching for.

Windows Vista includes new methods that enable faster searching of files. However, these new methods may be unfamiliar and cause some confusion to users who are not familiar with them.

Resolution

To resolve this issue, use one or more of the following methods, as appropriate for your situation.

When you search any location

This section lists methods that you can use to help you resolve this issue when you search any location for a file. Each method corresponds to an item that is listed in the "Cause" section.

Cause 1: The file is not in the location that you are currently searching

Make sure that the file that you want to find is within the scope of the location that you are searching. To determine the location that you are currently searching, follow these steps:

  1. Under Did you find what you were looking for? at the bottom of the search results window, click Advanced Search.

  2. In the Advanced Search area, note the location that you are currently searching.

The location that you are searching must contain the file that you are looking for.

Search everywhere on the computer

To search everywhere on the computer, click Everywhere in the Location box, and then click to select the Include non-indexed, hidden, and system files (might be slow) check box.

Search only indexed locations

To search only indexed locations, click Indexed Locations in the Location box.

Cause 2: The file is located in a system folder

By default, when you try to find a file that is located on your computer, Windows Vista does not search system folders. System folders include the Program Files folder and the Windows folder. To search a system folder, use one of the following methods.

Method 1

Search within the system folder that contains the file. For example, if you want to find the Shell32.dll file, do not search by using the Everywhere option. Instead, locate the Drive:\Windows folder, and then search for the Shell32.dll file.

Method 2

Click Organize, and then click Folder and Search Options. In the Folder Options dialog box, click the Search tab, and then under When searching non-indexed locations, click to select the Include system directories check box.

Method 3

In the Advanced Search area, click to select the Include non-indexed, hidden, and system files (might be slow) check box.

Cause 3: The file is a hidden file

To display hidden files in the search results, use one of the following methods.

Method 1

Click Organize, and then click Folder and Search Options. In the Folder Options dialog box, click the View tab, and then under Hidden files and folders, click Show hidden files and folders.

Method 2

In the Advanced Search area, click to select the Include non-indexed, hidden, and system files (might be slow) check box.

Cause 4: The file does not appear in the first five thousand items that are listed in the search results

If Windows Vista finds more than five thousand search results, you receive the following message:

There are more results than will fit in this view. Narrow your results with the Search box or click to see all results…You can show all the search results. To do this, click the message. Or you can reduce the number of items that appear in the search results. To do this, add more search terms. For example, add the file type as a search term. To use more advanced methods to filter search results, use the options that are available in the Advanced Search area.

Cause 5: The file contains the search term in one of its properties and not in the file name

When you type a term in the Search box, Windows Vista always searches file names. If the file is in the index, Windows Vista also searches the file properties. File properties include the file type, the author, content such as words and phrases in the file, and comments that were added to pictures. To search for content in a file if the file is not in the index, use one of the following methods.

Method 1

Click Organize, and then click Folder and Search Options. In the Folder Options dialog box, click the Search tab, and then click to select the Always search filenames and contents (might be slow) check box.

Method 2

If you search a location that is not in the index, under Did you find what you were looking for? at the bottom of the search results window, click Search in File Contents.

When you search the index

This section lists methods that you can use to help you resolve this issue when you search the index for a file. Each method corresponds to an item that is listed in the "Cause" section.

Cause 1: The file is not in an indexed location

If you click Indexed Locations to search indexed locations, the location of the item that you want to find must be in the index. To determine whether files and folders that you expect to appear in the search results are located in the index, follow these steps:

  1. Click Start Start button , click Control Panel, and then click System and Maintenance.

  2. Click Indexing Options. The folders that are indexed are listed under Included Locations in the Indexing Options dialog box.

  3. To view the path of the folders that are in the index, click Modify and then click Show all locations. Under Summary of selected locations, click the item that you want to view.

To add a location to the index, use one of the following procedures:

  • Use the options in the Indexing Options dialog box to add, to remove, or to exclude locations from the index.

  • In scenarios where you search a location that is not in the index, you receive the following message:

    Searches might be slow in non-indexed locations: Location. Click to add to index…To add the location to the index, click the message.

You can only add locations on the local computer to the index. If you search a computer on the network that is running Windows Vista, the indexed locations that are configured on the remote Windows Vista-based computer are used in the search.

You can add a folder from a computer on the network that is not running Windows Vista to the index. Before you add the folder to the index, you must use the FolderName Properties dialog box to make the folder available offline on the remote computer.

Cause 2: The file type of the file is not indexed

Certain file types are not included in the index. To view the file types that are included in the index, follow these steps:

  1. Click Start Start button , click Control Panel, and then click System and Maintenance.

  2. Click Indexing Options, and then click Advanced.

     User Account Control permission  If you are prompted for an administrator password or confirmation, type your password or click Continue.

  3. Click the File Types tab, and then view the list of file types. If the check box that is next to the file name extension is selected, the file type is included in the index. If the check box that is next to the file name extension is not selected, the file type is not included in the index.

Note You can also configure whether you want to index only the properties of specific file types or whether you want to index the properties and the contents of specific file types. To index on the properties of a file type, click Index Properties Only. To index the properties and the contents of a specific file type, click Index Properties and File Contents.

Cause 3: The file has properties that prevent it from being indexed

Files can have properties that prevent the files from being indexed. A file is not added to the index if any one of the following conditions is true:

  • The Index this file for faster searching check box is not selected. (To locate this check box, right-click the file, click Properties, and then click Advanced.)

  • The file is configured to use the Hidden attribute and the System attribute. Very few files use both these attributes. The Desktop.ini file is an example of a file that uses both attributes.

To find these files, use one of the following methods.

Method 1

Remove the properties or the attributes that prevent the file from being indexed.

Method 2

In the Advanced Search area, click to select the Include non-indexed, hidden, and system files (might be slow) check box.

Method 3

Click Organize, and then click Folder and Search Options. In the Folder Options dialog box, click the Search tab, and then under How to search, click to select the Don’t use the Index when searching the file system (might be slow) check box.

Cause 4: The indexer has not yet inserted the file into the index

Files are not immediately inserted into the index by the indexer. When there is no user activity, the indexer uses resources to process the backlog of files that have not yet been indexed. For example, you open the Indexing Options dialog box, and then you do not use the mouse or keyboard for 45 seconds. In the Indexing Options dialog box, you will see that the indexer increases the indexing speed to finish indexing items. The Indexing Options dialog box also shows whether indexing is completed. In scenarios where you add lots of new files to the computer, make sure that indexing is completed.

Cause 5: The indexer is overlooking the file

If you suspect that an issue exists in which the indexer does not contain a file or files that it should contain, rebuild the index. To have us rebuild the index for you, go to the "Fix it for me" section. If you prefer to rebuild the index yourself, go to the "Let me fix it myself" section.

Fix it for me



To rebuild the index automatically, click the
Fix this problemlink. Click
Runin the
File Downloaddialog box, and follow the steps in the Fix it wizard.




NoteThis wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

NoteIf you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.


Thanks to MVP Anand Khanse for contributing to this Fix it.

Next, go to the "Did this fix the problem?" section.



Let me fix it myself



To rebuild the index, follow these steps:

  1. Click Start Start button , click Control Panel, and then click System and Maintenance.

  2. Click Indexing Options, and then click Advanced.

     User Account Control permission  If you are prompted for an administrator password or confirmation, type your password or click Continue.

  3. Click Rebuild. When you are prompted to confirm that you want to rebuild the index, click OK.

  4. Once the Rebuild is complete, reboot your computer.

Rebuilding the index may take some time to finish. During the rebuild operation, the indexer tries to reinsert all items into the index.

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.

Cause 6: The items in the search results do not match the file that you are searching for

When you use the Search box to search the index, the search includes properties such as author, artist, tags, and file contents. Use the Advanced Search area to specify what you are looking for.

For more information about how to search for files by using advanced query syntax, see Windows Vista Help.

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