Client Machines Are Taking Too Long To Log On To The Domain

Author:

Nirmal Sharma MVP

COMMUNITY SOLUTIONS CONTENT DISCLAIMER

MICROSOFT CORPORATION AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY, RELIABILITY, OR ACCURACY OF THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN. ALL SUCH INFORMATION AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, WORKMANLIKE EFFORT, TITLE AND NON-INFRINGEMENT. YOU SPECIFICALLY AGREE THAT IN NO EVENT SHALL MICROSOFT AND/OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, PUNITIVE, INCIDENTAL, SPECIAL, CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA OR PROFITS, ARISING OUT OF OR IN ANY WAY CONNECTED WITH THE USE OF OR INABILITY TO USE THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF MICROSOFT OR ANY OF ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES.

SUMMARY

The following knowledgebase explains the issue when client machines take too long to log on to domain.

CAUSE

The following knowledgebase explains the issue when client machines take too long to log on to domain:

RESOLUTION

Client computers use DNS to find the domain controllers. If  DNS is not running or SRV records of domain controllers are not registered then client computers will not be able to log on to the domain.
 
You can use the following tools to verify the SRV registration in the domain:
 
  • NetDiag /v
  • Netlogon
  • Pinging _Ldap records.
 
The above command will display if there is any problem with the SRV records of the domain controller.
 
If all the client computes in your network are taking too long to log on to the network then please verify if the SRV records of the domain controllers are registered in the domain.
 
You can use the following options to re-register the SRV records of a domain controller in the DNS:
 
  1. Restart the Netlogon Serivce.
  2. Use DcDiag /fix or NetDiag /fix
  3. Local the Netlogon.dns file in \Windows\System32\Config directory and manually add them into the DNS Zone of that domain.
 
गुण

आलेख ID: 555998 - पिछली समीक्षा: 14/02/2017 - संशोधन: 1

Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition

प्रतिक्रिया