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Symptoms

You have Microsoft Office SharePoint Workspace 2010 clients or Microsoft Office Groove 2007 clients. These clients are provisioned to Microsoft Office Groove Server 2007 Relay or Microsoft Office Groove Server 2010 Relay on a computer that is running Windows Server 2008 R2. These clients may occasionally experience the following problems:

  • A Groove Workspace synchronization error.

  • Groove instant messages that are transmitted through the relay server are missing.

The affected SharePoint Workspace client will recover from the data loss by resending the workspace data automatically. However, the affected workspace may be unrecoverable in some instances.

When this problem occurs, the relay server administrative trace log contains one of the following error messages:

  • GCFFQOpGetNext::CompleteMessageAvailable: From canonical failed

  • GCFFQOpAdvance::AdvanceMessage: Advancing already deleted message

  • GCFFQOpGetNext::SendCachedMessage: Can't send

Cause

This problem occurs because of a race condition in the NTFS file system. This behavior may cause write failures.

Groove Server 2007 Relay or Groove Server 2010 Relay that is running on Windows Server 2008 R2 may occasionally not persist end user data to disk. This behavior may occur under heavy server load conditions. This behavior may also occur when a client is updating the content of a workspace that has a large number of participants.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760
    0.20xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Ntfs.sys

6.1.7600.20884

1,685,888

20-Jan-2011

08:03

x64

Ntfs.sys

6.1.7601.21645

1,659,776

20-Jan-2011

07:48

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Ntfs.sys

6.1.7600.20884

3,552,640

20-Jan-2011

07:06

IA-64

Ntfs.sys

6.1.7601.21645

3,553,152

20-Jan-2011

06:46

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Groove Server Relay architecture, visit the following Web site:

http://technet.microsoft.com/en-us/library/cc261969.aspxFor more information about the WriteFile function, visit the following Web site:

http://msdn.microsoft.com/en-us/library/aa365747(VS.85).aspxFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20884_none_02eebf7d4fbb1b49.manifest

File version

Not Applicable

File size

14,514

Date (UTC)

20-Jan-2011

Time (UTC)

08:34

Platform

Not Applicable

File name

Amd64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7601.21645_none_05015c7d4cc030c8.manifest

File version

Not Applicable

File size

14,514

Date (UTC)

20-Jan-2011

Time (UTC)

08:18

Platform

Not Applicable

File name

Update.mum

File version

Not Applicable

File size

3,207

Date (UTC)

20-Jan-2011

Time (UTC)

20:10

Platform

Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20884_none_a6d1c7ef975bb30f.manifest

File version

Not Applicable

File size

14,511

Date (UTC)

20-Jan-2011

Time (UTC)

08:32

Platform

Not Applicable

File name

Ia64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7601.21645_none_a8e464ef9460c88e.manifest

File version

Not Applicable

File size

14,511

Date (UTC)

20-Jan-2011

Time (UTC)

07:58

Platform

Not Applicable

File name

Update.mum

File version

Not Applicable

File size

2,160

Date (UTC)

20-Jan-2011

Time (UTC)

20:10

Platform

Not Applicable

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