Az utolsó cella megadása az Excel alkalmazásban

Összefoglaló

A Microsoft Excel a munkalapoknak csupán azt a részét menti el, amelyik használatban van, azaz amelyik adatokat vagy formázást tartalmaz. Előfordulhat azonban, hogy a munkalap utolsó cellája kívül esik a ténylegesen használt adatok tartományán. A probléma következtében előfordulhat, hogy a kapott fájl nagyobb lesz a feltétlenül szükségesnél, hogy felesleges oldalakat is ki kell nyomtatnia, hogy „Nincs elég memória” tartalmú hibaüzeneteket kap, vagy más szokatlan viselkedést tapasztal. A fölösleges sorok és oszlopok törlése és az utolsó cella visszaállítása segíthet megoldani az efféle problémákat.

Megjegyzés: Az aktív munkalap utolsó celláját a CTRL+SHIFT+END megnyomásával keresheti meg.

További információ

A legtöbb esetben annak, hogy az utolsó cella a munkalap tartományán kívülre esik, a túlságosan sok formázás használata az oka. Ha teljes sorokat és oszlopokat formáz, egyes formázástípusok következtében az utolsó cella jobbra vagy alul jelentősen túl fog lógni a ténylegesen használt tartományon.

Ez a probléma Lotus 1-2-3 fájlok Excel fájlba való importálásakor is előfordulhat. A Lotus fájlok Excel munkafüzet formátumban való mentésekor az Excel nem képes meghatározni a Lotus 1-2-3 munkalap utolsó celláját, ezért az egész munkalapot aktiválja. Az utolsó cella címének visszaállításához el kell távolítani munkalap nem használt soraiban és oszlopaiban lévő felesleges információt (adatok és formázás), amihez az alábbi módszerek egyikét alkalmazhatja. A felesleges információ eltávolítása után mentse a munkalapot, hogy az Excel újból létrehozza az aktív cellatáblázatot.

Megjegyzés: A következő módszerek használata esetén előfordulhat, hogy a „Nincs elég memória” vagy más hasonló hibaüzenet jelenik meg. Ennek oka, hogy az Excel törölni próbálja a kiválasztott tartományt. Ha ezt a hibaüzenetet kapja, kisebb sor- vagy oszloptartományonként próbáljon törölni.

1. módszer: A felesleges sorok és oszlopok kézi törlése

Az utolsó cellának a felesleges sorok és oszlopok manuális törlésével való visszaállításához kövesse az alábbi lépéseket:
  1. A megfelelő oszlopfejlécek kiválasztásával jelölje ki az utolsó adatokat tartalmazó oszloptól jobbra található valamennyi oszlopot.

    Tipp: Ennek egy egyszerű módja az, ha lenyomja az F5 billentyűt, és beírja a megfelelő hivatkozást. Írja be például az F:IV értéket az oszlopokhoz, vagy írja be az 5:65536 értéket a sorokhoz.
  2. A Szerkesztés menüben mutasson a Tartalom törlése pontra, majd kattintson a Mindent parancsra.

    Megjegyzés: Ha ezzel a lépéssel nem törlődik az összes felesleges formázás, akkor a cellák teljes eltávolításához kattintson a jobb gombbal az oszlopokra, majd válassza a Törlés parancsot. Képletek által hivatkozott cellák törlése esetén a hivatkozás a következőre módosul: #HIV!. Ezért ajánlott az eredeti fájlról biztonsági másolatot készíteni, majd a lépések végrehajtását követően ellenőrizni a „#HIV!” jelzésekhez tartozó képleteket.
  3. Az 1. és a 2. lépést ismételje meg az utolsó adatokat tartalmazó sor alatti sorokkal is.
  4. Mentse a fájlt.
  5. A fájlban végzett munka folytatásához zárja be a fájlt, majd nyissa meg újra.

2. módszer: Az Excel egyik bővítményének használata

Megjegyzés: A következőkben bemutatott Excel-bővítmény csak az Excel angol nyelvű változatában alkalmazható, a nem angol nyelvű változatokban nem. Javasoljuk, hogy az Excel-bővítmény használata előtt változtassa meg az Excel nyelvi beállítását.

Most letölthető a felesleges formázás eltávolítására és az utolsó cella visszaállítására alkalmas Excel-bővítmény. A bővítmény a Microsoft következő webhelyéről tölthető le:
  1. A letöltési oldalon kattintson a Letöltés gombra. Amikor a rendszer arra kéri, nyomja meg a Megnyitás vagy a Futtatás gombot.
  2. A licencszerződés megjelenésekor kattintson az Igen gombra.
  3. A WinZip Self-Extractor ablakának megjelenésekor kattintson a Browse (Tallózás) gombra, majd jelölje ki a bővítmény kibontásának helyét.

    Megjegyzés: Ha a fájlt az Excel-bővítmények számára kijelölt helyen bontja ki, a bővítmény automatikusan meg fog jelenni az Excel alkalmazás Bővítmények párbeszédpanelén. Ez a hely az Office telepítési mappájának Library almappája, amely az esetek nagy részében a C:\Program Files\Microsoft Office\Office\Library mappa.

    Miután a Browse párbeszédpanelen kiválasztotta a kívánt letöltési helyet, a WinZip párbeszédpanelen kattintson az UnZip (Kibontás) gombra. Kattintson a sikeres letöltésről tájékoztató párbeszédpanelen az OK gombra, majd a WinZip párbeszédpanelen a Close (Bezárás) gombra.
  4. Indítsa el az Excelt, és hajtsa végre az alábbi lépéseket, az Excel telepített verziójának megfelelően.

    Microsoft Office Excel 2007

    1. Kattintson a Microsoft Office gombra, majd Az Excel beállításai gombra.
    2. A Kezelés párbeszédpanelen kattintson a Bővítmények, majd az Excel-bővítmények elemre, végül kattintson az Ugrás gombra.
    3. Ha nem a Library mappába mentette a fájlt, kattintson a Tallózás gombra, majd a Tallózás ablakban keresse meg és jelölje ki a mentett fájlt.
    4. Kattintson az Excess Format Cleaner 1.1 elemre, majd az OK gombra.

    A Microsoft Office Excel 2003 és az Excel korábbi verziói

    1. Kattintson az Eszközök menü Bővítmények parancsára.
    2. Ha nem a Library mappába mentette a fájlt, kattintson a Tallózás gombra, majd a Tallózás ablakban keresse meg és jelölje ki a mentett fájlt.
    3. Kattintson az Excess Format Cleaner 1.1 elemre, majd az OK gombra.
  5. Az Excel 2007 alkalmazásban kattintson a Bővítmények fülre, majd a Menüparancsok csoportban kattintson a Clear Excess Formats in XSFormatCleaner.xla (Felesleges formázások eltávolítása az XSFormatCleaner.xla fájlban) elemre.

    Az Excel 2003 alkalmazásban és az Excel korábbi verzióiban annyit kell tennie, hogy megnyitja a megtisztítani kívánt munkafüzetet, majd kattintson a Fájl menü Clear Excess Formatting in munkafüzet_neve (Felesleges formázás törlése a következőben: munkafüzet_neve) parancsára. Ezután a makró eltávolítja a felesleges formázást a fájlban található munkalapokból.

    A makró futásának befejeződésekor egy üzenet jelenik meg, amely figyelmezteti, hogy a változtatások rögzítéséhez el kell mentenie a munkafüzetet.
  6. Mentse, zárja be, majd nyissa meg újra a fájlt.
Tulajdonságok

Cikkazonosító: 244435 - Utolsó ellenőrzés: 2008. máj. 21. - Verziószám: 1

Visszajelzés