Jelenleg nem kapcsolódik az internethez. Várakozás a kapcsolat helyreállítására

MS10-022: A Visual Basic Scripting (VBScript) 5.6 biztonsági frissítése: 2010. április 13.

A Windows XP támogatása megszűnt

A Microsoft 2014. április 8-án megszüntette a Windows XP terméktámogatását. Ez a változás kihatással van a szoftverfrissítésekre és a biztonsági beállításokra. Megtudhatja, hogy ez milyen következményekkel jár és hogyan tarthatja fenn rendszere védelmét.

2015. július 14-én véget ért a Windows Server 2003 támogatása

2015. július 14-én a Microsoft megszüntette a Windows Server 2003 támogatását. Ez a változás kihatással van a szoftverfrissítésekre és a biztonsági beállításokra. Megtudhatja, hogy ez milyen következményekkel jár és hogyan tarthatja fenn rendszere védelmét.

BEVEZETÉS
A Microsoft közzétette az MS10-022 jelű biztonsági közleményt. A biztonsági közlemény teljes szövege a Microsoft alábbi webhelyein tekinthető meg:

Támogatás és segítségnyújtás a biztonsági frissítéshez

Az otthoni felhasználók az Amerikai Egyesült Államokban, illetve Kanadában díjmentes telefonos támogatást kaphatnak az 1-866-PCSAFETY számon, illetve más országokban a Microsoft helyi képviseletétől. A biztonsági frissítésekhez támogatást nyújtó helyi Microsoft-képviseletek elérhetőségéről az alábbi nemzetközi támogatási webhelyen tájékozódhat: Az észak-amerikai ügyfelek a Microsoft alábbi webhelyén továbbá ingyenes e-mailes vagy korlátlan egyedi, csevegőprogramon keresztüli támogatást is kaphatnak: A vállalati ügyfelek a biztonsági frissítésekhez saját tanácsadóiktól kaphatnak támogatást.
További információ

További információk a biztonsági frissítésről

Ismert probléma

Tudomásunkra jutott egy, a számítógépek kis hányadát érintő probléma, mely az alábbi feltételek együttes fennállásakor fordulhat elő:
  • A Windows XP Service Pack 3 szervizcsomag telepítve van.
  • Manuálisan telepítve lett a Windows Script Host 5.6 egy régebbi verziója.
Megjegyzés: Alapértelmezés szerint a Windows XP Service Pack 3 a Windows Script Host 5.7-es verzióját telepíti. Ez az ismert probléma csak azokat a számítógépeket érinti, amelyeken a Windows Script Host egy régebbi verziója manuálisan telepítve lett (a régebbi verzió telepítése indokolatlan).

Az ismert probléma által érintett számítógépeken előfordulhat, hogy ez a biztonsági frissítés nem telepíthető, mert a rendszerben a Vbscript.dll fájl egy nem megfelelő verziója található meg. Ahhoz, hogy a jelen biztonsági frissítést telepíteni lehessen Windows XP Service Pack 3 rendszerre, minimum 5.7-es verziójú Vbscript.dll fájl szükséges.

Azokon a Windows XP Service Pack 3 rendszerű számítógépeken, amelyeken 5.6-os verziójú Vbscript.dll fájl található, a probléma megoldásához kövesse az alábbi módszereket, a Windows Internet Explorer telepített verziójának megfelelően.

Internet Explorer 6 esetén
  1. Állítsa vissza a Vbscript.dll fájl megfelelő verzióját.

    A Vbscript.dll fájl 5.7-es verziójának visszaállításához hajtsa végre az alábbiak egyikét:
    • Töltse le és telepítse a Windows XP parancsfájl-végrehajtójának KB951978 jelű frissítését:
      951978 A parancsfájlok kimenete nem jelenik meg a várt módon VBScript- vagy JScript-parancsfájlok futtatásakor a Windows Vista Service Pack 1, a Windows Server 2008 vagy a Windows XP Service Pack 3 rendszerben (Előfordulhat, hogy a hivatkozás részben vagy teljes egészében angol nyelvű tartalomra mutat.)
      Megjegyzés: Ha engedélyezte az automatikus frissítéseket, akkor ezt a frissítést a rendszer automatikusan felajánlja.
    • Frissítsen az Internet Explorer 8 böngészőre. Az Internet Explorer 8 beszerzéséről további tudnivalókat a Microsoft alábbi webhelyén talál:Megjegyzés: Ha engedélyezte az automatikus frissítéseket, akkor ezt a frissítést a rendszer automatikusan felajánlja.
    • Frissítsen az Internet Explorer 7 böngészőre. Az Internet Explorer 7 beszerzéséről további tudnivalókat a Microsoft alábbi webhelyén talál:
  2. Telepítse a biztonsági frissítést.

    Miután a fenti módon sikeresen visszaállította a Vbscript.dll fájl megfelelő verzióját, telepítse a VBScript 5.7 szoftver Windows XP Service Pack 3 rendszerhez készült biztonsági frissítését (KB981349) az MS10-022 jelű biztonsági közleményben írtaknak megfelelően.

    Megjegyzés: Ezt a biztonsági frissítést felajánlja az automatikus frissítési szolgáltatás, ha a Vbscript.dll fájl verziója legalább 5.7.0.0.
Internet Explorer 7 esetén
  1. Állítsa vissza a Vbscript.dll fájl megfelelő verzióját.

    A Vbscript.dll fájl 5.7-es verziójának visszaállításához hajtsa végre az alábbiak egyikét:
    • Töltse le és telepítse a Windows XP parancsfájl-végrehajtójának KB951978 jelű frissítését:
      951978 A parancsfájlok kimenete nem jelenik meg a várt módon VBScript- vagy JScript-parancsfájlok futtatásakor a Windows Vista Service Pack 1, a Windows Server 2008 vagy a Windows XP Service Pack 3 rendszerben (Előfordulhat, hogy a hivatkozás részben vagy teljes egészében angol nyelvű tartalomra mutat.)
      Megjegyzés: Ha engedélyezte az automatikus frissítéseket, akkor ezt a frissítést a rendszer automatikusan felajánlja.
    • Frissítsen az Internet Explorer 8 böngészőre. Az Internet Explorer 8 beszerzéséről további tudnivalókat a Microsoft alábbi webhelyén talál:Megjegyzés: Ha engedélyezte az automatikus frissítéseket, akkor ezt a frissítést a rendszer automatikusan felajánlja.
    • Távolítsa el az Internet Explorer 7 böngészőt, majd telepítse azt újra.
  2. Telepítse a biztonsági frissítést.

    Miután a fenti módon sikeresen visszaállította a Vbscript.dll fájl megfelelő verzióját, telepítse a VBScript 5.7 szoftver Windows XP Service Pack 3 rendszerhez készült biztonsági frissítését (KB981349) az MS10-022 jelű biztonsági közleményben írtaknak megfelelően.

    Megjegyzés: Ha engedélyezte az automatikus frissítéseket, akkor ezt a frissítést a rendszer automatikusan felajánlja.
Internet Explorer 8 esetén

Ha telepítve van az Internet Explorer 8 böngésző, és be van kapcsolva az automatikus frissítési szolgáltatás, a rendszer automatikusan felajánlja a megfelelő frissítést, külön beavatkozás nélkül. Ha mégis manuálisan kellene telepítenie ezt a biztonsági frissítést, telepítse a VBScript 5.8 alkalmazás Windows XP Service Pack 3 rendszerhez készült biztonsági frissítését (KB981349) az MS10-022 jelű biztonsági közleményben írtaknak megfelelően.

A biztonsági frissítés telepítésének előfeltételei

A biztonsági frissítés telepítéséhez a számítógépen telepítve kell lennie a Microsoft Visual Basic Scripting Edition (VBScript) 5.6 szoftvernek.

A VBScript 5.6 az alábbiakkal telepíthető:
  • Microsoft Internet Explorer 6
  • Windows Server 2003 (A következő változatok: x86 SP2, x64 SP2 és Itanium SP2)
  • Windows XP (A következő változatok: x86 SP2 és x64 SP2)
  • Windows Script Host 5.6
A számítógépen telepített VBScript verzióját az alábbiakban ismertetett lépések végrehajtásával állapíthatja meg:
  1. Nyissa meg a Windows Intézőt.
  2. Nyissa meg a következő mappát:
    %systemroot%\system32
  3. Kattintson a jobb gombbal a Vbscript.dll fájlra, és kattintson a Tulajdonságok parancsra.
  4. Kattintson a Részletek fülre a Fájlverzió mező értékének megtekintéséhez.
Ha a fájlverzió az „5.6” értékkel kezdődik (például „5.6.0.8825”), akkor a VBScript 5.6-os verziója van telepítve a számítógépen.

Eltávolítási információk

A jelen biztonsági frissítést az alábbi módon távolíthatja el:
  • Használja a Vezérlőpult alkalmazás Programok telepítése és törlése elemét.
  • Használja az Spuninst.exe segédprogramot, mely a következő mappában található:
    %Windir%\$NTUninstallKB981350$\Spuninst

Újraindítás szükségessége

A biztonsági frissítés telepítését követően előfordulhat, hogy újra kell indítani a számítógépet.

Fájlinformációk

A biztonsági frissítés angol nyelvű (egyesült államokbeli) változata a következő táblázatban található fájlattribútumokkal (vagy újabbakkal) rendelkezik. A fájlok dátuma és időpontja egyezményes világidő (UTC) szerint van megadva. A fájlinformációk megtekintése során a dátumok és időpontok helyi időre konvertálódnak. A helyi idő és az egyezményes világidő közötti különbségről a Vezérlőpultról elérhető Dátum és idő párbeszédpanel Időzóna lapján tájékozódhat.
A Windows 2000 SP4 összes támogatott x86-alapú változata esetén
File nameFile versionFile sizeDateTimePlatform
Vbscript.dll5.6.0.8838401,40812-Mar-201021:44x86
A Windows XP Service Pack 2 összes támogatott x86-alapú változata esetén
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838417,79210-Mar-201008:02x86SP2SP2GDR
Vbscript.dll5.6.0.8838417,79210-Mar-201008:07x86SP2SP2QFE
A Windows Server 2003 Service Pack 2 összes támogatott x86-alapú változata esetén
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838401,40809-Mar-201005:20x86SP2SP2GDR
Vbscript.dll5.6.0.8838401,40809-Mar-201005:27x86SP2SP2QFE
A Windows Server 2003 SP2 és a Windows XP Professional SP2 összes támogatott x64-alapú változata esetén
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838663,04009-Mar-201004:43x64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:43x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.8838663,55209-Mar-201004:38x64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
A Windows Server 2003 SP2 összes támogatott Itanium-alapú változata esetén
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.88381,116,67209-Mar-201004:41IA-64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:41x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.88381,117,69609-Mar-201004:38IA-64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
Tulajdonságok

Cikkazonosító: 981350 - Utolsó ellenőrzés: 04/19/2010 17:21:00 - Verziószám: 1.0

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows 2000 Service Pack 4
  • kbbug kbfix kbsecvulnerability kbqfe kbsecurity kbsecbulletin kbexpertiseinter kbsurveynew KB981350
Visszajelzés