A logikai függvények közé tartozó ÉS függvénnyel megállapítható, hogy egy adott vizsgálat összes feltétele IGAZ értékű-e.

Példa

Példák az ÉS függvényre

Az ÉS függvény az IGAZ értéket adja vissza, ha az összes argumentumának IGAZ az értéke. Ha legalább egy argumentuma HAMIS értékű, akkor a HAMIS értéket adja vissza.

Az ÉS függvény egyik leggyakoribb szerepe más, logikai vizsgálatokat végrehajtó függvények hasznosságának kiterjesztése. A HA függvény például egy logikai vizsgálatot végez, és IGAZ eredmény esetén egy adott értéket, HAMIS eredmény esetén pedig egy másik értéket ad vissza. Ha az ÉS függvényt használja fel a HA függvény logikai_vizsgálat argumentumaként, akkor nem csak egy, hanem egyszerre több különböző feltételt vizsgálhat.

Szintaxis

ÉS(logikai1; [logikai2]; ...)

Az ÉS függvény szintaxisa az alábbi argumentumokat foglalja magában:

Argumentum

Leírás

logikai1

Megadása kötelező. Az első vizsgálandó feltétel, amelynek IGAZ vagy HAMIS értéket kell adnia.

logikai2; ...

Nem kötelező. További tesztelni kívánt feltételek, amelyek IGAZ vagy HAMIS értéket kaphatnak, de legfeljebb 255 feltételt.

Megjegyzések

  • Az argumentumoknak logikai értékeket kell eredményezniük (például IGAZ vagy HAMIS), illetve olyan hivatkozásoknak vagy tömböknek kell lenniük, amelyek logikai értékeket tartalmaznak.

  • Ha egy tömb vagy hivatkozás argumentum szöveget vagy üres cellákat tartalmaz, akkor ezeket az értékeket figyelmen kívül hagyja a program.

  • Ha a megadott tartomány nem tartalmaz logikai értékeket, az ÉS függvény az #ÉRTÉK! hibát adja eredményül.

Példák

Az alábbiakban általános jellegű példákat adunk az ÉS függvény önálló használatára, valamint a HA függvénnyel együtt történő használatára.

Példák a HA és az ÉS függvény közös használatára

Képlet

Leírás

=ÉS(A2>1;A2<100)

Eredménye akkor IGAZ, ha az A2 cella értéke egynél nagyobb ÉS száznál kisebb. Minden más esetben a HAMIS értéket adja eredményül.

=HA(ÉS(A2<A3;A2<100);A2;"Az érték a tartományon kívül esik")

Az A2 cellában lévő értéket jeleníti meg, ha az kisebb az A3 cella értékénél ÉS száznál. Ellenkező esetben „Az érték a tartományon kívül esik” üzenetet jeleníti meg.

=HA(ÉS(A3>1;A3<100);A3;"Az érték a tartományon kívül esik")

Az A3 cellában lévő értéket jeleníti meg, ha az nagyobb 1-től ÉS kisebb 100-ig, ellenkező esetben üzenetet jelenít meg. Bármilyen üzenetet helyettesíthet.

Bónusz kiszámítása

A következő példa azt szemlélteti, hogy miként számítható ki az értékesítők bónusza a HA és az ÉS függvénnyel.

Példa arra, hogy hogyan számíthat ki értékesítési jutalékot a HA és az ÉS függvénnyel.  Az E14 cellában lévő képlet a következő: =HA(ÉS(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =HA(ÉS(B14>=$B$7;C14>=$B$5);B14*$B$8;0)HA az összforgalom nagyobb vagy egyenlő (>=), mint az értékesítési célérték ÉS az ügyfélszerzések száma nagyobb vagy egyenlő (>=), mint az ügyfélszerzési célérték, akkor az összforgalom szorzása a bónusz százalékos értékével, minden más esetben a 0 érték visszaadása.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Kapcsolódó témakörök

Videó: HA függvények haladóknak
További információ a beágyazott függvények képletekben való használatának mikéntjéből
HA függvény
VAGY függvény
NEM függvény
A képletek áttekintése a Excel
Hibás képletek elkerülése
Képlethibák észlelése
A Excel billentyűparancsai
Logikai függvények (hivatkozás)
Excel függvények (betűrendes)
Excel függvények kategória szerint

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×