ÉS függvény

A logikai függvények közé tartozó ÉS függvénnyel megállapítható, hogy egy adott vizsgálat összes feltétele IGAZ értékű-e.

Példa

Példák az ÉS függvényre

Az ÉS függvény az IGAZ értéket adja vissza, ha az összes argumentumának IGAZ az értéke. Ha legalább egy argumentuma HAMIS értékű, akkor a HAMIS értéket adja vissza.

Az ÉS függvény egyik leggyakoribb szerepe más, logikai vizsgálatokat végrehajtó függvények hasznosságának kiterjesztése. A HA függvény például egy logikai vizsgálatot végez, és IGAZ eredmény esetén egy adott értéket, HAMIS eredmény esetén pedig egy másik értéket ad vissza. Ha az ÉS függvényt használja fel a HA függvény logikai_vizsgálat argumentumaként, akkor nem csak egy, hanem egyszerre több különböző feltételt vizsgálhat.

Szintaxis

ÉS(logikai1; [logikai2]; ...)

Az ÉS függvény szintaxisa az alábbi argumentumokat foglalja magában:

Argumentum

Leírás

logikai1

Megadása kötelező. Az első vizsgálandó feltétel, amelynek IGAZ vagy HAMIS értéket kell adnia.

logikai2; ...

Megadása nem kötelező. A tesztelni kívánt további feltételek, amelyek kiértékelése igaz vagy hamis értékre, legfeljebb 255 feltételre.

Megjegyzések

  • Az argumentumoknak logikai értékeket kell eredményezniük (például IGAZ vagy HAMIS), illetve olyan hivatkozásoknak vagy tömböknek kell lenniük, amelyek logikai értékeket tartalmaznak.

  • Ha egy tömb vagy hivatkozás argumentum szöveget vagy üres cellákat tartalmaz, akkor ezeket az értékeket figyelmen kívül hagyja a program.

  • Ha a megadott tartomány nem tartalmaz logikai értékeket, az ÉS függvény az #ÉRTÉK! hibát adja eredményül.

Példák

Az alábbiakban általános jellegű példákat adunk az ÉS függvény önálló használatára, valamint a HA függvénnyel együtt történő használatára.

Példák a HA és az ÉS függvény közös használatára

Képlet

Leírás

=ÉS(A2>1;A2<100)

Eredménye akkor IGAZ, ha az A2 cella értéke egynél nagyobb ÉS száznál kisebb. Minden más esetben a HAMIS értéket adja eredményül.

=HA(ÉS(A2<A3;A2<100);A2;"Az érték a tartományon kívül esik")

Az A2 cellában lévő értéket jeleníti meg, ha az kisebb az A3 cella értékénél ÉS száznál. Ellenkező esetben „Az érték a tartományon kívül esik” üzenetet jeleníti meg.

=HA(ÉS(A3>1;A3<100);A3;"Az érték a tartományon kívül esik")

Az a3 cellában lévő értéket jeleníti meg, ha értéke nagyobb 1-nél, és nem kisebb, mint 100, ellenkező esetben egy üzenet jelenik meg. Tetszőleges üzenetet tetszés szerint helyettesíthet.

Bónusz kiszámítása

A következő példa azt szemlélteti, hogy miként számítható ki az értékesítők bónusza a HA és az ÉS függvénnyel.

Példa arra, hogy hogyan számíthat ki értékesítési jutalékot a HA és az ÉS függvénnyel.  Az E14 cellában lévő képlet a következő: =HA(ÉS(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =HA(ÉS(B14>=$B$7;C14>=$B$5);B14*$B$8;0)HA az összforgalom nagyobb vagy egyenlő (>=), mint az értékesítési célérték ÉS az ügyfélszerzések száma nagyobb vagy egyenlő (>=), mint az ügyfélszerzési célérték, akkor az összforgalom szorzása a bónusz százalékos értékével, minden más esetben a 0 érték visszaadása.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Kapcsolódó témakörök

Videó: az Advanced if függvényekkel
megtudhatja, hogy miként használhat beágyazott függvényeket képletekben
Ha a függvény
vagy a függvény
nem függvényt
tekint meg a képletek között az Excelben
A hibás képletek
észlelése
az Excel
logikai függvények (segédlet)
Excel-függvények (betűrendes)billentyűparancsai Excel- függvények (kategória szerint)

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×