#ÉRTÉK! hiba kijavítása az ÁTLAG vagy a SZUM függvényben

Ha az ÁTLAG vagy a SZUM függvény olyan cellára hivatkozik, amely #ÉRTÉK! hibát tartalmaz, akkor a képlet eredménye is #ÉRTÉK! hiba lesz.

#ÉRTÉK! hiba az ÁTLAG függvényben

A hibaérték elkerüléséhez létrehozunk egy olyan képletet, amely figyelmen kívül hagyja a hibákat a hivatkozott tartományban, és az átlagot a fennmaradt „normál” értékekből számítja ki.

A képletben az ÁTLAG függvényt a HA és a HIBÁS függvénnyel kombináljuk annak meghatározásához, hogy található-e hiba a megadott tartományban. Ez a megoldás tömbképlet használatát igényli:

=ÁTLAG(HA(HIBÁS(B2:D2);"";B2:D2))

Ez egy tömbképlet. Így vagy az ENTER billentyűt kell lenyomnia (csak akkor, ha Microsoft 365 t használja) vagy a CTRL + SHIFT + ENTER billentyűkombinációt a képletben.

Megjegyzés: Ha a Microsoft 365jelenlegi verziójával rendelkezik, akkor egyszerűen írja be a képletet a kimeneti cellába, majd nyomja le az ENTER billentyűt a képlet dinamikus tömbképletként való megerősítéséhez. Máskülönben a képletet örökölt tömbképletként kell beírnia, ha először kijelöli a kimeneti cellát, beírja a képletet a kimeneti cellába, majd a CTRL + SHIFT + ENTER billentyűkombinációt lenyomva erősítse meg. Az Excel a képlet elejére és végére beszúrja Ön helyett a kapcsos zárójeleket. A tömbképletekről további információt az Útmutatások és példák tömbképletek használatához című cikkben talál.

Tömbképlet az ÁTLAG függvényben az #ÉRTÉK! hiba javításához

Megjegyzés: A fenti képlet nemcsak az #ÉRTÉK! hibákhoz, de a #HIÁNYZIK, a #NULLA, a #ZÉRÓOSZTÓ! és más hibák esetében is használható.

A SZUM függvényt is használhatja hasonlóképpen:

=SZUM(HA(HIBÁS(B2:D2);"";B2:D2))

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel kérdését az Excel közösségi fórumában

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Az #ÉRTÉK! hiba javítása

ÁTLAG függvény

SZUM függvény

A képletek áttekintése az Excelben

A képlethibák feltárása

Az Excel összes függvénye (betűrendes)

Az Excel függvényeinek kategória szerinti listája

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Egy előfizetés, amellyel maradéktalanul kihasználhatja idejét

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×