A cellákban található karakterek megszámolása

A cellákban található karakterek megszámolása

Ha meg kell számolnia a cellák karaktereit, használja a HOSSZfüggvényt , amely megszámolja a betűket, számokat, karaktereket és minden szóközt. A "Ma 98 fok van, úgyhogy strandra megyek" (az idézőjeleket kivéve) hossza például 42 karakter – 31 betű, 2 szám, 8 szóköz, vessző és 2 aposztróf.

A függvény alkalmazáshoz írja be az =HOSSZ(cella) képletet a szerkesztőlécre, majd nyomja le az Enter billentyűt.

Több cella: Ha ugyanazt a képletet több cellára is alkalmaznia kell, írja be a képletet az első cellába, majd húzza a kitöltőpontot lefelé (vagy a cellatartományon keresztül).

Több HOSSZ függvény beírása egy munkalapba

Több cella összes karakterének teljes számát úgy számíthatja ki, hogy a SZUM függvényeket használja a HOSSZ függvényekkel együtt. Ebben a példában a HOSSZ függvény megszámolja az egyes cellákban lévő karaktereket, a SZUM függvény pedig összeadja az értékeket:

=SZUM((HOSSZ( cella1 );HOSSZ( 2. cella );(HOSSZ( cella3 )) )).

Tegyen egy próbát!

Íme néhány példa, amely bemutatja a HOSSZ függvény használatát.

Másolja az alábbi táblázatot a vágólapra, és illessze be egy Excel A1 cellájába. Húzza a képletet a B2-ről a B4 cellára, hogy lássa a szöveg hosszát az A oszlop összes celláiban.

Szöveges karakterláncok

Képletek

A gyors barna róka.

=HOSSZ(A2)

A gyors barna róka ugrott be.

Árvíztűrő tükörfúrógép ÁRVÍZTŰRŐ TÜKÖRFÚRÓGÉP

Egy cella karaktereinek megszámolása

  1. Kattintson a B2 cellára.

  2. Írja be az =HOSSZ(A2) függvényt.

A képlet megszámolja az A2 cellában lévő karaktereket, összesen 27-et, amely tartalmazza az összes szóközt és a mondat végén lévő 0-t.

MEGJEGYZÉS: A HOSSZ függvény az utolsó karakter után minden szóközt megszámol.
 

Több cella karaktereinek megszámolása

  1. Kattintson a B2 cellára.

  2. A Ctrl+C billentyűkombinációt lenyomva másolja a vágólapra a B2 cellát, jelölje ki a B3 és a B4 cellát, majd a Ctrl+V billentyűkombinációt lenyomva illessze be a képletet a B3:B4 cellákba.

Ezzel a képletet a B3 és a B4 cellába másolja, a függvény pedig megszámolja az egyes cellákban lévő karaktereket (20, 27 és 45).

A karakterszám összesítése

  1. Kattintson a minta munkafüzet B6 cellájára.

  2. Írja be a cellába az =SZUM(HOSSZ(A2);HOSSZ(A3);HOSSZ(A4)) képletet, és nyomja le az Enter billentyűt.

Ez megszámolja a három cella karaktereit és összegeit (92).

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×