A képlethibák feltárása

A képletek eredménye bizonyos esetekben valamilyen hiba vagy nem várt érték. Az alábbiakban néhány olyan eszközről olvashat, amellyel megkeresheti és feltárhatja az ilyen hibák okait, és megoldást találhat rájuk.

Megjegyzés: Ez a témakör olyan technikákat tartalmaz, amelyek segíthetnek a képlethibák kijavításában. A teljes lista nem tartalmazza az összes lehetséges képlethiba kijavítása módszereit. Adott hibákkal kapcsolatban az Excel közösségi fórumán kereshet az Önéhez hasonló kérdéseket, illetve ugyanott felteheti saját kérdését is.

Egyszerű képletek beírása

A képletek olyan egyenletek, amelyek a munkalapon számításokat hajtanak végre értékekkel. A képletet egyenlőségjellel (=) kell kezdeni. A következő képlet például a háromhoz egyet ad hozzá.

=3+1

A képlet a következők bármelyikét tartalmazhatja: függvények, hivatkozások, operátorok és állandók.

Parts of a formula

A képlet részei

  1. Függvények: az Excel részét képező függvények létrehozott képletek, amelyek adott számításokat végeznek el. A PI() függvény például a pi értékét (3,142...) adja vissza.

  2. Hivatkozások: egyedi cellákra vagy cellatartományokra utal. Az A2 az A2 cellában lévő értéket adja vissza.

  3. Állandók: a képletbe közvetlenül beírt számok vagy karakterláncok, például a 2.

  4. Operátorok: a ^ (kalap) a hatványozás, a * (csillag) pedig a szorzás jele. A + és a - jellel hozzáadhat és kivonhat értékeket, a / jellel pedig osztást végezhet.

    Megjegyzés: Egyes függvények argumentumként is használhatók. Az argumentumok azok az értékek, amelyek bizonyos függvényekkel számításokat hajtnak végre. Szükség esetén az argumentumok a függvény zárójelei () közé kerülnek. A PI függvényhez nem szükséges argumentum, ezért üres. Egyes függvények egy vagy több argumentumot igényelnek, és hagyjon helyet a további argumentumok számára. Az argumentumokat pontosvesszővel vagy pontosvesszővel (pontosvesszővel) ;) gombra a tartózkodási hely beállításaitól függően.

A SZUM függvényhez például csak egy argumentum szükséges, de összesen 255 argumentumot is használhat.

SZUM függvény

=SZUM(A1:A10) – ez egyetlen argumentumra példa

=SZUM(A1:A10; C1:C10) – ez több argumentumra példa

Az alábbi táblázat összefoglalja a képletek beírásakor leggyakrabban elkövetett hibákat és kijavításuk módját:

Ellenőrizendő szempont

További információ

Az egyenlőségjel (=) használata a függvények elején

Ha kihagyja az egyenlőségjelet, előfordulhat, hogy a beírt szöveg szövegként vagy dátumként jelenik meg. Ha például a SZUM(A1:A10)képletet írja be, a Excel a SZUM(A1:A10) karakterláncot jeleníti meg, és nem végzi el a számítást. Ha a 11/2dátumot írja be, Excel a 2. nov. dátumot jeleníti meg (feltéve, hogy a cellaformátum általános),és nem 11-et oszt el 2-vel.

A nyitó és záró zárójelek párosítása

Győződjön meg arról, hogy minden zárójelnek megvan a (nyitó, illetve záró) párja. Ha a képletben függvényt használ, a megfelelő működéséhez fontos, hogy minden zárójel a megfelelő helyen legyen. Például a =HA(B5<0);"Nem érvényes";B5*1,05) képlet nem fog működni, mert két záró és csak egy nyitó zárójelet tartalmaz (csak egynek kellene lennie mindkettőből). A képletnek a következőnek kell lennie: =HA(B5<0;"Nem érvényes";B5*1,05).

A tartomány jelölése kettősponttal

Amikor cellatartományra hivatkozik, akkor a tartomány első és utolsó cellájára való hivatkozás között használjon kettőspontot (:). Például: =SZUM(A1:A5), és nem =SZUM(A1 A5), amely #NULLA! hibát ad eredményül.

Az összes szükséges argumentum megadása

Egyes függvények kötelező argumentumokkal rendelkeznek. Ügyeljen arra, hogy túl sok argumentumot se írjon be.

A megfelelő típusú argumentumok megadása

Egyes függvények, például a SZUM, numerikus argumentumokat vesznek fel. Más függvények, például a CSERE esetén az argumentumok legalább egyikéhez szöveges értéket kell megadni. Ha nem megfelelő típusú adatot használ argumentumként, előfordulhat, hogy az Excel nem a várt eredményt adja vissza, illetve hibaüzenetet jelenít meg.

A függvények egymásba ágyazásának legfeljebb 64 szintje

Egy függvényen belül nem lehet 64-nél több szinten megadni, illetve egymásba ágyazni a függvényeket.

Más lapnevek aposztrófok közé foglalása

Ha a képlet más munkalapon vagy munkafüzetben lévő cellákra vagy értékekre hivatkozik, és a másik munkafüzet vagy munkalap neve szóközt vagy más, nem betű jellegű karaktert tartalmaz, a nevet aposztrófok ( ' ) közé kell foglalni, például: ='Negyedéves adatok'!D3 vagy =‘123’!A1.

Felkiáltójel (!) elhelyezése a képletekben a hivatkozott munkalapok neve után

Ha például a D3 cella értékét szeretné visszaadni az ugyanabban a munkafüzetben található Negyedéves adatok munkalapról, használja a következő képletet: ='Negyedéves adatok'!D3.

A külső munkafüzetek elérési útjának feltüntetése

Győződjön meg arról, hogy minden külső hivatkozás tartalmazza a munkafüzet nevét és elérési útját.

A munkafüzetre való hivatkozásban szerepelnie kell a munkafüzet nevének, amelynek szögletes zárójelben ([Munkafüzetneve.xlsx]) kell lennie. A hivatkozásnak a munkafüzet megfelelő munkalapjának nevét is tartalmaznia kell.

Ha a hivatkozni kívánt munkafüzet nincs megnyitva a Excel, akkor is hivatkozhat rá egy képletben. Adja meg a fájl teljes elérési útját, például a következő példában: =SOROK('C:\Dokumentumok\[2. negyedév Operations.xlsx]Értékesítés'! A1:A8). Ez a képlet a tartomány azon sorait adja eredményül, amelyek a másik munkafüzet A1-től A8-ig celláiba esnek (8).

Megjegyzés: Ha a teljes elérési út szóközöket tartalmaz, ahogyan az iménti példában is, akkor az elérési utat aposztrófok között kell megadni (az aposztrófokat az elérési út előtt, illetve a munkalap neve és a felkiáltójel között kell elhelyezni).

A számok formázás nélküli beírása a képletbe

Ne formázza a számokat, amikor beírja őket a képletekbe. Ha például a beírni kívánt érték 100 000 Ft, írja be az 1000 értéket a képletbe. Ha egy szám részeként vesszőt ad meg, a Excel elválasztó karakterként kezeli. Ha azt szeretné, hogy a számok több ezer vagy millió elválasztójelet vagy pénznemszimbólumokat jelenítsen meg, a számok beírása után formázza a cellákat.

Ha például ilyen beállítások mellett 3100-at szeretne hozzáadni az A3 cellában lévő értékhez, és az =SZUM(3,100,A3) képletet adja meg, az Excel összeadja a 3 és a 100 értéket, majd ezt az összeget adja hozzá az A3 cella értékéhez ahelyett, hogy 3100-at adna hozzá, ami =SZUM(3100;A3) lenne. Vagy ha az =ABS(-2,134) képletet adja meg, az Excel hibát jelenít meg, mert az =ABS(-2134) függvény csak egy argumentumot fogad el.

A képletek ellenőrzéséhez lehetőség van bizonyos szabályok bevezetésére. Ezek a szabályok nem garantálják, hogy a munkalap hibátlan legyen, de segítségükkel sok gyakori hiba felderíthető. A szabályok egyenként be- vagy kikapcsolhatók.

A hibákat kétféle módon lehet megjelölni és javítani: egyesével, mint például a helyesírás-ellenőrzők esetében, vagy előfordulásukkor azonnal, a munkalapon történő adatbevitellel egyidejűleg.

A hibák kijavíthatók az Excel által megjelenített lehetőségek valamelyikével, illetve figyelmen kívül hagyhatók a Hiba mellőzése gombra kattintva. Ha egy adott cellában észlelt hibát figyelmen kívül hagy, az a későbbi hibaellenőrzések alkalmával nem jelenik meg. Mindazonáltal a korábban figyelmen kívül hagyott hibák észlelése alaphelyzetbe állítható, így a hibák újra megjeleníthetők.

  1. Windows Excel esetén kattintson a Fájl > beállítások >,vagy a
    Mac Excel esetén kattintson az Excel menüre > Beállítások > Hibaellenőrzés parancsra. 

    Az Excel 2007-ben kattintson a Microsoft Office gombra Office gomb képe > Az Excel beállításai > Képletek elemre.

  2. A Hibaellenőrzés csoportban törölje az Automatikus hibaellenőrzés a háttérben jelölőnégyzet jelölését. A talált hibákat egy háromszög jelöli a cella bal felső sarkában.

    Képlethibát tartalmazó cella
  3. Ha meg szeretné változtatni a hibák előfordulását jelző háromszög színét, válasszon a Hibák jelzése ezzel a színnel listában lévő lehetőségek közül.

  4. Hibaellenőrzési szabályok területen a következő szabályok jelölőnégyzeteit jelölheti be, illetve törölheti:

    • Hibát eredményezőképleteket tartalmazó cellák: A képletek nem a várt szintaxist, argumentumokat vagy adattípusokat használják. A hibaértékek közé tartoznak a következők: #DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!, #VALUE!. E hibaértékek mindegyikének különböző okai vannak, és különböző módokon oldható meg.

      Megjegyzés: Ha közvetlenül egy cellába ír be hibás értéket, a program azt hibaértékként tárolja, ugyanakkor nem jelöli meg hibaként. Ha azonban egy másik cellában található képlet erre a cellára hivatkozik, akkor a képlet visszaadja az adott cellából a hibaértéket.

    • Táblázatok számított oszlopánakkövetkezetlen képlete: A számított oszlopok tartalmazhatnak olyan egyéni képleteket, amelyek eltérnek a főoszlop képlettől, ami kivételt hoz létre. A számított oszlopnál akkor jön létre kivétel, ha a következő műveletek valamelyikét hajtja végre:

      • Számított oszlop cellájába képlettől eltérő adatot ír be.

      • Írjon be egy képletet egy számított oszlop cellájába, majd használja a Ctrl+Z billentyűkombinációt, vagy kattintson a Gyorselérési Visszavonás gomb Visszavonás gombjára.

      • Új képletet ír be egy olyan számított oszlopba, amely már tartalmaz egy vagy több kivételt.

      • Olyan adatokat másol be a számított oszlopba, amelyek nem felelnek meg a számított oszlop képletének. Ha a másolt adat képletet tartalmaz, a képlet felülírja a számított oszlopban szereplő adatokat.

      • A munkalap olyan területének celláját helyezi át vagy törli, amelyre a számított oszlop egyik sora hivatkozik.

    • Két számjeggyelábrázolt évszámokat tartalmazó cellák: A cella szöveges dátumot tartalmaz, amely képletekben való használata során tévesen a megfelelő századként használható. Az =ÉV("2031.01.01.") képletben például a dátum 1931 vagy 2031 lehet. Ezzel a s szabály használatával ellenőrizheti, hogy nem tartalmaz-e kétértelmű dátumokat a szövegben.

    • Szövegként formázottvagy aposztróf előz meg számokat: A cella szövegként tárolt számokat tartalmaz. Ez általában külső forrásból történő importáláskor fordul elő. A szövegként tárolt számok rendezés esetén nem várt eredményt hozhatnak, ezért legjobb, ha mindig számokká alakítja őket. A '=SZUM(A1:A10) szövegként látható.

    • A régiómás képleteivel nem következetes képletek: A képlet nem felel meg a közeli többi képlet mintája. Számos esetben az egymással szomszédos képletek csak a hivatkozásokban térnek el. Az alábbi négy szomszédos képletet tartalmazó példában az Excel hibát jelenít meg a D4 cellában az =SZUM(A10:C10) képlet mellett, mivel a szomszédos képletek egy sorral, eggyel 8 sorral nőnek – az Excel az =SZUM(A4:C4) képletet várja.

      Az Excel hibát jelenít meg, ha egy képlet nem egyezik a szomszédos képletek mintájával

      Ha egy képletben a hivatkozások nem követik a szomszédos képletek hivatkozásait, az Excel hibát jelez.

    • Egy régiócelláit kihagyó képletek: Előfordulhat, hogy egy képlet nem hivatkozik automatikusan az eredeti adattartomány és a képletet tartalmazó cella közé beszúrt adatokra. Ez a szabály összehasonlítja a képletben található hivatkozást a képletet tartalmazó cellával szomszédos tartománnyal. Ha a szomszédos cellák további értékeket tartalmaznak (nem üresek), az Excel hibát jelez a képlet mellett.

      Az Excel hibát jelez például az =SZUM(D2:D4) képlet mellett, amikor ezt a szabályt alkalmazza, ugyanis a D5, a D6 és a D7 cella szomszédos a képletben hivatkozott és a képletet tartalmazó (D8) cellával is, valamint ezek a cellák adatokat tartalmaznak, amelyekre a képletnek hivatkoznia kellett volna.

      Az Excel hibát jelenít meg, ha egy képlet kihagy cellákat egy tartományban
    • Képleteket tartalmazónem zárolt cellák: A képlet nincs zárolva a védelem érdekében. Alapértelmezés szerint a munkalap minden cellát zárol, így azok nem módosíthatók, ha a munkalap védett. Ezzel elkerülheti a véletlen hibákat, például a képletek véletlen törlését vagy megváltoztatását. Ez a hiba azt jelzi, hogy a cella zárolásának feloldása be van állítva, de a lap nincs védelem alatt. Ellenőrizze, hogy nem szeretné-e zárolni a cellát.

    • Üres cellákra hivatkozóképletek: A képlet üres cellára hivatkozik. Ez nem kívánt eredményhez vezethet, amint az a következő példában is látható.

      Tegyük fel, hogy az alábbi oszlopban található számok átlagát szeretné kiszámolni. Ha a harmadik cella üres, akkor nem szerepel a számolásban, és az eredmény 22,75. Ha ebben cellában 0 van, az eredmény 18,2.

      Az Excel hibát jelenít meg, ha egy képlet üres cellákra hivatkozik
    • A táblázatba beírt adatok érvénytelenek:Érvényesítési hiba van a táblában. Ellenőrizze a cella érvényesítési beállítását az Adateszközök csoport Adatok lapján > adatok érvényesítése > gombra.

  1. Jelölje ki az ellenőrizni kívánt munkalapot.

  2. Ha a munkalapon nincs beállítva az automatikus újraszámolás, akkor nyomja le az F9 billentyűt.

    Ha a Hibaellenőrzés nem látható, kattintson a Képletek lap > Képletvizsgálat > Hibaellenőrzés gombra.

  3. Ha a korábban figyelmen kívül hagyott hibákat ismét ellenőrizni szeretné, kattintson a Fájl > Beállítások > Képletek kategóriára. Mac Excel esetén kattintson az Excel menüre > Beállítások > hibaellenőrzéshez.

    A Hibaellenőrzés csoportban kattintson a Mellőzött hibák újrafigyelése > OK gombra.

    Hibaellenőrzés

    Megjegyzés: A mellőzött hibák visszaállításával az összes hibát visszaállítja az aktív munkafüzet minden lapján.

    Tipp: Segíthet, ha a Hibaellenőrzés párbeszédpanelt közvetlenül a képletsáv alá helyezi.

    A Hibaellenőrzés panel áthelyezése a szerkesztőléc alá
  4. Kattintson a párbeszédpanel jobb oldalán található műveletgombok valamelyikére. Az elérhető műveletek különböző típusú hibák esetén eltérnek.

  5. Kattintson a Tovább gombra.

Megjegyzés: Ha a Hiba mellőzése parancsot választja, azzal megjelöli a problémát úgy, hogy az alkalmazás minden ezt követő ellenőrzés során mellőzni fogja.

  1. Kattintson a cella mellett megjelenő Hibaellenőrzés gombra Hibaellenőrzés ikon , majd válasszon az ott látható lehetőségek közül. Az elérhető parancsok a hibatípusoktól és a hibát leíró első bejegyzéstől függően eltérők lehetnek.

    Ha a Hiba mellőzése parancsot választja, azzal megjelöli a problémát úgy, hogy az alkalmazás minden ezt követő ellenőrzés során mellőzni fogja.

    A Hibaellenőrzés panel áthelyezése a szerkesztőléc alá

Ha egy képlet nem tudja helyesen kiértékelni az eredményt, az Excel hibaértéket jelenít meg, például ####, #DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!, és #VALUE!. Minden hibatípusnak különböző okai és különböző megoldásai vannak.

Az alábbi táblázat hivatkozásokat tartalmaz az e hibákkal részletesen foglalkozó cikkekre, és rövid leírással segíti az első lépéseket.

Témakör

Leírás

A #### hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha az adott oszlop nem elég széles a benne lévő összes karakter megjelenítéséhez, illetve negatív dátum vagy időérték van valamelyik cellában.

Ez történik, ha egy képlet jövőbeli dátumból múltbéli dátumot von ki (pl. =2008.06.15.-2008.07.21.), mert az eredmény negatív dátumérték lesz.

Tipp: Az oszlopfejlécek közé duplán kattintva próbálja meg automatikusan igazítani a cellát. Ha a ### azért jelenik meg, mert az Excel nem tudja az összes karaktert megjeleníteni, ezzel a művelettel kijavíthatja a hibát.

# hiba

A #ZÉRÓOSZTÓ! hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha egy számot nullával (0) vagy értéket nem tartalmazó cellával próbál osztani.

Tipp: Vegyen fel egy hibakezelőt, mint például a következő példában: =HA(C2;B2/C2;0)

A hibakezelő függvényekkel (például a HA függvénnyel) elfedhetők a hibák

A #HIÁNYZIK hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha egy érték nem áll rendelkezésre egy függvényhez vagy képlethez.

Egy függvény, például az FKERES használata esetén van a keresésének megfelelő elem a keresési tartományban? Többnyire nincs.

A #HIÁNYZIK hiba elkerüléséhez használja a HAHIBA függvényt. Ebben az esetben használhatja a következőt:

=HAHIBA(FKERES(D2;$D$6:$E$8;2;IGAZ);0)

#HIÁNYZIK hiba

A #NÉV? hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha nem ismeri fel a képletben lévő szöveget. Előfordulhat, például, hogy egy tartomány vagy egy függvény neve helyesírási hibát tartalmaz.

Megjegyzés: Ha függvényt használ, ellenőrizze, hogy helyesen írta-e a nevét. Ebben az esetben a SZUM helyesírási hibát tartalmaz. Távolítsa el az „e” betűt, és az Excel ki fogja javítani.

Az Excel #NÉV? hibát jelenít meg, ha egy képletnévben elírás van

A #NULLA! hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha két olyan tartomány metszetét adta meg, amelyek nem metszik egymást. A metszetoperátor egy szóközkarakter, amely elválasztja a képletbe írt hivatkozásokat.

Megjegyzés: Ellenőrizze, hogy a tartományok helyesen vannak-e elválasztva – a C2:C3 és az E4:E6 nem metszik egymást, így az =SZUM(C2:C3 E4:E6) a #NULLA! hibát adja vissza. Ha pontosvesszőt tesz a C és az E tartomány közé, kijavítja az =SZUM(C2:C3;E4:E6) képletet.

#NULLA! hiba

A #SZÁM! hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha egy képlet vagy függvény érvénytelen számértékeket tartalmaz.

Iteráló függvényt (például BMR vagy RÁTA) használ? Ha igen, a #SZÁM! hibát valószínűleg az okozza, hogy a függvény nem talál eredményt. A megoldáshoz szükséges lépéseket a súgótémakörben találja.

A #HIV! hiba javítása

Az Excel akkor jeleníti meg ezt a hibát, ha érvénytelen egy cellahivatkozás. Lehet például, hogy olyan cellákat törölt, amelyekre más képletek hivatkoznak, vagy más képletek által hivatkozott cellákra helyezett át cellákat.

Véletlenül törölt egy sort vagy oszlopot? A =SZUM(A2;B2;C2) képletben töröltük a B oszlopot, és lássuk, hogy mi történik.

Használja a Visszavonás (Ctrl+Z) parancsot a törlés visszavonásához, készítse el újra a képletet, vagy használjon egy folyamatos hivatkozástartományt, például a következőt: =SZUM(A2:C2), amely automatikusan frissült a B oszlop törlésekor.

Az Excel #HIV! hibát jelenít meg, ha érvénytelen egy cellahivatkozás

Az #ÉRTÉK! hiba javítása

Az Excel akkor jelenítheti meg ezt a hibát, ha a képlet különböző adattípusú cellákat tartalmaz.

Matematikai operátorokat (+, -, *, /, ^) használ különböző adattípusokkal? Ha igen, próbáljon meg inkább egy függvényt használni. Ebben az esetben a =SZUM(F2:F5) megoldja a problémát.

#ÉRTÉK! hiba

Ha egyes cellák nem láthatók a munkalapon, a Figyelőablak eszköztáron figyelheti őket és a bennük lévő képletet. A Figyelőablak segítségével a nagy méretű munkalapokon kényelmesen figyelheti, vizsgálhatja vagy megerősítheti egyes képletek számításait és eredményeit. A Figyelőablak használatakor nem kell újra és újra a munkalap különböző részeire görgetnie vagy ugrania.

A Figyelőablak segítségével egyszerűen figyelhetők a munkalapokon használt képletek

Ezt az eszköztárat a többi eszköztárhoz hasonló módon áthelyezheti vagy dokkolhatja. Például az ablak alján dokkolhatja. Az eszköztár a következő cellatulajdonságokat követi nyomon: 1) Munkafüzet, 2) Munkalap, 3) Név (ha a cellának van megfelelő elnevezett tartománya), 4) Cellacím, 5) Érték és 6) Képlet.

Megjegyzés: Cellánként csak egy figyelőpont adható meg.

Cellák hozzáadása a Figyelőablakhoz

  1. Jelölje ki a figyelni kívánt cellákat.

    Ha az összes cellát ki szeretné jelölni egy munkalapon, amely képletet tartalmaz, a Kezdőlap lap Szerkesztés csoportjában kattintson a Keresés és kijelölés gombra (vagy használhatja a Ctrl+G, illetve Macen a Control+G billentyűkombinációval elérhető) > Irányított kijelölés > Képletek választógombot.

    Irányított kijelölés párbeszédpanel
  2. Képletek lap Képletvizsgálat csoportjában kattintson a Figyelőablak gombra.

  3. Kattintson a Figyelőpont elhelyezése gombra.

    Figyelőpont hozzáadása a táblázatban a Figyelőpont elhelyezése elemre kattintva
  4. Győződjön meg arról, hogy a figyelni kívánt összes cellát kijelölte, és kattintson a Hozzáadás gombra.

    A figyelni kívánt cellatartomány megadása a Figyelőpont elhelyezése párbeszédpanelen
  5. A Figyelőablak oszlopszélességének módosításához húzza az oszlopfejléc jobb oldalán lévő szegélyt.

  6. A Figyelőablak eszköztáron lévő bejegyzéshez tartozó cella megjelenítéséhez kattintson duplán a bejegyzésre.

    Megjegyzés: A másik munkafüzetre mutató külső hivatkozásokat tartalmazó cellák csak akkor jelennek meg a Figyelőablak eszköztáron, ha a másik munkafüzet is meg van nyitva.

Cellák eltávolítása a Figyelőablakból

  1. Ha nem látható a Figyelőablak eszköztár, kattintson a Képletek lap Képletvizsgálat csoportjában a Figyelőablak gombra.

  2. Jelölje ki az eltávolítani kívánt cellákat.

    Több cella kijelöléséhez a CTRL billentyűt lenyomva tartva kattintson sorban a cellákra.

  3. Kattintson a Figyelőpont törlése gombra.

    Figyelőpont törlése

Sokszor nehéz átlátni, hogy egy beágyazott képlet hogyan számítja ki a végeredményt, hiszen az alkalmazás számos közbenső számítást és logikai tesztet végez e folyamat során. A Képletkiértékelő párbeszédpanel segítségével azonban megtekintheti a beágyazott képlet különböző részeit a számítások sorrendje szerint kiértékelve. Például a =HA(ÁTLAG(D2:D5)>50;SZUM(E2:E5);0) képletet egyszerűbb megérteni, ha láthatja az alábbi közbenső eredményeket:

A Képletkiértékelő segítségével megtekintheti, hogy hogyan történik a beágyazott képletek különböző részeinek értékelése

A Képletkiértékelő párbeszédpanelen

Leírás

=HA(ÁTLAG(D2:D5)>50;SZUM(E2:E5);0)

Kezdetben a beágyazott képlet látható. Az ÁTLAG és a SZUM függvény a HA függvénybe van ágyazva.

A D2:D5 cellatartomány az 55, a 35, a 45 és a 25 értéket tartalmazza, ezért az ÁTLAG(D2:D5) függvény eredménye 40 lesz.

=HA(40>50;SZUM(E2:E5);0)

A D2:D5 cellatartomány az 55, a 35, a 45 és a 25 értéket tartalmazza, ezért az ÁTLAG(D2:D5) függvény eredménye 40 lesz.

=HA(Hamis,SZUM(E2:E5);0)

A 40 nem nagyobb, mint 50, ezért a HA függvény első argumentumában (a logikai_vizsgálat argumentumban) található kifejezés hamis.

A HA függvény a harmadik (az érték_ha_hamis) argumentum értékét adja eredményül. A SZUM függvényt nem kell kiértékelni, mivel ez a HA függvény második (érték_ha_igaz) argumentuma, és ezt az alkalmazás csak akkor értékeli, ha a kifejezés igaz.

  1. Jelölje ki a kiértékelni kívánt cellát. Egyszerre csak egy cellát lehet kiértékelni.

  2. Válassza a Képletek lap > Képletvizsgálat > Képletkiértékelő lehetőséget.

  3. Kattintson a Kiértékelés gombra az aláhúzott hivatkozás megvizsgálásához. A kiértékelés eredménye dőlt formázással jelenik meg.

    Ha a képlet aláhúzott része egy másik képletre mutató hivatkozás, a Belelépés gombra kattintva jelenítse meg a másik képletet a Kiértékelés mezőben. A Visszaugrás gombra kattintva lépjen vissza az előző cellába és képletre.

    Belelépés gomb nem használható a képletben második alkalommal megjelenő hivatkozás esetében, illetve ha a képlet külön munkafüzetben lévő cellára hivatkozik.

  4. Addig kattintson a Kiértékelés gombra, amíg a képlet minden részét ki nem értékeli.

  5. A kiértékelés újbóli megjelenítéséhez kattintson az Újraindítás gombra.

  6. A kiértékelés befejezéséhez kattintson a Bezárás gombra.

Megjegyzések: 

  • HA vagy a VÁLASZT függvényt használó képletek egyes részeinek kiértékelése nem történik meg – ilyenkor a Kiértékelés mezőben a #HIÁNYZIK hibaérték jelenik meg.

  • Ha a hivatkozás üres, nulla érték (0) jelenik meg a Kiértékelés mezőben.

  • A munkalap módosításakor az alkalmazás a következő függvények értékét mindig újraszámolja, és emiatt a Képletkiértékelő más eredményt adhat, mint ami a cellában megjelenik: VÉL, TERÜLET, INDEX, ELTOLÁS, CELLA, INDIREKT, SOROK, OSZLOPOK, MOST, MA és VÉLETLEN.KÖZÖTT.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Képlet és cella kapcsolatának megjelenítése

Hibás képletek kiküszöbölése

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×