FKERES függvény

Tipp: Próbálja ki az új XKERES függvényt, az FKERES függvényt, amely bármilyen irányban működik, és alapértelmezés szerint pontos egyezéseket ad vissza, így egyszerűbben és kényelmesebben használható, mint a megelőzője.

Az FKERES használata akkor, ha egy táblázatban vagy tartományban sor alapján kell megtalálnia a dolgokat. Megkeresheti például egy alkatrész árát a alkatrészszám alapján, vagy megkeresheti az alkalmazott nevét az alkalmazott azonosítója alapján.

Tipp: Az FKERES alkalmazással kapcsolatos további segítségért tekintse meg a Microsoft Creators youTube-videóit!

Az FKERES függvény legegyszerűbben az alábbi módon értelmezhető:

=FKERES(Amit ki szeretne keresni, hol szeretné keresni, a visszakeresni kívánt értéket tartalmazó tartomány oszlopszáma, közelítő vagy pontos egyezés – 1/IGAZ vagy 0/HAMIS jelölésű értékkel).

Ez a böngésző nem támogatja a videók lejátszását.

Tipp: Az FKERES azt jelenti, hogy úgy rendezi az adatokat, hogy a kikeresett érték (gyümölcs) a megtalált eredményérték (Összeg) bal oldali értékeként 100 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 000 0000.000.0

Az FKERES függvénnyel kikeresheti egy táblázat egy értékét.

Szintaxis

Szintaxis: FKERES(keresési_érték; tábla; oszlop_szám; [tartományban_keres])

Például:

  • =FKERES(A2;A10:C20;2;IGAZ)

  • =FKERES("Lengyel";B2:E7;2;HAMIS)

  • =FKERES(A2;'Ügyféladatok'! A:F,3,HAMIS)

Argumentum neve

Leírás

keresési_érték    (kötelező)

A kikeresni kívánt érték. A keresni kívánt értéknek az argumentumban megadott cellatartomány első table_array kell lennie.

Ha például a tábla a B2:D7 cellatartományt is átfogja, akkor a lookup_value a B oszlopban kell lennie.

Lookup_value lehet érték vagy cellahivatkozás.

tábla    (kötelező)

Az a cellatartomány, amelyben az FKERES függvény a keresési_értéket és a visszaadott értéket keresi. Használhat elnevezett tartományt vagy táblázatot, és cellahivatkozások helyett neveket is használhat az argumentumban. 

A cellatartomány első oszlopának tartalmaznia kell a lookup_value. A cellatartománynak tartalmaznia kell a keresni kívánt visszatérési értéket is.

Tudnivalók a tartományok kijelöléséről munkalapon.

oszlop_szám    (kötelező)

A visszatérési értéket tartalmazó oszlop száma (a bal oldali oszlop bal table_array 1-től kezdve).

tartományban_keres    (nem kötelező)

Logikai érték, amellyel az FKERES függvényhez közelítő vagy pontos keresést írhat elő:

  • Közelítő egyezés – Az 1/IGAZ azt feltételezi, hogy a táblázat első oszlopa számsorrendben vagy betűrendben van rendezve, majd rákeres a legközelebbi értékre. Ez az alapértelmezett keresési mód, ha nincs semmi megadva. Például: =FKERES(90;A1:B100;2;IGAZ).

  • Pontos egyezés – 0/HAMIS keresés az első oszlop pontos értékére. Például: =FKERES("Kovács",A1:B100;2;HAMIS).

Első lépések

Az FKERES függvény szintaktikailag helyes használatához az alábbi négy adatot kell megadnia:

  1. A keresendő érték, melyet keresési értéknek is nevezünk.

  2. A tartomány, amelyben a keresési érték megtalálható. Ne feledje, hogy a keresési értéknek mindig a tartomány első oszlopának kell lennie ahhoz, hogy az FKERES függvény megfelelően működjön. Ha például a keresési érték a C2 cellában található, akkor a tartománynak a C oszloppal kell kezdődnie.

  3. A visszatérési érték oszlopszáma a tartományban. Ha például a B2:D11 tartományt adja meg, akkor a B az első oszlop, a C a második stb.

  4. Opcionálisan megadhatja az IGAZ értéket, ha a visszatérési érték kereséséhez közelítő egyezést szeretne előírni, vagy a HAMIS értéket, ha pontos egyezést. Ha nem ad meg semmit, az alapértelmezett érték az IGAZ, vagyis a közelítő egyezés.

A fentieket a következőképpen egyesítheti egy működő képletbe:

=FKERES(keresési érték; keresési értéket tartalmazó tartomány; a visszatérési értéket tartalmazó tartomány oszlopszáma, közelítő egyezés (IGAZ) vagy Pontos egyezés (HAMIS)).

Példák

Íme néhány példa az FKERES parancsra:

1. példa

FKERES – példa 1

2. példa

FKERES – példa 2

3. példa

FKERES – példa 3

4. példa

FKERES – példa 4

5. példa

FKERES – példa 5

Az FKERES segítségével több táblát egyesíthet egy táblában, ha az egyik táblában közös mezők vannak a többi táblában. Ez különösen hasznos lehet, ha olyanokkal kell megosztania egy munkafüzetet, akik az Excel régebbi verzióival nem támogatják az adatforrásként több táblázatot tartalmazó adatszolgáltatásokat – a források egyetlen táblázatba történő kombinálásával és az adatkapcsolat adatforrásának az új táblára való módosításával, az adat funkciót a régebbi Excel-verziókban is használhatja (feltéve, hogy magát az adatszolgáltatásokat a régebbi verzió támogatja).

Munkalap olyan oszlopokkal, amelyek az FKERES segítségével más táblázatokból származó adatokat tartalmaznak

Az A-F és a H oszlop itt olyan értékeket vagy képleteket tartalmaz, amelyek csak a munkalapon használják az értékeket, a többi oszlop pedig az FKERES és az A oszlop (ügyfélkód) és a B oszlop értékeit használja más táblákból való adatok bekereséséhez.

  1. Másolja a közös mezőket tartalmazó táblát egy új munkalapra, és adjon neki egy nevet.

  2. A Kapcsolatok > párbeszédpanel megnyitásához kattintson az Adateszközök >kapcsolatok gombra.

    A Kapcsolatok kezelése párbeszédpanel
  3. Minden felsorolt kapcsolathoz jegyezze fel az alábbiakat:

    • A táblákat összetartó mező (a párbeszédpanelen zárójelekkel jelennek meg). Ez az lookup_value az FKERES képlethez.

    • A kapcsolódó keresési tábla neve. Ez az table_array az FKERES képletben.

    • A Kapcsolódó keresési tábla mezője (oszlopa) az új oszlopban kívánt adatokat tartalmazza. Ezek az információk nem jelennek meg a Kapcsolatok kezelése párbeszédpanelen – a Kapcsolódó keresési táblában meg kell néznie, hogy melyik mezőt szeretné lekérni. Fel szeretné jegyezni az oszlop számát (A=1) – ez col_index_num képletben lévő szám.

  4. Ha új mezőt szeretne hozzáadni az új táblához, a 3. lépésben összegyűjtött információk alapján írja be az FKERES képletet az első üres oszlopba.

    Ebben a példában a G oszlop a Jobbik (a lookup_value)oszlop segítségével beszerzi a számladíj adatait a negyedik oszlopból(col_index_num = 4) az Iroda munkalap táblából ( tblAttorneys (a table_array), az =FKERES([@Attorney],tbl_Attorneys;4;HAMIS)képlettel.

    A képlet cellahivatkozást és tartományhivatkozást is használhat. Ebben a példában az =FKERES(A2;'Ügyészek'! A:D,4,HAMIS).

  5. Folytassa a mezők hozzáadását, amíg meg nem adja az összes szükséges mezőt. Ha olyan munkafüzetet próbál készíteni, amely több táblát tartalmazó adatszolgáltatásokat tartalmaz, módosítsa az adatkapcsolat-szolgáltatás adatforrását az új táblára.

Probléma

A probléma oka

Nem megfelelő visszaadott érték

Ha a tartományban_keres argumentum értéke IGAZ vagy nincs megadva, az első oszlopban lévő értékeknek betűrendben vagy számsorrendben kell elhelyezkedniük. Ha az első oszlop nem rendezett, előfordulhat, hogy nem a várt eredményt kapja vissza. Rendezze az első oszlopot, vagy adjon meg HAMIS értéket a pontos egyezés érdekében.

#HIÁNYZIK hiba egy cellában

  • Ha a tartományban_keres értéke IGAZ, akkor ha a keresési_érték kisebb a tábla első oszlopában lévő értéknél, a képlet #HIÁNYZIK hibaértéket ad vissza.

  • Ha a tartományban_keres értéke HAMIS, a #HIÁNYZIK érték azt jelzi, hogy a pontos szám nem található.

Az FKERES függvény használatakor fellépő #HIÁNYZIK hiba elhárításáról bővebben a #HIÁNYZIK! hiba kijavítása az FKERES függvényben című témakörben olvashat.

#HIV! hiba egy cellában

Ha az oszlop_szám nagyobb a tábla oszlopainak a számánál, a képlet #HIV! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #HIV! hiba elhárításáról bővebben A #HIV! hiba javítása.

#ÉRTÉK! hiba egy cellában

Ha a tábla értéke kisebb 1-nél, a képlet #ÉRTÉK! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #ÉRTÉK! hiba elhárításáról bővebben az #ÉRTÉK! hiba kijavítása az FKERES függvényben.

#NÉV? hiba egy cellában

A #NÉV? hibaérték általában azt jelenti, hogy a képletből idézőjelek hiányoznak. Ha egy személy nevére keres, ügyeljen arra, hogy a képletben foglalja idézőjelek közé a nevet. A nevet például a következőképpen írja be: "Lengyel" az =FKERES("Lengyel",B2:E7,2,HAMIS) képletben.

További információt A #NÉV? hiba javítása.

#KITÖLTÉS! hiba egy cellában

Ez a #SPILL! hiba általában azt jelenti, hogy a képlet implicit metszetre támaszkodik a keresési értékhez, és hivatkozásként egy teljes oszlopot használ. Például: =FKERES(A:A,A:C,2,HAMIS). A problémát úgy oldhatja meg, hogy a keresési hivatkozást az = FKERES( @A:A,A:C,2,HAMIS) operátorral együtt horgonyozhatja. Másik lehetőségként használhatja a hagyományos FKERES metódust, és egyetlen cellára hivatkozhat a teljes oszlop helyett: =FKERES( A2 ,A:C,2,HAMIS).

Művelet

Indoklás

Használjon abszolút cellahivatkozásokat a tartományban_keres értékeként

Az abszolút hivatkozásokkal automatikusan kitöltheti a cellákat a képlettel, biztosítva, hogy az mindig ugyanazt a keresési tartományt használja.

Tudnivalók az abszolút cellahivatkozások használatáról.

Ne tárolja a számokat és a dátumokat szövegként.

Szám vagy dátumértékek keresésekor ügyeljen arra, hogy a tábla első oszlopában az adatok ne szöveges értékként legyenek tárolva. Ebben az esetben az FKERES hibás vagy váratlan eredményt adhat.

Rendezze az első oszlopot

Rendezze a tábla első oszlopát az FKERES használata előtt, ha a tartományban_keres értéke IGAZ.

Helyettesítő karakterek használata

Ha range_lookup HAMIS, lookup_value a helyettesítő karaktereket – kérdőjelet (?) és csillagot (*) – is használhatja a lookup_value. A kérdőjel egyetlen tetszőleges karaktert helyettesít. A csillag tetszőleges karaktersorozatot helyettesít. Ha ténylegesen kérdőjelet vagy csillagot szeretne megtalálni, írjon be egy tilde karaktert (~) a karakter elé.

Az =FKERES("Betűtípus?",B2:E7,2,HAMIS) kifejezés például a Fontana összes előfordulására keres egy olyan utolsó betűt, amely változó lehet.

Győződjön meg arról, hogy az adatokban nincsenek elírások.

Ha szöveges értékekben keres az első oszlopban, ügyeljen arra, hogy az első oszlopban szereplő adatok ne tartalmazzanak szóközöket a karakterlánc elején vagy végén, ne szerepeljenek bennük nem egységes módon használt egyenes (' vagy "), illetve nyomdai (‘ vagy “) idézőjelek, továbbá nem nyomtatható karakterek. Ilyenkor az FKERES hibás vagy váratlan eredményt adhat.

A pontos eredmény érdekében szükséges lehet a táblázatadatok utáni szóközök eltávolítása a cellákból. Ehhez használhatja a TISZTÍT függvényt vagy a KIMETSZ függvényt.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Rövid összefoglalás: FKERES frissítő
Rövid összefoglalás: Hibaelhárítási tippek az FKERES használatához
YouTube: A Microsoft Creators FKERES-videói
A függvényhiba #VALUE az FKERES függvényben
Az FKERES #N/A hiba kijavítja
A képletek áttekintése az Excelben
Hibás képletek elkerülése
Képlethibák észlelése
Excel-függvények (betűrendes)
Excel-függvények (kategória szerint)
FKERES (ingyenes előzetes verzió)

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban