Tipp: Próbálja ki az új XLOOKUP függvényt, amely a VLOOKUP továbbfejlesztett verziója, amely bármilyen irányban működik, és alapértelmezett beállítás szerint pontos egyezéseket ad vissza, így könnyebben és kényelmesebben használható, mint az elődje.

Akkor használja az FKERES függvényt, ha egy táblázatban vagy tartományban soronként kell megkeresnie a dolgokat. Megkeresheti például egy autóalkatrész árát a cikkszám alapján, vagy megkeresheti az alkalmazott nevét az alkalmazott azonosítója alapján.

Az FKERES függvény legegyszerűbben az alábbi módon értelmezhető:

=FKERES(Amit ki szeretne keresni, ahol keresni szeretné, a visszaadandó értéket tartalmazó tartomány oszlopszáma, közelítő vagy pontos egyezést ad vissza – 1/IGAZ vagy 0/HAMIS értékként jelölve).

Ez a böngésző nem támogatja a videók lejátszását. Telepítse a Microsoft Silverlightot, az Adobe Flash Playert vagy az Internet Explorer 9-es verzióját.

Tipp: Az FKERES függvény titka, hogy úgy rendezi az adatokat, hogy a keresett érték (Gyümölcs) a keresett visszatérési értéktől (Összeg) balra legyen.

Az FKERES függvénnyel kikeresheti egy táblázat egy értékét.

Szintaxis 

Szintaxis: FKERES(keresési_érték; tábla; oszlop_szám; [tartományban_keres])

Például:

  • =FKERES(A2;A10:C20;2;IGAZ)

  • =FKERES("Lengyel";B2:E7;2;HAMIS)

  • =FKERES(A2;'Ügyfél részletei'! A:F,3,HAMIS)

Argumentum neve

Leírás

keresési_érték    (kötelező)

A kikeresni kívánt érték. A keresendő értéknek a table_array argumentumban megadott cellatartomány első oszlopában kell lennie.

Ha például a táblázattömb a B2:D7 cellákra terjed ki, akkor a lookup_value a B oszlopban kell lennie.

Lookup_value lehet érték vagy cellahivatkozás.

tábla    (kötelező)

Az a cellatartomány, amelyben az FKERES függvény a keresési_értéket és a visszaadott értéket keresi. Névvel ellátott tartományt vagy táblázatot is használhat, és cellahivatkozások helyett neveket is használhat az argumentumban. 

A cellatartomány első oszlopának tartalmaznia kell a lookup_value. A cellatartománynak tartalmaznia kell a keresett visszatérési értéket is.

Tudnivalók a tartományok kijelöléséről munkalapon.

oszlop_szám    (kötelező)

A visszatérési értéket tartalmazó oszlop száma (a table_array bal szélső oszlopában 1-től kezdve).

tartományban_keres    (nem kötelező)

Logikai érték, amellyel az FKERES függvényhez közelítő vagy pontos keresést írhat elő:

  • Közelítő egyezés – az 1/IGAZ azt feltételezi, hogy a táblázat első oszlopa numerikus vagy betűrendben van rendezve, majd a legközelebbi értéket keresi. Ez az alapértelmezett keresési mód, ha nincs semmi megadva. Például: =FKERES(90;A1:B100;2;IGAZ).

  • Pontos egyezés – 0/HAMIS az első oszlopban szereplő pontos érték keresése. Például: =FKERES("Kovács";A1:B100;2;HAMIS).

Első lépések

Az FKERES függvény szintaktikailag helyes használatához az alábbi négy adatot kell megadnia:

  1. A keresendő érték, melyet keresési értéknek is nevezünk.

  2. A tartomány, amelyben a keresési érték megtalálható. Ne feledje, hogy a keresési értéknek mindig a tartomány első oszlopának kell lennie ahhoz, hogy az FKERES függvény megfelelően működjön. Ha például a keresési érték a C2 cellában található, akkor a tartománynak a C oszloppal kell kezdődnie.

  3. A visszatérési érték oszlopszáma a tartományban. Ha például a B2:D11 tartományt adja meg, akkor a B oszlopot kell első oszlopnak, a C-t a másodiknak és így tovább.

  4. Opcionálisan megadhatja az IGAZ értéket, ha a visszatérési érték kereséséhez közelítő egyezést szeretne előírni, vagy a HAMIS értéket, ha pontos egyezést. Ha nem ad meg semmit, az alapértelmezett érték az IGAZ, vagyis a közelítő egyezés.

A fentieket a következőképpen egyesítheti egy működő képletbe:

=FKERES(keresési érték; a keresési értéket tartalmazó tartomány, a visszatérési értéket tartalmazó tartomány oszlopszáma, közelítő egyezés (IGAZ) vagy Pontos egyezés (HAMIS)).

Példák

Íme néhány példa az FKERES függvényre:

1. példa

=FKERES (B3;B2:E7;2;HAMIS)

Az FKERES függvény a B2:E7 table_array első oszlopában (B oszlopában) keresi a Fontana elemet, és a table_array második oszlopában (C oszlopában) szereplő Olivier értéket adja vissza.  A False pontos egyezést ad vissza.

2. példa

=FKERES (102;A2:C7;2;HAMIS)

Az FKERES függvény az A2:C7 tartomány második oszlopában (B oszlopban) keresi a 102 (lookup_value) vezetéknév pontos egyezését (HAMIS), és fontana értéket ad vissza.

3. példa

=HA(FKERES(103;A1:E7;2;HAMIS)="Souse";"Található";"Nem található")

HA ellenőrzi, hogy az FKERES függvény a Sousát adja-e vissza az A1:E7 (table_array) 103-as (lookup_value) értéket visszaadó alkalmazott vezetékneveként. Mivel a 103-nak megfelelő vezetéknév Leal, a HA feltétel hamis, és a Not Found (Nem található) érték jelenik meg.

4. példa

=INT(YEARFRAC(DATE(2014;6;30);FKERES(105;A2:E7;5;FLASE);1))

Az FKERES az A2:E7 tartományban (table_array) a 109 (lookup_value) értéknek megfelelő alkalmazott születési dátumát keresi, és 1955. 03. 04. dátumot adja vissza. Ezután a YEARFRAC kivonja ezt a születési dátumot a 2014/6/30 dátumból, és visszaad egy értéket, amelyet az INY átalakít az 59-es egész számra.

5. példa

HA(ISNA(FKERES(105;A2:E7;2;FLASE))=IGAZ;"Alkalmazott nem található";FKERES(105;A2:E7;2;HAMIS))

A HA ellenőrzi, hogy az FKERES függvény visszaadja-e a vezetéknév értékét a B oszlopból a 105-höz (lookup_value). Ha az FKERES függvény utónevet talál, akkor a HA függvény a vezetéknevet jeleníti meg, ellenkező esetben a HA függvény az Alkalmazott nem található értéket adja vissza. Az ISNA gondoskodik arról, hogy ha az FKERES függvény #N/A értéket ad vissza, akkor a hibát a nem található alkalmazott váltja fel #N/A helyett.



Ebben a példában a visszatérési érték Burke, amely a 105-nek megfelelő vezetéknév.

Az FKERES függvény használatával több táblát egyesíthet egy táblában, ha az egyik táblában az összes többi tábla közös mezőket tartalmaz. Ez különösen akkor lehet hasznos, ha olyan felhasználókkal kell megosztania egy munkafüzetet, akik a Excel olyan régebbi verzióival rendelkeznek, amelyek nem támogatják az adatforrásként több táblázattal rendelkező adatszolgáltatásokat – ha a forrásokat egyetlen táblában egyesíti, és az adatfunkció adatforrását az új táblára módosítja, az adatfunkció a régebbi Excel verziókban is használható (feltéve, hogy magát az adatfunkciót a régebbi verzió támogatja).

Munkalap olyan oszlopokkal, amelyek az FKERES függvényt használják más táblák adatainak lekéréséhez

Itt az A-F és a H oszlop olyan értékekkel vagy képletekkel rendelkezik, amelyek csak a munkalapon használnak értékeket, a többi oszlop pedig az FKERES függvényt, az A oszlop (Ügyfélkód) és a B oszlop (Attorney) értékeit pedig más táblák adatainak lekéréséhez.

  1. Másolja a közös mezőket tartalmazó táblát egy új munkalapra, és nevezze el.

  2. Kattintson az Adateszközök> >Kapcsolatok elemre a Kapcsolatok kezelése párbeszédpanel megnyitásához.

    A Kapcsolatok kezelése párbeszédpanel
  3. Minden felsorolt kapcsolathoz vegye figyelembe a következőket:

    • A táblákat összekapcsoló mező (zárójelben a párbeszédpanelen). Ez az FKERES képlet lookup_value .

    • A kapcsolódó keresési tábla neve. Ez az FKERES képlet table_array .

    • A Kapcsolódó keresési tábla azon mezője (oszlopa), amely az új oszlopban a kívánt adatokat tartalmazza. Ez az információ nem jelenik meg a Kapcsolatok kezelése párbeszédpanelen – a kapcsolódó keresési táblában kell megtekintenie, hogy melyik mezőt szeretné lekérni. Fel szeretné jegyezni az oszlopszámot (A=1) – ez a képlet col_index_num .

  4. Ha mezőt szeretne hozzáadni az új táblához, írja be az FKERES képletet az első üres oszlopba a 3. lépésben összegyűjtött információk alapján.

    A példánkban a G oszlop az Ügyvédi (lookup_value) oszlopot használja a tblAttorneys (a table_array) oszlop negyedik oszlopának (col_index_num = 4) számlázási díjadatainak lekéréséhez az =FKERES([@Attorney],tbl_Attorneys,4,HAMIS) képlettel.

    A képlet cellahivatkozást és tartományhivatkozást is használhat. A példánkban az =FKERES(A2;'Ügyvédek'! A:D,4,HAMIS).

  5. Folytassa a mezők hozzáadását, amíg meg nem adja az összes szükséges mezőt. Ha több táblát használó adatszolgáltatásokat tartalmazó munkafüzetet próbál előkészíteni, módosítsa az adatforrást az új táblára.

Probléma

A probléma oka

Nem megfelelő visszaadott érték

Ha a tartományban_keres argumentum értéke IGAZ vagy nincs megadva, az első oszlopban lévő értékeknek betűrendben vagy számsorrendben kell elhelyezkedniük. Ha az első oszlop nem rendezett, előfordulhat, hogy nem a várt eredményt kapja vissza. Rendezze az első oszlopot, vagy adjon meg HAMIS értéket a pontos egyezés érdekében.

#HIÁNYZIK hiba egy cellában

  • Ha a tartományban_keres értéke IGAZ, akkor ha a keresési_érték kisebb a tábla első oszlopában lévő értéknél, a képlet #HIÁNYZIK hibaértéket ad vissza.

  • Ha a tartományban_keres értéke HAMIS, a #HIÁNYZIK érték azt jelzi, hogy a pontos szám nem található.

Az FKERES függvény használatakor fellépő #HIÁNYZIK hiba elhárításáról bővebben a #HIÁNYZIK! hiba kijavítása az FKERES függvényben című témakörben olvashat.

#HIV! hiba egy cellában

Ha az oszlop_szám nagyobb a tábla oszlopainak a számánál, a képlet #HIV! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #HIV! hiba elhárításáról bővebben A #HIV! hiba javítása.

#ÉRTÉK! hiba egy cellában

Ha a tábla értéke kisebb 1-nél, a képlet #ÉRTÉK! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #ÉRTÉK! hiba elhárításáról bővebben az #ÉRTÉK! hiba kijavítása az FKERES függvényben.

#NÉV? hiba egy cellában

A #NÉV? hibaérték általában azt jelenti, hogy a képletből idézőjelek hiányoznak. Ha egy személy nevére keres, ügyeljen arra, hogy a képletben foglalja idézőjelek közé a nevet. A nevet például a következőképpen írja be: "Lengyel" az =FKERES("Lengyel",B2:E7,2,HAMIS) képletben.

További információt A #NÉV? hiba javítása.

#KITÖLTÉS! hiba egy cellában

Ez a #SPILL! hiba A általában azt jelenti, hogy a képlet implicit metszetre támaszkodik a keresési értékhez, és egy teljes oszlopot használ hivatkozásként. Például: =FKERES(A:A;A:C;2;HAMIS). A probléma megoldásához rögzítse a keresési hivatkozást a @ operátorral a következő módon: =FKERES(@A:A,A:C;2;HAMIS). Másik lehetőségként használhatja a hagyományos FKERES metódust, és egyetlen cellára hivatkozhat a teljes oszlop helyett: =FKERES(A2;A:C;2;HAMIS).

Művelet

Indoklás

Használjon abszolút cellahivatkozásokat a tartományban_keres értékeként

Az abszolút hivatkozásokkal automatikusan kitöltheti a cellákat a képlettel, biztosítva, hogy az mindig ugyanazt a keresési tartományt használja.

Tudnivalók az abszolút cellahivatkozások használatáról.

Ne tárolja a számokat és a dátumokat szövegként.

Szám vagy dátumértékek keresésekor ügyeljen arra, hogy a tábla első oszlopában az adatok ne szöveges értékként legyenek tárolva. Ebben az esetben az FKERES hibás vagy váratlan eredményt adhat.

Rendezze az első oszlopot

Rendezze a tábla első oszlopát az FKERES használata előtt, ha a tartományban_keres értéke IGAZ.

Helyettesítő karakterek használata

Ha range_lookup HAMIS, és lookup_value szöveg, használhatja a helyettesítő karaktereket – a kérdőjelet (?) és a csillagot (*) – lookup_value. A kérdőjel egyetlen tetszőleges karaktert helyettesít. A csillag tetszőleges karaktersorozatot helyettesít. Ha valódi kérdőjelet vagy csillagot szeretne keresni, írjon be egy tilde (~) karaktert a karakter elé.

Az =FKERES("Fontan?";B2:E7;2;HAMIS) például a Fontana összes olyan példányát keresi, amelynek az utolsó betűje változhat.

Győződjön meg arról, hogy az adatokban nincsenek elírások.

Ha szöveges értékekben keres az első oszlopban, ügyeljen arra, hogy az első oszlopban szereplő adatok ne tartalmazzanak szóközöket a karakterlánc elején vagy végén, ne szerepeljenek bennük nem egységes módon használt egyenes (' vagy "), illetve nyomdai (‘ vagy “) idézőjelek, továbbá nem nyomtatható karakterek. Ilyenkor az FKERES hibás vagy váratlan eredményt adhat.

A pontos eredmény érdekében szükséges lehet a táblázatadatok utáni szóközök eltávolítása a cellákból. Ehhez használhatja a TISZTÍT függvényt vagy a KIMETSZ függvényt.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

Rövid összefoglaló: FKERES frissítő
Rövid összefoglaló: Az FKERES hibaelhárítási tippjei
#VALUE! hiba kijavítása az FKERES függvényben
#N/A hiba kijavítása az FKERES függvényben
A képletek áttekintése a Excel
A hibás képletek
elkerülése– Képlethibák
észlelése Excel függvények (betűrendes)
Excel függvények (kategória szerint)
FKERES (ingyenes előzetes verzió)

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×