Tipp: Próbálja meg használni az új XKERES függvényt, az FKERES továbbfejlesztett verzióját, amely bármilyen irányban működik, és alapértelmezés szerint pontos egyezéseket ad vissza, így könnyebb és kényelmesebb a használata, mint a megelőzője.

Az FKERES akkor használható, ha egy táblázatban vagy tartományban sor alapján kell megtalálnia a dolgokat. Megkeresheti például egy alkatrész árát a alkatrészszám alapján, vagy megkeresheti az alkalmazott nevét az alkalmazott azonosítója alapján.

Az FKERES függvény legegyszerűbben az alábbi módon értelmezhető:

=FKERES(Amit ki szeretne keresni, ahol meg szeretné keresni, a visszakeresni kívánt értéket tartalmazó tartomány oszlopszáma, közelítő vagy pontos egyezés – 1/IGAZ vagy 0/HAMIS jelölésű érték).

Ez a böngésző nem támogatja a videók lejátszását.

Tipp: Az FKERES az adatok rendszerezése úgy, hogy a kikeresett érték (Gyümölcs) a keresni kívánt visszatérési érték (Mennyiség) bal oldali értéke.

Az FKERES függvénnyel kikeresheti egy táblázat egy értékét.

Szintaxis 

Szintaxis: FKERES(keresési_érték; tábla; oszlop_szám; [tartományban_keres])

Például:

  • =FKERES(A2;A10:C20;2;IGAZ)

  • =FKERES("Lengyel";B2:E7;2;HAMIS)

  • =FKERES(A2;'Ügyféladatok'! A:F,3,HAMIS)

Argumentum neve

Leírás

keresési_érték    (kötelező)

A kikeresni kívánt érték. A ki keresni kívánt értéknek a Cellatartomány argumentumban megadott első oszlopban kell lennie table_array meg.

Ha például a tábla a B2:D7 cellatartományt is átfogja, akkor az lookup_value a B oszlopban kell lennie.

Lookup_value érték vagy cellahivatkozás lehet.

tábla    (kötelező)

Az a cellatartomány, amelyben az FKERES függvény a keresési_értéket és a visszaadott értéket keresi. Használhat elnevezett tartományt vagy táblázatot, és cellahivatkozások helyett neveket is használhat az argumentumban. 

A cellatartomány első oszlopának tartalmaznia kell a lookup_value. A cellatartománynak tartalmaznia kell a keresve kívánt visszatérési értéket is.

Tudnivalók a tartományok kijelöléséről munkalapon.

oszlop_szám    (kötelező)

A visszatérési értéket tartalmazó oszlop száma (a bal oldali oszlopban table_array1-től kezdve).

tartományban_keres    (nem kötelező)

Logikai érték, amellyel az FKERES függvényhez közelítő vagy pontos keresést írhat elő:

  • Közelítő egyezés – 1/IGAZ azt feltételezi, hogy a tábla első oszlopa számsorrendben vagy betűrendben van rendezve, majd rákeres a legközelebbi értékre. Ez az alapértelmezett keresési mód, ha nincs semmi megadva. Például: =FKERES(90;A1:B100;2;IGAZ).

  • Pontos egyezés – 0/HAMIS kereséssel pontosan az első oszlopban lévő értéket keresi. Például: =FKERES("Kovács",A1:B100,2,HAMIS).

Első lépések

Az FKERES függvény szintaktikailag helyes használatához az alábbi négy adatot kell megadnia:

  1. A keresendő érték, melyet keresési értéknek is nevezünk.

  2. A tartomány, amelyben a keresési érték megtalálható. Ne feledje, hogy a keresési értéknek mindig a tartomány első oszlopának kell lennie ahhoz, hogy az FKERES függvény megfelelően működjön. Ha például a keresési érték a C2 cellában található, akkor a tartománynak a C oszloppal kell kezdődnie.

  3. A visszatérési érték oszlopszáma a tartományban. Ha például a B2:D11 tartományt adja meg, akkor a B számít első oszlopnak, a C másodiknak és így tovább.

  4. Opcionálisan megadhatja az IGAZ értéket, ha a visszatérési érték kereséséhez közelítő egyezést szeretne előírni, vagy a HAMIS értéket, ha pontos egyezést. Ha nem ad meg semmit, az alapértelmezett érték az IGAZ, vagyis a közelítő egyezés.

A fentieket a következőképpen egyesítheti egy működő képletbe:

=FKERES(keresési érték; keresési értéket tartalmazó tartomány; a visszatérési értéket tartalmazó tartomány oszlopszáma, közelítő egyezés (IGAZ) vagy Pontos egyezés (HAMIS)).

Példák

Íme néhány példa az FKERES használatára:

1. példa

=FKERES (B3;B2:E7;2;HAMIS)

Az FKERES függvény a B2:E7 sor első oszlopában (B oszlop table_array ában) rákeres a Fontana függvényre, és a képlet második oszlopából (C oszlopából) visszaadja az Olivier table_array.  A Hamis pontos egyezést ad vissza.

2. példa

=FKERES (102;A2:C7;2;HAMIS)

Az FKERES függvény pontos egyezést keres az A2:C7 tartomány második oszlopában (lookup_value) lévő vezetéknév (lookup_value) vezetéknevének (HAMIS), és visszaadja a Fontana értéket.

3. példa

=HA(FKERES(103;A1:E7;2;HAMIS)="Souse";"Található";"Nem található")

A HA függvény ellenőrzi, hogy az FKERES az A1:E7 (E table_array 7) adatban megadott 103 -as (lookup_value) értéket adja-e vissza az alkalmazott vezetékneveként (Sousza). Mivel a 103-as értéknek megfelelő vezetéknév Leal, a HA feltétel hamis, és a Nem található érték jelenik meg.

4. példa

=INT(ÉVFRAC(DÁTUM(2014;6;30);FKERES(105;A2:E7;5;FLASE);1))

Az FKERES függvény az A2:E7 tartományban (lookup_value) megfelelő alkalmazott születési dátumát (table_array) keres, és 1955.03.04. értéket adja eredményül. Ezután a TÖRÉSÉV kivonja ezt a születési dátumot a 2014.06.30.06. dátumból, és visszaad egy értéket, amelyet az INY függvény az 59-es egész számra konvertál.

5. példa

HA(NINCS(FKERES(105;A2:E7;2;FLASE))=IGAZ;"Az alkalmazott nem található",FKERES(105;A2:E7;2;HAMIS))

A HA függvény ellenőrzi, hogy az FKERES függvény a B oszlopban lévő vezetéknév értékét adja-e vissza a 105-ös értékhez (lookup_value). Ha az FKERES megtalálja a vezetéknevet, akkor a HA függvény megjeleníti a vezetéknevet, ellenkező esetben a HA függvény a Nem található alkalmazott értéket adja vissza. Ha az FKERES függvény a #N/A értéket adja vissza, a hibát a Nem található alkalmazott szöveg helyettesíti a #N/A helyett.



Ebben a példában a visszatérési érték Benini, amely a 105-nek megfelelő vezetéknév.

Az FKERES segítségével több táblát egyesíthet egyetlen táblában, ha az egyik táblában közös mezők vannak a többi táblában. Ez különösen hasznos lehet, ha olyanokkal kell megosztania egy munkafüzetet, akik az Excel régebbi verzióival nem támogatják a több táblázatot adatforrásként tartalmazó adatszolgáltatásokat – a források egyetlen táblába történő kombinálásával és az adatkapcsolat adatforrásának az új táblára történő módosításával az adat funkciót használhatja a régebbi Excel-verziókban is (feltéve, hogy a régebbi verzió támogatja az adatszolgáltatásokat).

Munkalap az FKERES segítségével más táblázatokból származó adatok bekereséséhez

Az A-F és a H oszlop itt olyan értékeket vagy képleteket tartalmaz, amelyek csak a munkalapon használják az értékeket, a többi oszlopban pedig az FKERES, az A oszlop értéke (Ügyfélkód) és a B oszlop értéke más táblázatokból származó adatok bekereséséhez.

  1. Másolja a közös mezőket tartalmazó táblát egy új munkalapra, és nevezze el.

  2. Kattintson az> adateszközök >kapcsolatok parancsra a Kapcsolatok kezelése párbeszédpanel megnyitásához.

    The Manage Relationships dialog box
  3. Az egyes felsorolt kapcsolatokhoz jegyezze fel az alábbiakat:

    • A táblákat összetartó mező (amely zárójelek között látható a párbeszédpanelen). Ez az lookup_value az FKERES képlethez.

    • A kapcsolódó keresési tábla neve. Ez az table_array az FKERES képletben.

    • A Kapcsolódó keresési tábla abban a mezőjében (oszlopában), amely az új oszlopban kívánt adatokat tartalmazza. Ezek az információk nem jelennek meg a Kapcsolatok kezelése párbeszédpanelen – a kapcsolódó keresési táblában meg kell néznie, hogy melyik mezőt szeretné lekérni. Fel szeretné jegyezni az oszlop számát (A=1) – ez col_index_num száma a képletben.

  4. Ha új mezőt szeretne hozzáadni az új táblához, a 3. lépésben összegyűjtött adatok alapján írja be az FKERES képletet az első üres oszlopba.

    Ebben a példában a G oszlop a Attorney (a lookup_value) oszlopot használja a Bill Rate (Számladíj) adatoknak a negyedik oszlopból(col_index_num = 4) a tblAttorneys (a table_array)táblázatból, az =FKERES([@Attorney],tbl_Attorneys,4,HAMIS)képlettel.

    A képlet cellahivatkozást és tartományhivatkozást is használhat. A példában ez a következő lenne: =FKERES(A2;'Ügyvédi'! A:D,4,HAMIS).

  5. Folytassa a mezők hozzáadását, amíg az összes szükséges mezőt meg nem adja. Ha olyan munkafüzetet próbál készíteni, amely több táblát tartalmazó adatszolgáltatásokat tartalmaz, módosítsa az adatkapcsolat-szolgáltatás adatforrását az új táblára.

Probléma

A probléma oka

Nem megfelelő visszaadott érték

Ha a tartományban_keres argumentum értéke IGAZ vagy nincs megadva, az első oszlopban lévő értékeknek betűrendben vagy számsorrendben kell elhelyezkedniük. Ha az első oszlop nem rendezett, előfordulhat, hogy nem a várt eredményt kapja vissza. Rendezze az első oszlopot, vagy adjon meg HAMIS értéket a pontos egyezés érdekében.

#HIÁNYZIK hiba egy cellában

  • Ha a tartományban_keres értéke IGAZ, akkor ha a keresési_érték kisebb a tábla első oszlopában lévő értéknél, a képlet #HIÁNYZIK hibaértéket ad vissza.

  • Ha a tartományban_keres értéke HAMIS, a #HIÁNYZIK érték azt jelzi, hogy a pontos szám nem található.

Az FKERES függvény használatakor fellépő #HIÁNYZIK hiba elhárításáról bővebben a #HIÁNYZIK! hiba kijavítása az FKERES függvényben című témakörben olvashat.

#HIV! hiba egy cellában

Ha az oszlop_szám nagyobb a tábla oszlopainak a számánál, a képlet #HIV! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #HIV! hiba elhárításáról bővebben A #HIV! hiba javítása.

#ÉRTÉK! hiba egy cellában

Ha a tábla értéke kisebb 1-nél, a képlet #ÉRTÉK! hibaértéket ad vissza.

Az FKERES függvény használatakor fellépő #ÉRTÉK! hiba elhárításáról bővebben az #ÉRTÉK! hiba kijavítása az FKERES függvényben.

#NÉV? hiba egy cellában

A #NÉV? hibaérték általában azt jelenti, hogy a képletből idézőjelek hiányoznak. Ha egy személy nevére keres, ügyeljen arra, hogy a képletben foglalja idézőjelek közé a nevet. A nevet például a következőképpen írja be: "Lengyel" az =FKERES("Lengyel",B2:E7,2,HAMIS) képletben.

További információt A #NÉV? hiba javítása.

#KITÖLTÉS! hiba egy cellában

Ez a #SPILL! hiba ez általában azt jelenti, hogy a képlet implicit metszetre támaszkodik a keresési értékhez, és egy teljes oszlopot használ hivatkozásként. Például: =FKERES(A:A,A:C,2,HAMIS). A problémát megoldhatja úgy, hogy a keresési hivatkozást az = FKERES(@A:A,A:C,2,HAMIS) operátorhoz rögzítette. Másik lehetőségként használhatja a hagyományos FKERES metódust, és egyetlen cellára hivatkozhat egy teljes oszlop helyett: =FKERES( A2 ,A:C,2,HAMIS).

Művelet

Indoklás

Használjon abszolút cellahivatkozásokat a tartományban_keres értékeként

Az abszolút hivatkozásokkal automatikusan kitöltheti a cellákat a képlettel, biztosítva, hogy az mindig ugyanazt a keresési tartományt használja.

Tudnivalók az abszolút cellahivatkozások használatáról.

Ne tárolja a számokat és a dátumokat szövegként.

Szám vagy dátumértékek keresésekor ügyeljen arra, hogy a tábla első oszlopában az adatok ne szöveges értékként legyenek tárolva. Ebben az esetben az FKERES hibás vagy váratlan eredményt adhat.

Rendezze az első oszlopot

Rendezze a tábla első oszlopát az FKERES használata előtt, ha a tartományban_keres értéke IGAZ.

Helyettesítő karakterek használata

Ha range_lookup hamis, lookup_value a helyettesítő karaktereket – kérdőjelet (?) és csillagot (*) – használhatja a lookup_value. A kérdőjel egyetlen tetszőleges karaktert helyettesít. A csillag tetszőleges karaktersorozatot helyettesít. Ha magát a kérdőjelet vagy csillagot szeretné megtalálni, írjon be elé egy tilde karaktert (~).

Az =FKERES("Betűtípus?",B2:E7,2,HAMIS) keresés például a Fontana összes előfordulására keres, és az utolsó betű változó lehet.

Győződjön meg arról, hogy az adatokban nincsenek elírások.

Ha szöveges értékekben keres az első oszlopban, ügyeljen arra, hogy az első oszlopban szereplő adatok ne tartalmazzanak szóközöket a karakterlánc elején vagy végén, ne szerepeljenek bennük nem egységes módon használt egyenes (' vagy "), illetve nyomdai (‘ vagy “) idézőjelek, továbbá nem nyomtatható karakterek. Ilyenkor az FKERES hibás vagy váratlan eredményt adhat.

A pontos eredmény érdekében szükséges lehet a táblázatadatok utáni szóközök eltávolítása a cellákból. Ehhez használhatja a TISZTÍT függvényt vagy a KIMETSZ függvényt.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

Rövid összefoglalás: FKERES frissítő
Rövid összefoglalás: Hibaelhárítási tippek az FKERESkereshez
Az FKERES #VALUE! hiba kijavítja
A hibaértékek #N/A hiba kijavítja az FKERES függvényben
A képletek áttekintése a Excel
Hibás képletek elkerülése
Képlethibák észlelése
Excel függvények (betűrendes)
Excel függvények kategória szerint
FKERES (ingyenes előzetes verzió)

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük visszajelzését!

×