Ha meg kell számolnia a cellákban lévő karaktereket, használja a HOSSZ függvényt. A függvény a betűket, számokat, karaktereket és az összes szóközt megszámolja. A "Ma 98 fok van, úgyhogy strandra megyek" (az idézőjeleket kivéve) hossza például 42 karakter – 31 betű, 2 szám, 8 szóköz, vessző és 2 aposztróf.

  • A függvény alkalmazáshoz írja be az =HOSSZ(cella) képletet a szerkesztőlécre, és nyomja le az Enter billentyűt. Ezekben a példákban a cella a megszámolni kívánt cella, például B1.

  • Ha egynél több cellában szeretné megszámolni a karaktereket, írja be a képletet, majd másolja be azt a többi cellába.

  • Több cella karakterszámának megszámlálásához használja a SZUM függvényeket a HOSSZ függvényekkel együtt. Például: =SZUM((HOSSZ(cella1);HOSSZ(2. cella);(HOSSZ(cella3)))). Ebben a példában a HOSSZ függvény megszámolja az egyes cellákban lévő karaktereket, a SZUM függvény pedig összeadja az értékeket.

  • Ha azt szeretné megszámolni, hogy hányszor szerepel egy konkrét karakter a cellákban, akkor használja a HOSSZ függvényt a HELYETTE függvénnyel együtt. Ha például tudni szeretné, hogy hány kis Z betű található egy adott cellában, akkor használja a következő képletet: =HOSSZ(cella1)-HOSSZ(HELYETTE(cella1,"z",""))

Tegyen egy próbát!

Írja be az alábbi adatokat egy új Excel-munkalapra. Kezdje az A1 cellában.

Szöveges karakterláncok

Képletek

Árvíztűrő tükörfúrógép

Árvíztűrő tükörfúrógép ÁRVÍZTŰRŐ

Árvíztűrő tükörfúrógép ÁRVÍZTŰRŐ TÜKÖRFÚRÓGÉP

Egy cella karaktereinek megszámolása

  1. Kattintson a B2 cellára.

  2. Írja be a cellába az =HOSSZ(A2) képletet, és nyomja meg az Enter billentyűt.

A képlet megszámolja az A2 cellában található karaktereket, amelyek száma 19, beleértve a szóközöket is. Ha az utolsó pont után is vannak szóközök, a képlet azokat is beleszámolja.

Karakterek megszámlálása ebben: több cella

  1. A B2 cella másolásához nyomja le a CONTROL + C billentyűkombinációt.

  2. A képlet a B3:B4 cellákba való beillesztéséhez nyomja le a CONTROL + V billentyűkombinációt

Ez a művelet a B3 és a B4 cellába másolja a képletet, a függvény pedig mindhárom cellában megszámolja a karaktereket (26 és 44).

A karakterszám összesítése

  1. Kattintson a B6 cellára.

  2. Írja be a cellába az =SZUM(HOSSZ(A2);HOSSZ(A3);HOSSZ(A4)) képletet, és nyomja le az Enter billentyűt.

Ez a művelet megszámolja, hogy hány karakter van a három cellában, és összeadja az értékeket. Az eredmény 89.

Konkrét karakterek megszámolása az egyes cellákban

  1. Kattintson a C4 cellára.

  2. Írja be a cellába a =HOSSZ(A4)-HOSSZ(HELYETTE(A4,"z","")) képletet, és nyomja le az Enter billentyűt.

Ez megszámolja az A4 cellában található kis Z betűket, amelyek száma 1.

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×