Műveleti jelek és elsőbbségi sorrend az Excelben

Az operátorok határozzák meg a képlet elemein (például összeadáson, kivonáson, szorzáson vagy osztáson) végrehajtani kívánt számítás típusát. Ebben a cikkben megtudhatja, hogy az operátorok milyen alapértelmezett sorrendben lépnek fel a számításokban szereplő elemek alapján. Azt is megtudhatja, hogy miként módosíthatja ezt a sorrendet zárójelek használatával.

Operátortípusok

Az Excel a következő négy operátortípust tartalmazza: számtani, összehasonlító, szövegösszefűző és hivatkozási operátor.

Ha alapvető matematikai műveleteket (például összeadást, kivonást vagy szorzást) vagy számok egyesítését vagy numerikus eredményeket hoz létre, használja a táblázat számtani operátorait.

Számtani operátor

Jelentés

Példa

+ (pluszjel)

Összeadás

=3+3

– (mínuszjel)


Kivonás Negation

=3–1
=–1

* (csillag)

Szorzás

=3*3

/ (törtjel)

Osztás

=3/3

% (százalékjel)

Százalékszámítás

=20%

^ (kalap)

Hatványra emelés

=

Az alábbi táblázatban szereplő operátorokkal két értéket hasonlíthat össze. Ha két értéket hasonlít össze ezekkel az operátorokkal, az eredmény IGAZ vagy HAMIS logikai érték lesz.

Összehasonlító operátor

Jelentés

Példa

= (egyenlőségjel)

Egyenlő

=A1=B1

> (nagyobb, mint jel)

Nagyobb

=A1>B1

< (kisebb, mint jel)

Kisebb

=A1<B1

>= (nagyobb vagy egyenlő jel)

Nagyobb vagy egyenlő

=A1>=B1

<= (kisebb vagy egyenlő jel)

Kisebb vagy egyenlő

=A1<=B1

<> (nem egyenlő jel)

Nem egyenlő

=A1<>B1

Az és (&) karaktersorozatot használva egy vagy több szöveges karakterláncot egyesítve vagy összefésülve egyetlen szövegrészet hoz létre.

Szövegösszefűző

Jelentés

Példa

& (és karakter)

Két értéket kapcsol össze (vagy összetesz) egy folyamatos szöveges érték előállításához.

="Észak"&"szél"

Cellatartományok kombinálása számításokhoz ezekkel az operátorokkal.

Hivatkozási operátor

Jelentés

Példa

: (kettőspont)

Tartományoperátor, amely a két hivatkozás közötti összes cellára (beleértve a két hivatkozást is) egyetlen hivatkozást eredményez

=SZUM(B5:B15)

; (pontosvessző)

Union operator, which combines multiple references into one reference.

=SZUM(B5:B15;D5:D15)

(szóköz)

Metszet operátor, amely a két hivatkozás közös celláira hivatkozik.

=SZUM(B7:D7 C6:C8)

# (font)

A # szimbólum több kontextusban is használatos:

  • Hibanév részeként használható.

  • A megjelenítéshez nem elegendő helyet jelez. A legtöbb esetben szélesedhet az oszlopon, amíg a tartalom nem megfelelően meg nem jelenik.

  • Spilled range operator, which used to reference an entire range in a dynamic array formula.

  • #ÉRTÉK!

  • #####

  • =SZUM(A2#)

@ (at)

Hivatkozási operátor, amely egy képlet implicit metszetének jelzésére szolgál. 

=@A1:A10

=SZUM(Tábla1[@[Január]:[December]])

Műveletek végrehajtási sorrendje képletekben

Bizonyos esetekben a számítás sorrendje befolyásolhatja a képlet eredményét, ezért fontos megérteni a sorrendet, és azt, hogy miként módosíthatja a sorrendet a várt eredmények eléréséhez.

A képletek meghatározott sorrendben számolják ki az értékeket. A képletek a Excel mindig egyenlőségjelet (=) tartalmaznak. Az egyenlőségjel Excel jelzi, hogy a következő karakterek alkotják a képletet. Az egyenlőségjel után lehet számított elemek sorozata (operandusok), amelyeket műveleti operátorok választnak el egymástól. Excel a képletet balról jobbra, a képletben szereplő egyes operátorok meghatározott sorrendje szerint számítja ki.

Ha egyetlen képletben több operátort ad meg, az Excel a műveleteket az alábbi táblázat szerinti sorrendben hajtja végre. A képlet azonos prioritású műveleteit (például szorzás és osztás) az Excel balról jobbra haladva értékeli ki.

Operátor

Leírás

: (kettőspont)

(szóköz)

; (pontosvessző)

Hivatkozási operátorok

Ellentett képzése (például –1)

%

Százalék

^

Hatványra emelés

* és /

Szorzás és osztás

+ és –

Összeadás és kivonás

&

Karaktersorozatok összefűzése

=
< >
<=
>=
<>

Összehasonlítás

A végrehajtási sorrend módosításához az elsőnek kiértékelni kívánt képletrészt írja zárójelek közé. A következő képlet eredménye például 11 lesz, mivel az Excel szorzást számít ki az összeadás előtt. A képlet először megszorz 2-t hárommal, majd hozzáad 5-öt az eredményhez.

=5+2*3

Ezzel szemben, ha zárójelekkel módosítja a szintaxist, az Excel összeadja az 5-öt és a 2-t, majd az eredményt megszorzása 3-sal 21-et eredményez.

=(5+2)*3

Az alábbi példában a képlet első részét körülválasztó zárójel arra kényszeríti a Excel-t, hogy először a B4+25 értéket számítsa ki, majd elosztja az eredményt a D5, az E5 és az F5 cella összegének összegával.

=(B4+25)/SZUM(D5:F5)

Ebből a videóból megtudhatja, hogy hogyan Excel operátorok sorrendjét.

Az Excel képletek értékeinek konvertálása

Képlet beírása esetén a Excel különböző típusú értékeket vár az egyes operátorok esetében. Ha a várttól eltérő típusú értéket ad meg, Excel konvertálhatja az értéket.

A képlet

Létrehozva

Ismertetés

= "1"+"2"

3

Ha pluszjelet (+) használ, Excel a program számokat vár a képletben. Bár az idézőjelek azt jelentik, hogy az "1" és a "2" szöveges érték, Excel automatikusan számokká alakítja a szöveges értékeket.

= 1+"400 Ft"

5

Ha egy képlet számot vár, a Excel konvertálja a szöveget, ha formátuma általában számként elfogadott.

= "2001.06.01."-"2001.05.01"

31

Excel a szöveget dátumként fogja értelmezni hh/hh/yyyy formátumban, a dátumokat sorszámokká alakítja, majd kiszámítja a különbséget közöttük.

=GYIK ("8+1")

#ÉRTÉK!

Excel nem konvertálhatja a szöveget számká, mert a "8+1" szöveget nem konvertálhatja számká. A "8+1" helyett a "9" vagy a "8"+"1" szöveget használhatja a szöveg számká konvertálása és a 3 eredményének visszaadása érdekében.

= "A"&IGAZ

ATRUE

Ha szövegre vár, a Excel számokat és logikai értékeket (például IGAZ és HAMIS) szöveggé konvertál.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

×