Ha meg akar róla győződni, hogy egy érték nem azonos egy másik értékkel, használja a NEM függvényt, amely a logikai függvények közé tartozik.

Példa

Példák argumentumok megfordítható NEM függvényre.  Pl.: =NEM(1+1=2)

A NEM függvény megfordítja a beleírt argumentum értékét.

A NEM függvény egyik leggyakoribb szerepe más, logikai vizsgálatokat végrehajtó függvények hasznosságának kiterjesztése. A HA függvény például egy logikai vizsgálatot végez, és IGAZ eredmény esetén egy adott értéket, HAMIS eredmény esetén pedig egy másik értéket ad vissza. Ha a NEM függvényt használja fel a HA függvény logikai_vizsgálat argumentumaként, akkor nem csak egy, hanem egyszerre több különböző feltételt vizsgálhat.

Szintaxis

NEM(logikai)

A NEM függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • Logikai:    Megadása kötelező. Olyan érték vagy kifejezés, amelynek kiértékelése az IGAZ vagy a HAMIS értéket adja.

Megjegyzések

Ha az argumentum értéke HAMIS, a NEM függvény visszatérési értéke IGAZ lesz, ha az argumentum értéke IGAZ, a NEM függvény visszatérési értéke HAMIS lesz.

Példák

Az alábbiakban általános jellegű példákat adunk a NEM függvény önálló, illetve HA, ÉS és VAGY. függvénnyel történő együttes használatára.

Példák a NEM függvényre a HA, az ÉS és a VAGY függvényekkel

Képlet

Leírás

=NEM(A2>100)

Az A2 cella értéke NEM nagyobb 100-nál.

=HA(ÉS(NEM(A2>1);NEM(A2<100));A2;"Az érték a tartományon kívül esik")

50 nagyobb, mint 1 (IGAZ) ÉS 50 kisebb, mint 100 (IGAZ), ezért a NEM mindkét argumentumot HAMIS értékűre változtatja. Az ÉS függvény esetében mindkét argumentumnak IGAZ értékűnek kell lennie, ezért a HAMIS eredményt adja vissza.

=HA(VAGY(NEM(A3<0);NEM(A3>50));A3;"Az érték a tartományon kívül van.")

100 kisebb, mint a 0 (HAMIS) és 100 nagyobb, mint 50 (IGAZ), így a NEM megfordítja a az argumentumok értékét IGAZ/HAMIS értékre. A VAGY függvény esetében csak az egyik argumentumnak kell IGAZ értékűnek kell lennie, ezért az IGAZ eredményt adja vissza.

Értékesítési jutalék kiszámítása

A következő példa azt szemlélteti, hogy miként számítható ki az értékesítők bónusza a NEM függvény HA és ÉSfüggvénnyel való használatával.

Példa értékesítési bónusz kiszámítására a HA, az ÉS és a NEM képletekkel.  Az E14 cellában lévő képlet a következő: =HA(ÉS(NEM(B14<$B$7);NEM(C14<$B$5));B14*$B$8;0)
  • =HA(ÉS(NEM(B14<$B$7);NEM(C14<$B$5));B14*$B$8;0)- HA az összforgalom NEM kisebb, mint az értékesítési célérték, ÉS az ügyfélszerzések száma NEM kisebb, mint az ügyfélszerzési célérték, akkor szorozza meg az összforgalmat a jutalék százalékos értékével, egyéb esetben a visszatérési érték legyen 0.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Kapcsolódó témakörök

Videó: HA függvények haladóknak
További információ a beágyazott függvények képletekben való használatának mikéntjéből
HA függvény
ÉS függvény
VAGY függvény
A képletek áttekintése a Excel
Hibás képletek elkerülése
Képlethibák észlelése hibaellenőrzés használatával
A Excel billentyűparancsai
Logikai függvények (hivatkozás)
Excel függvények (betűrendes)
Excel függvények kategória szerint

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×