A SZUMHA függvény a megadott feltételeknek tartomány értékek összegzésére használható. Tegyük fel például, hogy egy számokat tartalmazó oszlopban csak az 5-ösnél nagyobb értékeket szeretné összegni. A következő képletet használhatja: =SZUMHA(B2:B25;">5")

Ez a böngésző nem támogatja a videók lejátszását.

Ez a videó a Számok hozzáadása a Excel.

Tippek: 

  • A feltételek egy tartományra is alkalmazhatók, illetve egy másik tartomány megfelelő értékei is összeadhatók. Például a =SZUMHA(B2:B5, "Jani", C2:C5) képlet csak azokat az értékeket adja össze a C2:C5 tartományban, ahol a B2:B5 tartomány megfelelő cellái a „Jani” értéket tartalmazzák.

  • Ha több feltétel alapján szeretne összeadni cellákat, a SZUMHATÖBB függvény című témakörben talál további tudnivalókat.

Fontos: A SZUMHA függvény helytelen eredményt ad, ha 255 karakternél hosszabb karakterláncok vagy a #VALUE!.

Szintaxis

SZUMHA(tartomány; feltételek; [összegtartomány])

A SZUMHA függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • tartomány:   Megadása kötelező. Ez a feltételek alapján kiértékelendő cellatartomány. Az egyes tartományok celláiban számok vagy nevek, tömbök vagy számokat tartalmazó hivatkozások szerepelhetnek. Az üres és a szöveges értékeket nem veszi figyelembe a függvény. A választott tartomány dátumokat is tartalmazhat szabványos Excel-formátumban (lásd a példákat alább).

  • feltételek:   Megadása kötelező. Ezek az összeadandó cellákat meghatározó, számként, kifejezésként, cellahivatkozásként, szövegként vagy függvényként megadott feltételek. Helyettesítő karakterek is használhatók: kérdőjel (?) bármely adott karakternek, csillag (*) a tetszőleges karaktersorozatnak megfelelő. Ha magát a helyettesítő karaktert keresi, írjon be egy tildét (~) a keresett karakter elé.

    Például a következő feltételeket lehet kifejezni: 32, ">32", B5, "3?", "apple*", "*~?" vagy MA().

    Fontos: Bármely szöveges feltételt vagy bármely olyan feltételt, amely logikai vagy matematikai szimbólumokat tartalmaz, dupla idézőjelbe (") kell tenni. Ha a feltétel numerikus, nem szükséges a dupla idézőjel.

  • összegtartomány:   Megadása nem kötelező. Ezek a ténylegesen összeadandó cellák, ha a tartomány argumentumban megadottaktól eltérő cellákat szeretne összeadni. Ha az összegtartomány argumentumot elhagyja, az Excel a tartomány argumentumban megadott cellákat adja össze (ugyanazokat, amelyekre a feltételeket érvényesíti).

    Sum_range méretének és alakzatának meg kell egyennek lennie a tartomány méretével és alakzatának. Ha nem, a teljesítmény károkat okozhat, és a képlet össze fogja összegni azt a cellatartományt, amely az első cellával kezdődik a sum_range de a tartomány méretével azonos. Például:

    tartomány

    összegtartomány:

    Tényleges összegzetlen cellák

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1:K5

    B1:B5

Példák

1. példa

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Az ingatlan értéke

Jutalék

Adatok

10 00 000 Ft

700 000 Ft

25 000 000 Ft

20 000 000 Ft

1 400 000 Ft

30 000 000 Ft

2 100 000 Ft

40 000 000 Ft

2 800 000 Ft

Képlet

Leírás

Eredmény

=SZUMHA(A2:A5;">16000000";B2:B5)

A 16 000 000 Ft fölötti értékű ingatlanok után járó jutalékok összege.

6 300 000 Ft

=SZUMHA(A2:A5;">16000000")

A 16 000 000 Ft fölötti értékű ingatlanok értékének összege.

90 000 000 Ft

=SZUMHA(A2:A5;30000000;B2:B5)

A 30 000 000 Ft fölötti értékű ingatlanok után járó jutalékok összege.

2 100 000 Ft

=SZUMHA(A2:A5;">" & C2;B2:B5)

A C2 cellában megadott érték fölötti értékű ingatlanok után járó jutalékok összege.

4 900 000 Ft

2. példa

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Kategória

Élelmiszer

Értékesítés

Zöldségek

Paradicsom

230 000 Ft

Zöldségek

Zeller

550 000 Ft

Gyümölcs

Cseresznye

80 000 Ft

Vaj

40 000 Ft

Zöldségek

Répa

420 000 Ft

Gyümölcs

Alma

120 000 Ft

Képlet

Leírás

Eredmény

=SZUMHA(A2:A7;"Gyümölcs";C2:C7)

A „Gyümölcs” kategória összes élelmiszerének értékesítési összege.

200 000 Ft

=SZUMHA(A2:A7;"Zöldségek";C2:C7)

A „Zöldségek” kategória összes élelmiszerének értékesítési összege.

1 200 000 Ft

=SZUMHA(B2:B7;"*a";C2:C7)

Az összes „a” végű élelmiszer értékesítési összege (alma, répa).

430 000 Ft

=SZUMHA(A2:A7;"";C2:C7)

A kategória nélkül megadott összes élelmiszer értékesítési összege.

40 000 Ft

Vissza a lap tetejére

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

A SZUMHATÖBB függvény a több feltételnek megfelelő argumentumokat adja össze

A NÉGYZETÖSSZEG függvény több értéket összegez, miután mindegyiket négyzetre emelte

A DARABTELI függvény csak a megadott feltételnek megfelelő értékeket számolja meg

A DARABHATÖBB függvény csak a megadott összes feltételnek megfelelő értékeket számolja meg

HAELSŐIGAZ függvény (Office 365, Excel 2016 és újabb)

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása

Matematikai és trigonometriai függvények

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük visszajelzését!

×