Jelenség

A felhasználók felügyelet nélküli módban futtatják az asztalt, és a végrehajtás meghiúsul, mert nem találja a megfelelő felhasználói felületi elemeket. A hibaüzenetek azt mutatják, hogy a képernyőfelbontás futási időben eltér az asztali folyamat létrehozásakor használttól.   

A probléma oka

Felügyelet nélküli Windows futtatásakor egyes számítógépek vagy virtuális gépek alapértelmezés szerint kisebb képernyőfelbontást kaphatnak. Ha az automatizált alkalmazások megkülönböztetik a képernyőfelbontást, vagy képalapú automatizálást használ, az asztali folyamat sikertelen lesz. 

Megoldás

Állítsa be az alapértelmezett felbontást a UIFlowService.exe.config-fájlban:

  • Navigáljon a "C:\Program Files (x86)\Power Automate Desktop" mappára.

  • A UIFlowService.exe.config megnyitása szövegszerkesztőben

  • Állítsa be a Microsoftot. Flow. RPA. UIFlowService.ScreenDefaultResolutionEnabled to true

  • Módosítsa a képernyő alapértelmezett felbontását a Szélesség és a Magasság tulajdonság beállításával:

        <!-- Screen resolution settings -->

        <add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionEnabled" value="true" />

        <add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionWidth" value="1920" />

        <add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionHeight" value="1080" />

        <add key="Microsoft.Flow.RPA.UIFlowService.ScreenDefaultResolutionScale" value="100" />

  • Keresse meg a Start menü > Services szolgáltatást, keresse meg az "Power Automate szolgáltatást" (a régebbi verziókban ez a "UIFlowService" (UIFlowService), a folyamat neve pedig UIFlowService.exe, ha a Feladatkezelőt használja). Indítsa újra a szolgáltatást a jobb gombbal kattintva, majd az "Újraindítás" gombra kattintva. Vagy ha szeretné, egyszerűen indítsa újra a gépet.

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×