Az FKERES függvény egy táblázat balszélső oszlopában keres, és az oszlop_szám-mal megadott oszlop azonos sorából tér vissza egy értékkel. Amikor az összehasonlítási értékek a kikeresni kívánt adattól balra egy oszlopban helyezkednek el, akkor az FKERES-t használja a VKERES függvény helyett.

Az F az FKERES névben a Függőlegest jelöli.

Az FKERES szintaxisa

FKERES(keresési_érték,tábla,oszlop_szám,tartományban_keres)

  • keresési_érték A tömb első oszlopában megkeresendő érték.; keresési_érték lehet érték, hivatkozás vagy karaktersorozat.

  • tábla Az a tábla, amelyben a keresést végre kell hajtani. Tartományhivatkozás vagy egy tartomány neve adható itt meg (például "Adatbázis" vagy "Lista")

    • Ha a tartományban_keres értéke IGAZ, akkor a tábla első oszlopában lévő értékeknek növekvő sorrendben kell elhelyezkedniük (..., -2, -1, 0, 1, 2, ... , A-Z, HAMIS, IGAZ stb.), mert különben az FKERES hibás eredményt adhat. Ha a
      tartományban_keres értéke HAMIS, akkor a
      tábla adatainak nem szükséges rendezettnek lenniük.

    • Értékek növekvő sorrendbe rendezéséhez válasszuk az
      Adatok menü Sorba rendezés parancsát, majd az Emelkedő beállítást.

    • A tábla első oszlopában szöveg, számok vagy logikai értékek szerepelhetnek.

    • A függvény Nem tesz különbséget a kis- és a nagybetűk között.

  • Oszlop_szám A
    tábla azon oszlopának a táblán belüli sorszáma, amelyből az eredményt meg kívánjuk kapni. Ha az
    oszlop_szám értéke 1, akkor a
    tábla első oszlopában lévő értéket kapjuk eredményül, ha az oszlop_szám értéke 2, akkor a
    tábla második oszlopában lévő értéket, és így tovább. Ha az oszlop_szám Ha az oszlop_szám értéke egynél kisebb, akkor az FKERES az #ÉRTÉK! hibaértéket adja eredményül. ha az
    oszlop_szám nagyobb, mint a
    tábla oszlopainak száma, akkor #HIV! hibaértéket kapunk.

  • Tartományban_keres Logikai érték, amellyel az FKERES függvény pontos vagy közelítő keresését adhatjuk meg. Ha értéke IGAZ vagy hiányzik, akkor a visszaadott érték közelítő lehet, azaz ha pontos egyezést nem talált a függvény, akkor a következő legnagyobb, de a
    keresési_érték argumentumnál kisebb értéket adja vissza. Ha a Tartományban_keres argumentum értéke HAMIS, akkor az FKERES pontos egyezést keres, és ha ilyen nincs, akkor a #HIÁNYZIK hibaértéket adja eredményül.

Megjegyzés:

  • Ha az FKERES nem találja a
    keresési_értéket és a tartományban_keres argumentum értéke IGAZ, akkor a keresési_érték-nél kisebb vagy egyenlő legnagyobb értéket használja.

  • Ha a keresési_érték kisebb, mint a tábla legkisebb értéke, akkor az FKERES a #HIÁNYZIK hibaértéket adja eredményül.

  • Ha az FKERES nem találja a
    keresési_értéket és a
    tartományban_keres argumentum értéke HAMIS, akkor a #HIÁNYZIK hibaértéket adja vissza.

Példa:

A

B

C

1

Sűrűség

Viszkozitás

Hőmérséklet

2

0.457

3.55

500

3

0.525

3.25

400

4

0.616

2.93

300

5

0.675

2.75

250

6

0.746

2.57

200

7

0.835

2.38

150

8

0.946

2.17

100

9

1.09

1.95

50

10

1.29

1.71

0

Képlet

Leírás (Eredmény)

=FKERES(1,A2:C10,2)

Megkeresi az 1 értéket az A oszlopban és a B oszlopból, ugyan abban a sorban található értéket adja vissza (2.17).

=FKERES(1,A2:C10,3,IGAZ)

Megkeresi az 1 értéket az A oszlopban és a B oszlopból, ugyan abban a sorban található értéket adja vissza (100).

=FKERES(.7,A2:C10,3,HAMIS)

Megkeresi a 0.746 értéket az A oszlopban. Mivel nincs konkrét találat az A oszlopban, hibaértéket ad vissza (#HIÁNYZIK).

=FKERES(0.1,A2:C10,2,IGAZ)

Megkeresi a 0.1 értéket az A oszlopban. Mivel a 0.1kisebb, mint a legkisebb érték az A oszlopban, hibaértéket ad vissza (#HIÁNYZIK).

=FKERES(2,A2:C10,2,IGAZ)

Megkeresi a 2-őt az A oszlopban és a B oszlopból, ugyan abban a sorban található értéket adja vissza (1.71).

Összefoglaló

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás a Microsoft Insiderek

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×