Pesan kesalahan saat Anda menginstal paket pemutakhiran .msu di komputer yang menjalankan Windows: "Pemasang Modul Windows harus diperbarui sebelum Anda dapat memasang paket ini"

Gejala

Ketika Anda menginstal paket pemutakhiran .msu di komputer yang menjalankan Windows, Anda mungkin menerima pesan galat berikut:
Penginstal modul Windows harus diperbarui sebelum Anda dapat menginstal paket ini. Perbarui Penginstal Modul Windows di komputer, kemudian coba lagi Penataan.
Ketika Anda menggunakan skrip untuk menginstal paket pemutakhiran .msu, penginstalan gagal. Ketika masalah ini terjadi, proses Wusa.exe mengembalikan kode galat 0x800f0823.

Penyebab

Masalah ini terjadi karena penginstalan memerlukan versi baru dari modul Windows Installer atau tumpukan layanan.

Pemecahan masalah

Untuk mengatasi masalah ini, gunakan pembaruan Windows untuk memperbarui Windows Installer modul atau tumpukan layanan. Atau, mengunduh pemutakhiran yang tercantum dalam tabel berikut ini dari Microsoft Download Center.
Sistem operasiNomor KB
Windows Vista dan Windows Server 2008955430
Windows 7 dan Windows Server 2008 R22533552
Windows 8 dan Windows Server 20122871777
Windows 8.1 dan Windows Server 2012 R22919442

Informasi lebih lanjut

Ketika Anda menggunakan Pemutakhiran Windows, Penginstal modul Windows atau pemutakhiran tumpukan layanan yang diperlukan. Namun, ketika Anda menginstal paket pemutakhiran .msu, Setup program tidak tersambung ke Pemutakhiran Windows untuk memperbarui Windows Installer modul atau tumpukan layanan.
Properti

ID Artikel: 925316 - Tinjauan Terakhir: 15 Jan 2017 - Revisi: 1

Tanggapan