Anda sedang offline saat ini, menunggu internet Anda untuk menyambung kembali

Cara memecahkan masalah akun pengguna dihapus di Office 365, Azure, atau Intune

PENTING: Artikel ini diterjemahkan oleh perangkat lunak penerjemahan mesin Microsoft, dan mungkin telah diedit oleh Masyarakat Microsoft melalui teknologi CTF dan bukan oleh seorang penerjemah profesional. Microsoft menawarkan baik artikel yang diterjemahkan oleh manusia maupun artikel hasil editan terjemahan oleh mesin/komunitas, sehingga Anda dapat mengakses semua artikel di Sentra Pengetahuan yang kami miliki dalam berbagai bahasa. Namun artikel hasil editan mesin atau bahkan komunitas tidak selalu sempurna. Artikel ini dapat mengandung kesalahan dalam hal kosa kata, sintaksis atau tatabahasa, sangat mirip dengan penutur asing yang membuat kekeliruan ketika berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab atas ketidakakuratan, kesalahan atau kerugian apa pun akibat dari kekeliruan dalam penerjemahan isi atau penggunaannya oleh pelanggan kami. Microsoft juga akan senantiasa memperbarui perangkat lunak penerjemahan mesin dan alat untuk menyempurnakan Editan Hasil Penerjemahan Mesin.

Klik disini untuk melihat versi Inggris dari artikel ini: 2619308
MASALAH
Akun pengguna secara tidak sengaja dihapus dari Microsoft Office 365, Microsoft Azure, atau Microsoft Intune dan telah dipulihkan.
PENYEBAB
Office 365 pengguna akun dapat dihapus di salah satu cara berikut:
  • Akun pengguna dapat dihapus secara manual menggunakan portal Office 365.
  • Akun pengguna dapat dihapus secara manual menggunakan Azure portal.
  • Akun pengguna dapat dihapus secara manual atau dihapus melalui skrip dengan menggunakan Microsoft Azure Active Directory modul untuk Windows PowerShell.
  • Akun pengguna dapat dihapus secara manual menggunakan pusat admin Exchange di Exchange Online.
  • Akun pengguna dapat dihapus melalui penghapusan disinkronkan jika perubahan penyaringan sinkronisasi direktori mengecualikan objek lokal pengguna direktori aktif dari sinkronisasi yang ditetapkan. (Perubahan penyaringan sinkronisasi direktori juga dikenal sebagai scoping.)
  • Akun pengguna dapat dihapus melalui penghapusan disinkronkan jika objek lokal pengguna dihapus dari skema direktori aktif di tempat.
  • Akun pengguna dapat dihapus dengan menggunakan API (misalnya, API grafik).
SOLUSI

Sebelum memulai

Ketika objek pengguna dihapus, itu tidak segera dan benar-benar dihapus dari Azure Active Directory (Azure AD). Objek pengguna dimasukkan ke dalam keadaan dihapus dan tidak lagi ditampilkan dalam daftar pengguna. Namun, dapat dipulihkan organisasi dalam 30 hari. Untuk menentukan apakah objek pengguna memenuhi syarat untuk pulih dari keadaan dihapus, ikuti langkah-langkah berikut:
  1. Di portal Office 365, Cari akun pengguna yang telah dihapus melalui portal. Untuk melakukannya, ikuti langkah-langkah berikut:
    1. Masuk ke (portal Office 365https://portal.Office.com) dengan menggunakan kredensial administratif.
    2. Klik pengguna, dan kemudian klik Pengguna dihapus.
    3. Cari pengguna yang akan dipulihkan.
  2. Menggunakan Azure Active Directory modul untuk Windows PowerShell, ikuti langkah-langkah berikut:
    1. Klik mulai, klik Semua program, klik Windows Azure Active Directory, dan kemudian klik Windows Azure Active Directory modul untuk Windows PowerShell.
    2. Ketik perintah berikut ini dalam urutan menurun yang disajikan. Pastikan bahwa Anda menekan Enter setelah Anda mengetik perintah.
      • $cred = get-credential
        Catatan Ketika Anda diminta, masukkan kredensial Office 365.
      • Connect-MSOLService -credential:$cred
      • Get-MsolUser –ReturnDeletedUsers

Penyelesaian masalah 1: Menggunakan portal Office 365 atau Azure Active Directory modul untuk Windows PowerShell untuk memulihkan akun pengguna yang dihapus

Untuk memulihkan akun pengguna yang dihapus secara manual, gunakan salah satu dari metode berikut ini:
  • Menggunakan portal Office 365 untuk memulihkan akun pengguna. Untuk informasi selengkapnya tentang cara melakukannya, lihat Hapus atau gulung balik pengguna.
  • Gunakan Azure Active Directory modul untuk Windows PowerShell untuk memulihkan akun pengguna. Untuk melakukannya, ketik salah satu dari perintah berikut, dan kemudian tekan Enter:
    • Restore-MsolUser -ObjectId <Guid> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>
    • Restore-MsolUser -UserPrincipalName <string> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>


      Dalam perintah ini, Konvensi berikut digunakan:
      • Parameter UserPrincipalName dan ObjectID mengidentifikasi objek pengguna akan dipulihkan.
      • AutoReconcileProxyConflictsparameter opsional dan digunakan dalam skenario di mana objek pengguna lain yang diberikan alamat penyuratan proksi objek pengguna target setelah alamat penyuratan yang telah dihapus.
      • NewUserPrincipalNameparameter opsional digunakan dalam skenario di mana objek pengguna lain yang diberikan objek pengguna target pimpinan (UPN nama pengguna) setelah UPN yang telah dihapus.

Penyelesaian masalah 2: Memulihkan akun pengguna yang telah dihapus karena sinkronisasi direktori (scoping) perubahan filter mengecualikan objek lokal pengguna direktori aktif

Untuk memulihkan akun pengguna dihapus, pastikan bahwa penyaringan sinkronisasi direktori ditetapkan sedemikian rupa lingkup mencakup objek yang akan dipulihkan. Untuk informasi lebih lanjut, kunjungi website Microsoft berikut:

Resolusi 3: Memulihkan akun pengguna yang telah dihapus karena objek lokal pengguna dihapus dari skema direktori aktif di tempat

Untuk memulihkan item yang dihapus dari skema direktori aktif di tempat, ikuti langkah-langkah berikut:
  1. Cobalah untuk memulihkan item yang dihapus dari direktori aktif tampungan daur ulang. Untuk informasi selengkapnya tentang cara melakukannya, kunjungi website Microsoft berikut:Catatan
    • Tampungan daur ulang direktori aktif tersedia hanya dengan tingkat fungsional Windows 2008 R2 atau versi yang lebih baru.
    • Untuk Active Directory tampungan daur ulang untuk dapat berguna dalam memulihkan item, ini harus diaktifkan sebelum item yang dihapus.
  2. Jika direktori aktif keranjang sampah tidak tersedia, atau jika objek yang dimaksud tidak lagi di tampungan daur ulang, cobalah untuk memulihkan item yang dihapus dengan menggunakan alat AdRestore. Untuk melakukannya, ikuti langkah-langkah berikut:
    1. Instal alat AdRestore dari situs web Microsoft TechNet berikut:
    2. Gunakan AdRestore bersama-sama dengan filter pencarian untuk menemukan objek lokal pengguna dihapus.

      Berikut ini adalah contoh cara menggunakan AdRestore untuk menghitung semua objek pengguna yang memiliki untai "UserA" nama mereka:
      C:\>adrestore.exe UserAAdRestore v1.1 by Mark RussinovichSysinternals - www.sysinternals.comEnumerating domain deleted objects:cn: MailboxADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3fdistinguishedName: CN=UserA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=comlastKnownParent: OU=OnPremises,DC=Domain,DC=comFound 1 item matching search criteria.
    3. Gunakan AdRestore bersama-sama dengan -r beralih untuk memulihkan objek pengguna.

      Berikut ini adalah contoh cara menggunakan AdRestore untuk memulihkan UserA objek:
      C:\>adrestore.exe Usera –rAdRestore v1.1 by Mark RussinovichSysinternals - www.sysinternals.comEnumerating domain deleted objects:cn: UserADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3fdistinguishedName: CN=MailboxA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=comlastKnownParent: OU=OnPremises,DC=Domain,DC=comDo you want to restore this object (y/n)? yRestore succeeded.Found 1 item matching search criteria.
    4. Mengaktifkan objek pengguna di direktori aktif. Ketika objek dipulihkan, dinonaktifkan pada awalnya. Oleh karena itu, Anda harus mengaktifkannya. Bila perlu, terlebih dulu me-reset sandi pengguna objek, dan kemudian mengaktifkan objek pengguna di komputer dan pengguna direktori aktif.

      Untuk mengaktifkan objek pengguna di komputer dan pengguna direktori aktif, ikuti langkah-langkah berikut:
      1. Pengguna direktori aktif dan komputer, klik kanan-atas pengguna, dan kemudian klik Reset sandi.
      2. Masukkan sandi baru pada sandi baru dan konfirmasi sandi kotak, dan kemudian klik OK.
      3. Klik kanan-atas pengguna, klik Account Aktifkan, dan kemudian klik OK.

        Tangkapan layar Aktifkan akun di direktori aktif
        Anda menerima pesan galat berikut ini. (Pesan galat ini diharapkan.)
        Windows tidak dapat mengaktifkan objek <MailboxName>karena:
        Tidak dapat memperbarui sandi. Nilai yang diberikan untuk sandi baru tidak memenuhi panjang, kompleksitas atau Riwayat persyaratan domain.</MailboxName>
        Setelah Anda menerima pesan galat ini, reset sandi pengguna direktori aktif dan komputer.
    5. Mengkonfigurasi nama log masuk pengguna. Nama log masuk pengguna (juga dikenal sebagai pimpinan Nama pengguna, atau UPN) tidak ditetapkan dari objek pengguna yang dipulihkan. Anda harus memperbarui nama log masuk pengguna, terutama apabila pengguna akun gabungan.

      Untuk mengkonfigurasi nama log masuk pengguna, ikuti langkah-langkah berikut:
      1. Pengguna direktori aktif dan komputer, klik kanan-atas pengguna, dan kemudian klik properti.
      2. Klik Account, masukkan nama di kotak nama log masuk pengguna , dan kemudian klik OK.
Akhirnya, jika Anda tidak dapat memulihkan akun pengguna dihapus melalui tampungan daur ulang direktori aktif atau dengan menggunakan alat AdRestore, lakukan pemulihan otoritatif objek dihapus pengguna di direktori aktif.

Peringatan Pastikan bahwa hanya pengguna objek yang Anda ingin memulihkan ditandai sebagai otoritatif. Objek Active Directory yang ditandai sebagai otoritatif dalam proses pemulihan dapat menyebabkan banyak masalah layanan direktori aktif.

Untuk informasi selengkapnya tentang cara melakukan pemulihan otoritatif objek direktori aktif, kunjungi website Microsoft berikut:
Peringatan Objek yang dipulihkan menggunakan resolusi 3 mungkin tidak memiliki Semua layanan atribut (Exchange Online, Skype untuk Bisnis Online (sebelumnya Lync Online), dan sebagainya) secara otomatis mendiami kembali setelah tindakan pemulihan. Gunakan alat manajemen layanan yang sesuai untuk terisi kembali atribut objek lokal sebelum interval sinkronisasi direktori berikutnya menjalar tindakan pemulihan awan direktori.

Misalnya, untuk objek yang sebelumnya Surat diaktifkan di Exchange Online, Anda dapat menggunakan Windows PowerShell cmdlets terisi kembali atribut Exchange Online. Dalam contoh berikut, objek User1 tersebar dengan Exchange Online atribut untuk penghuni contoso.onmicrosoft.com:
Enable-RemoteMailbox -Identity User1 -RemoteRoutingAddress user1@contoso.mail.onmicrosoft.com
Jika kondisi berikut ini benar, resolusi 3 tidak akan bekerja:
  • Memulihkan objek menggunakan tampungan daur ulang direktori aktif tidak opsi yang tersedia.
  • Memulihkan objek dengan menggunakan alat AdRestore bukan opsi yang tersedia.
  • Active Directory otoritatif memulihkan bukan opsi yang tersedia.
Dalam situasi ini, hubungi dukungan Office 365 untuk bantuan.
INFORMASI LEBIH LANJUT
Perubahan yang dibuat ke domain atau ke objek pengguna di Office 365 setelah akun pengguna yang akan dihapus dan sebelum pengguna akun dipulihkan dapat mempengaruhi pengguna mengalami setelah pemulihan. Setelah pengguna penghapusan dan sebelum pengguna pemulihan, kejadian berikut akan terjadi:
  • Pengguna baru dibuat yang menggunakan nilai ID pengguna yang unik yang sebelumnya ditetapkan ke pengguna yang dihapus.
  • Pengguna baru dibuat yang menggunakan nilai alamat penyuratan email yang unik yang sebelumnya ditetapkan ke pengguna yang dihapus.
Saat terjadi konflik ini, atribut konflik harus diperbarui untuk menghapus konflik sebelum pemulihan pengguna dapat diselesaikan. Jika konflik terjadi selama pemulihan pengguna, pengguna akan mengalami salah satu dari gejala berikut ketika pemulihan pengguna mencoba:
  • Windows PowerShell gulung balik salah satu pesan galat berikut:

    Pesan galat 1
    Pemulihan-MsolUser: Akun pengguna khusus tidak dapat dipulihkan karena galat berikut: kesalahan ketik UserPrincipalName
    Pesan galat 2
    Pemulihan-MsolUser: Akun pengguna khusus tidak dapat dipulihkan karena galat berikut: proxyAddress jenis galat
    Untuk memulihkan pengguna yang berada dalam keadaan ini, Anda dapat memperbaiki konflik dengan menggunakan parameter berikut ini saat Anda menjalankan Pemulihan MSOLUser cmdlet:
    • AutoReconcileProxyConflicts
    • NewUserPrincipalName
    Catatan Ketika Anda menggunakan AutoReconcileProxyConflicts parameter, ada konflik alamat penyuratan email dihapus dari pengguna yang dihapus sebelum Anda melanjutkan dengan proses pemulihan.
  • Portal Office 365 menampilkan pesan galat yang sama dalam bentuk Windows PowerShell galat negara yang telah disebutkan sebelumnya. Misalnya, Anda melihat berikut ini:

    Tangkapan layar halaman konflik Nama pengguna

    Untuk memulihkan pengguna yang berada dalam keadaan ini, lengkapi formulir, dan pastikan bahwa Anda menentukan bagaimana Anda ingin memperbaiki konflik.

Masih memerlukan bantuan? Buka Komunitas Office 365 situs web atau Forum Azure Active Directory .

Peringatan: Artikel ini telah diterjemahkan secara otomatis

Properti

ID Artikel: 2619308 - Tinjauan Terakhir: 08/13/2015 13:32:00 - Revisi: 20.0

Microsoft Office 365, Microsoft Intune, Microsoft Azure Cloud Services, Microsoft Azure Active Directory, Office 365 User and Domain Management

  • o365a o365e kbgraphxlink o365 o365022013 o365m kbgraphic kbmt KB2619308 KbMtid
Tanggapan
d=1&t=">