Konfigurasi tidak diperbarui dan dicatat kejadian ID 29181 di System Center Operations Manager

PENTING: Artikel ini diterjemahkan oleh perangkat lunak penerjemahan mesin Microsoft, dan mungkin telah diedit oleh Masyarakat Microsoft melalui teknologi CTF dan bukan oleh seorang penerjemah profesional. Microsoft menawarkan baik artikel yang diterjemahkan oleh manusia maupun artikel hasil editan terjemahan oleh mesin/komunitas, sehingga Anda dapat mengakses semua artikel di Sentra Pengetahuan yang kami miliki dalam berbagai bahasa. Namun artikel hasil editan mesin atau bahkan komunitas tidak selalu sempurna. Artikel ini dapat mengandung kesalahan dalam hal kosa kata, sintaksis atau tatabahasa, sangat mirip dengan penutur asing yang membuat kekeliruan ketika berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab atas ketidakakuratan, kesalahan atau kerugian apa pun akibat dari kekeliruan dalam penerjemahan isi atau penggunaannya oleh pelanggan kami. Microsoft juga akan senantiasa memperbarui perangkat lunak penerjemahan mesin dan alat untuk menyempurnakan Editan Hasil Penerjemahan Mesin.

Klik disini untuk melihat versi Inggris dari artikel ini: 3092452
Gejala
Di lingkungan Microsoft System Center yang memiliki banyak klien, perubahan konfigurasi tidak diperbarui di server manajemen. Selain itu, kejadian berikut berulang kali dicatat di log Operations Manager:


Nama log: Manajer operasional
Sumber: OpsMgr manajemen konfigurasi
ID Kejadian: 29181
Tingkat: kesalahan
Pengguna: N/A
Komputer: <server></server>

Keterangan: OpsMgr manajemen konfigurasi Layanan gagal untuk menjalankan mesin 'SnapshotSynchronization' item kerja karena exceptionMicrosoft.EnterpriseManagement.ManagementConfiguration.DataAccessLayer.DataAccessException berikut: Rekam Jepret transfer data operasi tulis gagal batch.

Penyebab
Masalah ini terjadi saat Layanan Manajemen konfigurasi gagal karena contoh transfer tidak dapat melakukan insert massal. Masalah ini biasanya terjadi ketika lingkungan memiliki banyak klien, seperti 2000 atau lebih.
Pemecahan masalah
Untuk memperbaiki masalah ini, ikuti langkah-langkah untuk mengubah setelan ukuran batch untuk Layanan Manajemen konfigurasi server manajemen:
  1. Membuat cadangan berkas Manager\Server\ConfigService.Config 2012\Operations pusat Files\System Program.
  2. Mengedit berkas ConfigService.config, dan kemudian mengubah pengaturan sebagai berikut:
    <Setting Name="SnapshotSyncManagedEntityBatchSize" Value="10000" /><Setting Name="SnapshotSyncRelationshipBatchSize" Value="10000" /><Setting Name="SnapshotSyncTypedManagedEntityBatchSize" Value="20000" />
  3. Mulai ulang layanan konfigurasi.
Informasi lebih lanjut
Untuk menentukan apakah Anda mengalami masalah ini, jalankan kueri SQL berikut ini terhadap OperationsManager database:
select * from cs.WorkItem where workitemname like '%snapshot%' order by StartedDateTimeUtc desc
Dalam skenario yang dijelaskan di bagian "gejala",workitemstateid selalu 10 (gagal) bukannya 20 (berhasil).

Peringatan: Artikel ini telah diterjemahkan secara otomatis

Properti

ID Artikel: 3092452 - Tinjauan Terakhir: 11/01/2015 20:25:00 - Revisi: 1.0

Microsoft System Center 2012 Operations Manager Service Pack 1, Microsoft System Center 2012 R2 Operations Manager

  • kbexpertiseadvanced kbsurveytest kbtshoot kbmt KB3092452 KbMtid
Tanggapan