Gejala
Saat berusaha mengkonfigurasi Microsoft Dynamics CRM untuk Microsoft Office Outlook, Anda menerima pesan galat berikut ini:
"Ada masalah berkomunikasi dengan server Microsoft Dynamics CRM. Server mungkin tidak tersedia. Coba lagi nanti. Jika masalah tetap ada, hubungi administrator sistem Anda.
Error.AspNetInstallPath.Exception di Microsoft.Crm.Application.Outlook.Config.ConfigInfo.GetAspDotNetPath()
di Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetLaptopClientRegistryValues()
di Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetConfigurationRegistryValuesAction()
di Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.Configure (IProgressEventHandler progressEventHandler)
di Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure (objek stateInfo)"
Penyebab
Galat ini dapat terjadi jika ada masalah dengan pemasangan Microsoft .NET Framework.
Pemecahan masalah
Opsi 1
Mengunduh dan menjalankan alat perbaikan Microsoft .NET Framework.
Opsi 2 (Windows 8 atau yang lebih baru)
Bongkar dan pasang .NET Framework.
Catatan: 2013 CRM untuk Outlook menggunakan .NET Framework 4 atau yang lebih baru. 2015 CRM untuk Outlook menggunakan .NET Framework 4,5 atau yang lebih baru. 2016 CRM untuk Outlook menggunakan .NET Framework 4.5.2 atau yang lebih baru.
1. masuk ke Control Panel dan kemudian buka Bongkar Program (program dan fitur).
2. Klik Windows Aktifkan atau nonaktifkan fitur.
3. Hapus pilihan .NET Framework dan kemudian klik OK.
4. Klik tutup.
5. Klik Windows Aktifkan atau nonaktifkan fitur.
6. mengaktifkan .NET Framework dan ASP.NET opsi di bawah ini.
7. Klik OK.
Opsi 3 (Windows 7)
Memperbaiki .NET Framework dalam Tambah/Hapus Program
1. masuk ke Control Panel dan kemudian buka Bongkar Program (program dan fitur).
2. Pilih Microsoft .NET Framework dan kemudian klik Bongkar/Ubah.
3. Pilih opsi perbaikan dan kemudian klik berikutnya.