In Access è possibile creare report di molti tipi, da quelli più semplici a quelli più complessi. Inizia pensando all'origine record del rapporto. Sia che il report sia un semplice elenco di record o un riepilogo raggruppato delle vendite per area, è opportuno decidere prima di tutto quali campi contengono i dati da visualizzare e quali tabelle o query contengano tali campi.
Dopo aver scelto l'origine record, in genere è più facile creare il rapporto usando la Creazione guidata report. La Creazione guidata Report consente di esaminare una serie di domande e quindi di creare un report in base alle risposte.
Per saperne di più
- Scegliere un'origine record
- Creare un report con lo strumento Report
- Creare un report con la Creazione guidata Report
- Creare etichette con la Creazione guidata Etichetta
- Creare un report con lo strumento Report vuoto
- Informazioni sulle sezioni dei report
- Informazioni sui controlli
- Ottimizzare il report in visualizzazione Layout
- Ottimizzare il report in visualizzazione Struttura
- Aggiungere controlli al report
- Salvare i dati
- Visualizzare, stampare o inviare il report come messaggio di posta elettronica
- Visualizzare il report
- Stampare il report
- Inviare il report come messaggio di posta elettronica
Scegliere un'origine record
Un report è costituito da informazioni estratte da tabelle o query e da informazioni archiviate nella struttura del report, come etichette, intestazioni ed elementi grafici. Le tabelle o query contenenti i dati sottostanti sono note anche come origine record del report. Se i campi da includere sono tutti presenti in un'unica tabella, usare quest'ultima come origine record. Se invece i campi sono contenuti in più tabelle, come origine record occorre usare una o più query. Le query potrebbero essere già presenti nel database o potrebbe essere necessario creare nuove query specifiche in base alle particolari esigenze del report.
Creare un report con lo strumento Report
Lo strumento Report è il modo più rapido per creare un report perché ne crea uno immediatamente senza richiedere ulteriori informazioni. Nel report vengono visualizzati tutti i campi della tabella o query sottostante. Potrebbe non creare il report finale desiderato, ma è utile per esaminare rapidamente i dati sottostanti. È quindi possibile salvare il rapporto e modificarlo in visualizzazione Layout o Struttura.
- Nel riquadro di spostamento fare clic sulla tabella o query su cui basare il report.
- Nel gruppo Report della scheda Crea fare clic su Report. Access crea il report e lo apre in visualizzazione Layout.
- Per ulteriori informazioni sulla visualizzazione e la stampa del report, vedere Visualizzare, stampare o inviare il report come messaggio e-mail.
Dopo aver visualizzato il report, è possibile salvarlo e quindi chiudere sia il report che la tabella o query sottostante usata come origine record. Alla successiva apertura del report, verranno visualizzati i dati più recenti disponibili nell'origine record.
Creare un report con la Creazione guidata Report
Per scegliere in modo più selettivo i campi da visualizzare nel report, si può usare la Creazione guidata report. È anche possibile specificare come raggruppare e ordinare i dati, nonché usare i campi di più tabelle o query, a condizione che le relazioni tra le tabelle e le query siano state specificate in precedenza.
- Nel gruppo Report della scheda Crea fare clic su Creazione guidata Report.
- Seguire le istruzioni visualizzate nelle pagine della Creazione guidata Report. Nell'ultima pagina fare clic su Fine. Quando si visualizza in anteprima il report, si vedrà l'aspetto stampato. Si può anche fare zoom avanti per ingrandire e vedere meglio i dettagli. Per ulteriori informazioni sulla visualizzazione e la stampa del report, vedere Visualizzare, stampare o inviare il report come messaggio e-mail.
Nota
Se si vogliono includere nel report i campi da più tabelle e query, non fare clic su Avanti o Fine dopo aver selezionato i campi della prima tabella o query nella prima pagina della Creazione guidata Report. Ripetere invece i passaggi per selezionare una tabella o una query e quindi fare clic su ogni campo aggiuntivo da includere nel report. Fare quindi clic su Avanti o su Fine per continuare.
Creare etichette con la Creazione guidata Etichetta
Usare la Creazione guidata Etichetta per creare in modo semplice e rapido etichette di varie dimensioni standard.
- Nel riquadro di spostamento fare doppio clic sulla tabella o query che costituirà l'origine record per le etichette per aprirla.
- Nel gruppo Report della scheda Crea fare clic su Etichette.
- Seguire le istruzioni visualizzate nelle pagine della Creazione guidata Etichetta. Nell'ultima pagina fare clic su Fine.
Access visualizza le etichette in anteprima di stampa in modo che sia possibile vedere l'aspetto che avranno una volta stampate. È possibile usare il dispositivo di scorrimento sulla barra di stato di Access per ingrandire i dettagli. Per ulteriori informazioni sulla visualizzazione e la stampa del report, vedere Visualizzare, stampare o inviare il report come messaggio e-mail.
Nota
La visualizzazione Anteprima di stampa è l'unica che consente di vedere più colonne perché le altre visualizzazioni mostrano i dati in una singola colonna.
Creare un report con lo strumento Report vuoto
Se non si vuole usare lo strumento Report o la Creazione guidata report, è possibile usare lo strumento Report vuoto per creare un report da zero. Questo strumento consente di creare un report in modo rapido, in particolare se si prevede di inserire solo pochi campi.
- Nel gruppo Report della scheda Crea fare clic su Report vuoto. In visualizzazione Layout verrà visualizzato un report vuoto e il riquadro Elenco campi sul lato destro della finestra di Access.
- Nel riquadro Elenco campi fare clic sul segno più accanto alla tabella o alle tabelle che contengono i campi che si desidera visualizzare nel report.
- Trascinare i campi nel rapporto uno alla volta oppure tenere premuto CTRL e selezionare più campi. Trascinali quindi contemporaneamente nel report.
- Usare gli strumenti disponibili nel gruppo Intestazione/piè di pagina della scheda Struttura report per aggiungere al report un logo, un titolo, i numeri di pagina oppure la data e l'ora.
Informazioni sulle sezioni dei report
In Access, la struttura di un report è divisa in sezioni. È possibile visualizzare il report in visualizzazione Struttura per vedere le relative sezioni. Per creare report utili è necessario capire il funzionamento di ogni sezione. Ad esempio, la sezione in cui si decide di inserire un controllo calcolato definisce la modalità di calcolo dei risultati da parte di Access. Di seguito è riportato un riepilogo dei tipi di sezione e del relativo utilizzo:
Intestazione rapporto: questa sezione viene stampata una sola volta, all'inizio del rapporto. Usalo per informazioni che potrebbero normalmente apparire su una copertina, come un logo, un titolo o una data. Quando si inserisce un controllo calcolato che usa la
Sumfunzione di aggregazione nell'intestazione del report, la somma calcolata è relativa all'intero report. L'intestazione report viene stampata prima dell'intestazione pagina.Intestazione di pagina: questa sezione viene stampata nella parte superiore di ogni pagina. Ad esempio, usare un'intestazione di pagina per ripetere il titolo del report su ogni pagina.
Intestazione gruppo: questa sezione viene stampata all'inizio di ogni nuovo gruppo di record. Usarlo per stampare il nome del gruppo. Ad esempio, in un report raggruppato per prodotto, usare l'intestazione del gruppo per stampare il nome del prodotto. Quando si inserisce un controllo calcolato che usa la
Sumfunzione di aggregazione nell'intestazione del gruppo, la somma è per il gruppo corrente.Dettagli: questa sezione viene stampata una volta per ogni riga dell'origine record. Inserire qui i controlli che costituiscono il corpo principale del report.
Piè di pagina gruppo: questa sezione viene stampata alla fine di ogni gruppo di record. Usarlo per stampare informazioni di riepilogo per un gruppo.
Piè di pagina: questa sezione viene stampata alla fine di ogni pagina. Usarlo per stampare i numeri di pagina o le informazioni per pagina.
Piè di pagina report: questa sezione viene stampata una sola volta, alla fine del report. Usarlo per stampare i totali dei report o altre informazioni di riepilogo per l'intero report.
Nota
In visualizzazione Struttura il piè di pagina report è posizionato sotto il piè di pagina. Tuttavia, quando si esegue la stampa o l'anteprima del report, il piè di pagina report viene riportato sopra il piè di pagina, subito dopo l'ultimo piè di pagina gruppo oppure l'ultima riga della sezione Corpo nella pagina finale.
Informazioni sui controlli
I controlli sono oggetti che visualizzano dati, eseguono azioni e permettono di visualizzare e usare informazioni che migliorano l'interfaccia utente, ad esempio etichette e immagini. Access supporta tre tipi di controlli: associati, non associati e calcolati.
- Controllo associato: controllo la cui origine dati è un campo di una tabella o di una query. I controlli associati consentono di visualizzare i valori dei campi del database. I valori possono essere di testo, di data, numerici, valori Sì/No, immagini o grafici. Una casella di testo è il tipo più comune di controllo associato. Ad esempio, una casella di testo in una maschera che visualizza il cognome di un dipendente potrebbe recuperare questa informazione dal campo Cognome della tabella Dipendenti.
- Controllo non associato: controllo che non dispone di un'origine dati, ad esempio un campo o un'espressione. I controlli non associati consentono di visualizzare informazioni, righe, rettangoli e immagini. Un'etichetta contenente il titolo di un report è un esempio di controllo non associato.
-
Controllo calcolato: controllo la cui origine dati è un'espressione anziché un campo. Per specificare il valore da inserire nel controllo, è possibile definire un'espressione come origine dati per il controllo. Le espressioni sono una combinazione di operatori quali
=e+, nomi di controlli, nomi di campi, funzioni che restituiscono un singolo valore e valori costanti. L'espressione=[Unit Price] * 0.75consente ad esempio di calcolare il prezzo di un articolo con uno sconto del 25% moltiplicando il valore del campo Prezzo unitario per un valore costante (0.75). Un'espressione può usare i dati inclusi in un campo della tabella o della query sottostante del report oppure i dati inclusi in un altro controllo del report.
Quando si crea un report, può risultare più pratico aggiungere e disporre prima i controlli associati, in particolare se costituiscono la maggior parte dei controlli del report. È quindi possibile aggiungere i controlli non associati e calcolati che completano la progettazione utilizzando gli strumenti disponibili nel gruppo Controlli della scheda Struttura report .
Per associare un controllo a un campo, identificare il campo dal quale il controllo deve recuperare i dati. È possibile creare un controllo associato al campo selezionato trascinando il campo dal riquadro Elenco campi al report. Il riquadro Elenco campi visualizza i campi della tabella o query sottostante del report. Per visualizzare il riquadro Elenco campi, nel gruppo Strumenti della scheda Struttura report fare clic su Aggiungi campi esistenti.
In alternativa, è possibile associare un campo a un controllo digitando il nome del campo nel controllo stesso o nella casella relativa ControlSource al valore nella finestra delle proprietà del controllo. La finestra delle proprietà definisce le caratteristiche del controllo, ad esempio il nome, l'origine dati e il formato.
L'uso del riquadro Elenco campi rappresenta il modo migliore per creare un controllo associato, per due motivi:
- Un controllo associato ha un'etichetta associata e l'etichetta usa il nome del campo per impostazione predefinita o la didascalia definita per quel campo nella tabella o nella query sottostante. Questo significa che non è necessario digitare la didascalia manualmente.
- Un controllo associato eredita molte delle impostazioni del campo nella tabella o query sottostante, ad esempio ,
FormatDecimalPlaceseInputMaskle proprietà. Per questo motivo, le impostazioni delle proprietà rimangono invariate ogni volta che si crea un controllo associato a tale campo.
Se è già stato creato un controllo non associato e si desidera associarlo a un campo, impostare la proprietà del ControlSource controllo sul nome del campo. Per informazioni dettagliate sulla ControlSource proprietà, cercare nella Guida .ControlSource
Ottimizzare il report in visualizzazione Layout
Dopo aver creato un report, è possibile ottimizzarne con facilità la struttura lavorando in visualizzazione Layout. Usando i dati del report effettivo come guida, è possibile modificare le larghezze di colonna, ridisporre le colonne e aggiungere livelli di raggruppamento e totali. È anche possibile posizionare nuovi campi nel report e impostare le proprietà del report e dei relativi controlli.
Per passare alla visualizzazione Layout, fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout.
Il report viene aperto in visualizzazione Layout.
È possibile usare la finestra delle proprietà per modificare le proprietà del report e dei relativi controlli e sezioni. Per visualizzare la finestra delle proprietà, premere F4.
È possibile usare il riquadro Elenco campi per aggiungere campi dalla tabella o query sottostante alla struttura del report. Per visualizzare il riquadro Elenco campi, eseguire una delle operazioni seguenti:
- Nel gruppo Strumenti della scheda Progettazione layout report fare clic su Aggiungi campi esistenti.
- Premere ALT+F8.
È quindi possibile aggiungere i campi trascinandoli dal riquadro Elenco campi al report.
Ottimizzare il report in visualizzazione Struttura
Si può ottimizzare la struttura del report anche lavorando in visualizzazione Struttura. È possibile aggiungere nuovi controlli e campi al report aggiungendoli alla griglia di struttura. Tramite la finestra delle proprietà è possibile accedere a un gran numero di proprietà che è possibile impostare per personalizzare il report.
Per passare alla visualizzazione Struttura, fare clic con il pulsante destro del mouse sul nome del report nel riquadro di spostamento e scegliere Visualizzazione Struttura.
Il report viene aperto in visualizzazione Struttura.
È possibile usare la finestra delle proprietà per modificare le proprietà del report e dei controlli e sezioni che contiene. Per visualizzare la finestra delle proprietà, premere F4.
È possibile usare il riquadro Elenco campi per aggiungere campi dalla tabella o query sottostante alla struttura del report. Per visualizzare il riquadro Elenco campi, eseguire una delle operazioni seguenti:
- Nel gruppo Strumenti della scheda Struttura report fare clic su Aggiungi campi esistenti.
- Premere ALT+F8.
È quindi possibile aggiungere i campi trascinandoli dal riquadro Elenco campi al report.
Aggiungere campi dal riquadro Elenco campi
- Per aggiungere un singolo campo, trascinarlo dal riquadro Elenco campi nella sezione in cui lo si vuole visualizzare nel report.
- Per aggiungere contemporaneamente diversi campi, tenere premuto CTRL e fare clic sui campi desiderati. Quindi, trascinare i campi selezionati nel report.
Quando si rilasciano i campi in una sezione di report, Access crea un controllo casella di testo associato per ogni campo e inserisce automaticamente un controllo etichetta accanto a ogni campo.
Aggiungere controlli al report
Alcuni controlli vengono creati automaticamente, ad esempio il controllo casella di testo associato che viene creato quando si aggiunge un campo dal riquadro Elenco campi al report. Molti altri controlli possono essere creati in visualizzazione Struttura usando gli strumenti disponibili nel gruppo Controlli della scheda Struttura report .
Determinare il nome di uno strumento
- Posizionare il puntatore del mouse sullo strumento. Viene visualizzato il nome dello strumento.
Creare un controllo con gli strumenti disponibili nel gruppo Controlli
Fare clic sullo strumento corrispondente al tipo di controllo che si vuole aggiungere. Ad esempio, per creare una casella di controllo, fare clic sullo strumento Casella
di controllo.Fare clic nella griglia di struttura del report nel punto in cui si vuole posizionare l'angolo superiore sinistro del controllo. Fare clic una volta per creare un controllo con dimensioni predefinite oppure fare clic sullo strumento e quindi trascinare il mouse nella griglia di struttura del report per creare un controllo con le dimensioni desiderate.
Se al primo tentativo non si riesce a posizionare il controllo perfettamente, è possibile spostarlo usando la procedura seguente:
- Fare clic sul controllo per selezionarlo.
- Posizionare il puntatore del mouse sul bordo del controllo finché non assume la forma di una freccia a quattro punte
. - Trascinare il controllo nella posizione desiderata.
Questa procedura crea un controllo non associato. Se il controllo può visualizzare dati, ad esempio una casella di testo o una casella di controllo, è necessario immettere un nome di campo o un'espressione ControlSource nella proprietà per poter visualizzare i dati. Per altre informazioni, vedere Informazioni sui controlli.
Visualizzare la finestra delle proprietà
Per visualizzare la finestra delle proprietà in visualizzazione Struttura, eseguire una delle operazioni seguenti:
- Nel gruppo Strumenti della scheda Struttura report fare clic su Finestra delle proprietà.
- Premere F4.
Salvare i dati
Dopo aver salvato la struttura del report, sarà possibile eseguire il report quando necessario. La struttura del report non cambia, ma ogni volta che il report viene stampato o visualizzato vengono recuperati dati aggiornati. Nel momento in cui le esigenze relative ai report dovessero cambiare, sarà possibile modificare la struttura del report o creare un nuovo report simile basato sull'originale.
Salvare la struttura del report
- Fare clic su File>Salva o premere Ctrl+S. In alternativa, fare clic su Salva nella barra di accesso rapido.
- Se al report non è stato assegnato un titolo, digitare un nome nella casella Nome report e quindi fare clic su OK.
Salvare la struttura del report con un nuovo nome
- Fare clic su File>Save AsSave Object> As.
- Nella finestra di dialogo Salva con nome digitare un nome nella casella Salva rapporto in per il nuovo rapporto e quindi fare clic su OK.
Visualizzare, stampare o inviare il report come messaggio di posta elettronica
Dopo aver salvato la struttura del report, è possibile riutilizzarla più volte. La struttura del report non cambia, ma ogni volta che il report viene visualizzato o stampato verranno recuperati i dati aggiornati. Nel momento in cui le esigenze relative ai report dovessero cambiare, sarà possibile modificare la struttura del report o creare un nuovo report simile basato sull'originale.
Visualizzare il report
Esistono diversi modi per visualizzare i report. Il metodo da scegliere dipende da come verranno usati il report e i relativi dati:
- Se si desidera modificare temporaneamente i dati visualizzati nel report prima della stampa o se si desidera copiare i dati dal report agli Appunti, utilizzare la visualizzazione Report.
- Se si desidera modificare la struttura del report durante la visualizzazione dei dati, utilizzare la visualizzazione Layout.
- Se si vuole visualizzare l'aspetto del report una volta stampato, usare Anteprima di stampa.
Nota
Se il report è formattato con più colonne, il layout a colonne sarà visibile solo in Anteprima di stampa. Nelle visualizzazioni Layout e Report il report viene visualizzato con una sola colonna.
Aprire il report in visualizzazione Report
La visualizzazione Report è la visualizzazione predefinita che viene usata quando si fa doppio clic su un report nel riquadro di spostamento. Se il report non è aperto, fare doppio clic su di esso nel riquadro di spostamento per aprirlo in visualizzazione Report.
Se il report è già aperto, fare clic con il pulsante destro del mouse sul nome del report nel riquadro di spostamento e scegliere Visualizzazione report.
Usare i dati in visualizzazione Report
In visualizzazione Report è possibile selezionare il testo e copiarlo negli Appunti. Per selezionare intere righe, fare clic e trascinare il puntatore del mouse lungo il margine accanto alle righe da selezionare. Per copiare le righe selezionate negli Appunti, eseguire una delle operazioni seguenti:
- Nel gruppo Appunti della scheda Home fare clic su Copia.
- Fare clic con il pulsante destro del mouse sulle righe selezionate e scegliere Copia.
- Premere Ctrl+C.
Usare i filtri per visualizzare solo determinate righe
È possibile applicare filtri direttamente al report senza uscire dalla visualizzazione Report. Ad esempio, se è presente una colonna "Paese" e si vogliono visualizzare solo le righe in cui il paese è "Canada", seguire questa procedura:
- Trovare la parola "Canada" nel report e fare clic con il pulsante destro del mouse su di essa.
- Fare clic su Uguale a "Canada".
Access crea e applica il filtro.
Attivare e disattivare un filtro
Per passare dalla visualizzazione filtrata a quella non filtrata, è possibile fare clic su Attiva/disattiva filtro nel gruppo Ordina e filtra della scheda Home. In questo modo il filtro non viene rimosso, ma solo attivato e disattivato.
Rimuovere un filtro
- Fare clic sul campo da cui si vuole rimuovere il filtro.
- Fare clic su Cancella filtro da
. (nome campo è il segnaposto per il campo effettivo).
Dopo la rimozione di un filtro, non è possibile riattivarlo con il comando Attiva/disattiva filtro. Se necessario, il filtro deve essere creato nuovamente.
Nota
Se si applica un filtro a un report e quindi si salva e si chiude il report, il filtro verrà salvato con il report. Alla successiva apertura del report, però, il filtro non viene applicato automaticamente. Per riapplicare il filtro, nel gruppo Ordina e filtra della scheda Home fare clic su Attiva/disattiva filtro.
Visualizzare il report in Anteprima di stampa
Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Anteprima di stampa dal menu di scelta rapida.
Per visualizzare le pagine di un report in modo sequenziale o passare a una pagina specifica del report, è possibile usare i pulsanti di spostamento.
- Fare clic per visualizzare la prima pagina.
- Fare clic per visualizzare la pagina precedente.
- Fare clic per visualizzare la pagina successiva.
- Fare clic per visualizzare l'ultima pagina.
- Digitare un numero di pagina in questa casella e quindi premere INVIO per passare a una pagina specifica.
In Anteprima di stampa è possibile ingrandire la visualizzazione del report per esaminarne i dettagli oppure ridurla per verificare il corretto posizionamento dei dati sulla pagina. Verificare che il cursore sia posizionato sul report e fare clic una volta. Per annullare l'ingrandimento, fare di nuovo clic. Si può anche usare il controllo Zoom sulla barra di stato di Access per fare ulteriormente zoom avanti o indietro.
Per chiudere l'anteprima di stampa, eseguire una delle operazioni seguenti:
- Nella scheda Anteprima di stampa fare clic su Chiudi anteprima di stampa.
- Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout o Visualizzazione Struttura dal menu di scelta rapida.
Suggerimento
Dopo aver visualizzato l'anteprima del report, è possibile esportare i risultati in Word, Excel o in molte altre applicazioni di Office. Nel gruppo Esporta della scheda Dati esterni fare clic sul pulsante corrispondente al formato desiderato e quindi seguire le istruzioni.
Stampare il report
È possibile stampare un report aperto in qualsiasi visualizzazione e anche un report chiuso. Prima di stampare, verificare le impostazioni di pagina, come i margini o l'orientamento della pagina. Access salva le impostazioni della pagina con il report, quindi è sufficiente configurarle una sola volta. Le impostazioni possono comunque essere modificate in seguito, se necessario.
Modificare le impostazioni della pagina
- Aprire il report in Anteprima di stampa. È possibile modificare le impostazioni di pagina in qualsiasi visualizzazione, ma Anteprima di stampa è la scelta migliore perché permette di vedere subito l'effetto delle modifiche.
- Nei gruppi Layout di pagina e Dimensione pagina della scheda Anteprima di stampa fare clic su Verticale
o Orizzontale
per impostare l'orientamento della pagina, Dimensione
per impostare il formato della carta, Margini
per regolare i margini e così via. - Dopo aver apportato una modifica, usare i pulsanti di spostamento per visualizzare altre pagine e verificare di non avere creato problemi di formattazione nelle pagine successive.
Inviare il report a una stampante
- Aprire il report in qualsiasi visualizzazione o selezionarlo nel riquadro di spostamento.
- Fare clic su File>Stampa>Stampa. Access visualizza la finestra di dialogo Stampa.
- Immettere le opzioni preferite riguardo la stampante, l'intervallo di stampa e il numero di copie.
- Fare clic su OK.
Inviare il report come messaggio di posta elettronica
È possibile inviare il report ai destinatari come messaggio di posta elettronica invece di stampare una copia cartacea:
- Nel riquadro di spostamento fare clic sul report per selezionarlo. Nel gruppo Esporta della scheda Dati esterni fare clic su Posta elettronica.
- Nell'elenco Selezionare un formato di output della finestra di dialogo Invia oggetto come fare clic sul formato di file da usare.
- Completare le eventuali finestre di dialogo rimanenti.
- Nell'applicazione di posta elettronica digitare i dettagli del messaggio e inviarlo.